New-ish Linux User Having Some Issues After new Install

So I just installed Garuda Linux (KDE Dr460nized Gaming Edition) on my system a few days ago and I'm encountering a number of odd behaviors and issues that I haven't been able to figure out what is going on.

System Details
System:    Kernel: 5.11.5-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.1  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=5b6bfa08-616c-45d9-9809-290e29717447  
rw rootflags=subvol=@ quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.21.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM  
Distro: Garuda Linux  
Machine:   Type: Desktop System: ASUS product: All Series v: N/A serial: <filter>  
Mobo: ASUSTeK model: RAMPAGE V EXTREME v: Rev 1.xx serial: <filter> UEFI: American Megatrends  
v: 3701 date: 03/31/2017  
CPU:       Info: 6-Core model: Intel Core i7-5820K bits: 64 type: MT MCP arch: Haswell family: 6  
model-id: 3F (63) stepping: 2 microcode: 44 L2 cache: 15 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 79161  
Speed: 3598 MHz min/max: 1200/3600 MHz Core speeds (MHz): 1: 3598 2: 1251 3: 3597 4: 2919  
5: 1356 6: 1379 7: 3598 8: 3598 9: 3504 10: 3518 11: 3591 12: 3598  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported  
Type: l1tf mitigation: PTE Inversion  
Type: mds mitigation: Clear CPU buffers; SMT vulnerable  
Type: meltdown mitigation: PTI  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling  
Type: srbds status: Not affected  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: NVIDIA GM200 [GeForce GTX 980 Ti] vendor: Gigabyte driver: nouveau v: kernel  
bus ID: 01:00.0 chip ID: 10de:17c8 class ID: 0300  
Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: nouveau  
unloaded: modesetting alternate: fbdev,nv,vesa display ID: :0 screens: 1  
Screen-1: 0 s-res: 5760x1200 s-dpi: 96 s-size: 1524x317mm (60.0x12.5") s-diag: 1557mm (61.3")  
Monitor-1: DP-1 res: 1920x1200 hz: 60 dpi: 94 size: 519x320mm (20.4x12.6") diag: 610mm (24")  
Monitor-2: HDMI-1 res: 1920x1080 hz: 60 dpi: 82 size: 598x336mm (23.5x13.2") diag: 686mm (27")  
Monitor-3: DP-3 res: 1920x1080 hz: 120 dpi: 82 size: 598x336mm (23.5x13.2") diag: 686mm (27")  
OpenGL: renderer: NV120 v: 4.3 Mesa 20.3.4 direct render: Yes  
Audio:     Device-1: Intel C610/X99 series HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel  
bus ID: 00:1b.0 chip ID: 8086:8d20 class ID: 0403  
Device-2: NVIDIA GM200 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel  
bus ID: 01:00.1 chip ID: 10de:0fb0 class ID: 0403  
Device-3: Micronas BLUE USB Audio 2.0 type: USB driver: snd-usb-audio bus ID: 3-10.4:8  
chip ID: 074d:0002 class ID: fe01 serial: <filter>  
Sound Server: ALSA v: k5.11.5-zen1-1-zen  
Network:   Device-1: Intel Ethernet I218-V vendor: ASUSTeK driver: e1000e v: kernel port: f000  
bus ID: 00:19.0 chip ID: 8086:15a1 class ID: 0200  
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>  
Device-2: Broadcom BCM4360 802.11ac Wireless Network Adapter vendor: ASUSTeK driver: wl  
v: kernel port: e000 bus ID: 05:00.0 chip ID: 14e4:43a0 class ID: 0280  
IF: wlp5s0 state: dormant mac: <filter>  
Bluetooth: Device-1: ASUSTek Broadcom BCM20702 Single-Chip Bluetooth 4.0 + LE type: USB driver: btusb  
v: 0.8 bus ID: 3-6:2 chip ID: 0b05:180a class ID: fe01 serial: <filter>  
Message: Required tool hciconfig not installed. Check --recommends  
Drives:    Local Storage: total: 9.1 TiB used: 1.39 TiB (15.3%)  
SMART Message: Unable to run smartctl. Root privileges required.  
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Sabrent model: Rocket Q size: 931.51 GiB block size:  
physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter>  
rev: RKT30Q.1 temp: 28.9 C scheme: GPT  
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD1001FALS-75J7B0 size: 931.51 GiB  
block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s serial: <filter> rev: 0K05  
scheme: MBR  
ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST95005620AS size: 465.76 GiB block size:  
physical: 512 B logical: 512 B speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: SD28  
scheme: MBR  
ID-4: /dev/sdc maj-min: 8:32 vendor: HGST (Hitachi) model: HUH728060ALE600 size: 5.46 TiB  
block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter>  
rev: T514 scheme: GPT  
ID-5: /dev/sdd maj-min: 8:48 vendor: Seagate model: ST95005620AS size: 465.76 GiB block size:  
physical: 512 B logical: 512 B speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: SD28  
scheme: GPT  
ID-6: /dev/sde maj-min: 8:64 type: USB vendor: Samsung model: Portable SSD T5 size: 931.51 GiB  
block size: physical: 512 B logical: 512 B rotation: SSD serial: <filter> scheme: MBR  
Partition: ID-1: / raw size: 79.62 GiB size: 79.62 GiB (100.00%) used: 32.91 GiB (41.3%) fs: btrfs  
dev: /dev/nvme0n1p2 maj-min: 259:2  
ID-2: /boot/efi raw size: 100 MiB size: 96 MiB (96.00%) used: 566 KiB (0.6%) fs: vfat  
dev: /dev/nvme0n1p3 maj-min: 259:3  
ID-3: /home raw size: 79.62 GiB size: 79.62 GiB (100.00%) used: 32.91 GiB (41.3%) fs: btrfs  
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw size: 79.62 GiB size: 79.62 GiB (100.00%) used: 32.91 GiB (41.3%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw size: 79.62 GiB size: 79.62 GiB (100.00%) used: 32.91 GiB (41.3%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100)
ID-1: swap-1 type: zram size: 1.3 GiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-2: swap-2 type: zram size: 1.3 GiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-3: swap-3 type: zram size: 1.3 GiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-4: swap-4 type: zram size: 1.3 GiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram3
ID-5: swap-5 type: zram size: 1.3 GiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram4
ID-6: swap-6 type: zram size: 1.3 GiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram5
ID-7: swap-7 type: zram size: 1.3 GiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram6
ID-8: swap-8 type: zram size: 1.3 GiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram7
ID-9: swap-9 type: zram size: 1.3 GiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram8
ID-10: swap-10 type: zram size: 1.3 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram9
ID-11: swap-11 type: zram size: 1.3 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram10
ID-12: swap-12 type: zram size: 1.3 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram11
ID-13: swap-13 type: partition size: 4.88 GiB used: 0 KiB (0.0%) priority: 1024 dev: /dev/sdc3
maj-min: 8:35
Sensors:   System Temperatures: cpu: 39.0 C mobo: N/A gpu: nouveau temp: 42.0 C
Fan Speeds (RPM): N/A gpu: nouveau fan: 1825
Info:      Processes: 379 Uptime: 26m wakeups: 0 Memory: 15.54 GiB used: 4.37 GiB (28.1%) Init: systemd
v: 247 Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 2079 lib: 586 Shell: fish
v: 3.1.2 running in: konsole inxi: 3.3.01

Please forgive me, I'm new to linux, only having dabbled in it here or there. But I have been toying around with computers and building my own for over 20 years so I have a decent understanding of hardware and of the Windows and Mac world. But I'm fairly lost when it comes to Linux stuff, but I am trying to get the foundational stuff under my belt to better navigate the system to solve my issues. And that is one of my main issues with Linux is, is not knowing how to find the pertinent information to troubleshoot/solve a problem. But, I digress.

ISSUE 1 [Video Card Driver Install Issues]:
The first issue I'm having is I was trying to install the official Nvidia GPU drivers (which I assume is the way to go, official drivers being best is my assumption). But when I try to use the tool in the hardware configuration I get the following error:

:: python-pyxdg and python-xdg are in conflict. Remove python-xdg? [y/N] error: unresolvable package conflicts detected

error: failed to prepare transaction (conflicting dependencies)

:: python-pyxdg and python-xdg are in conflict

Error: pacman failed!

Error: script failed!

Clearly, I understand that there is a package conflict, but I don't know how to solve it. I checked the python-xdg package and Deluge, Oversteer, and speech-dispatcher are dependent on it, but I couldn't figure out if python-pyxdg can replace the first package for them.

So my question is how do I resolve this? Again assuming I need to if installing official Nvidia drivers is a bad idea for whatever reason. I'm aware of some issues with their drivers and gaming on Linux, but I don't know to what extent exactly. Also, Are there tools, websites, etc. that can help me more effectively solve this issue, like to check if one package can replace another for specific software?

I checked other posts about this problem. The first one I read on the forums here suggested updating packages using sudo pacman -Syu, and I guess trying to run the hardware configuration installation again (it wasn't clear, but I think it was implied). But that didn't work. I get the same error from the hardware configuration output.

The next suggestions I found were using pacman to remove the package directly or remove the software depending on that package. One suggestion was to do sudo pacman -Rc python-xdg and the other was to sudo pacman -Rns python-xdg. Now I tried to look into these to better understand what they are doing and what I found, that most of you probably know, is sudo pacman -Rns ******, and from what I gather sudo pacman -Rc ****** is fairly similar, completely removes the package and all dependancies, regardless of what other software is dependant on it. Is that safe/wise? I'm guessing this can potentially break stuff and how do I check to make sure it isn't going to. And what are my options if I did remove something that I needed. I'm trying to figure out what things are "safe" to mess up and what things are not safe to mess up.


ISSUE 2[Steam Game Launching Issues]:
Part of the reason I chose this distro, aside from liking its aesthetics, is that I'm a big-time gamer and saw that there are a lot of gaming packages included in the distro. So I had all of my games when I was running windows 10, saved on a partition on my NVMe drive, with my OS installed on another partition on that drive. About 75+% of the games are from Steam.

I made sure steam was setup with Proton setup and configured for all games. But I've only been able to get one game (Slay The Spire) to launch successfully. I've tried a number of other games that ProtonDB indicates should run with little to no issues (Hades, Risk of Rain2), but they all refuse to launch. They've updated with the Photon patch or whatever it is exactly, I click start, start changes to playing with whatever launch windows pop up (choosing game version to launch, such as x64, x32, or Vulkan). But after making a selection a few seconds later the play button returns to normal as if the game isn't running.

I'm not certain how to even start to troubleshoot the issue, again, I'm not super familiar with the operating principles of Linux, which I know would easily help me if I understood that better, but that is what I'm hoping on picking up. But can anyone give me any insight on what is causing the issue and how to fix it or at least how to try to fix it?


ISSUE 3["Missing" Package Manager]:
I was trying to follow the fresh install guide from the Wiki. One of the steps was to set up the package manager to remove unneeded packages as programs are removed, the first step is to open Pacman. But therein lies the issue, I can't find Pacman in my launcher. I searched through all the programs listed, I searched in the search bar, but no Pacman...what am I missing?

I realize now that pacman is generally a terminal app, but my confusion stems from the "First Steps: Removing Bloatware" on the wiki. The very first step is:

"Open up Pamac via its startmenu shortcut and change some settings related to how orphaned packages are being treated by Pamac. These are then being removed automatically instead of remaining installed."


ISSUE 4 [Deluge won't Launch]:
With the help of the install assistant, I installed a number of programs, Deluge being one of them. But, I can't get it to launch. When I try to open it from the application menu it acts like it's going to launch and then nothing happens.

How can I figure out what is going on and how to fix it.


ISSUE 5 (and the last of my initial issues)[Dr460nized Layout Broken]:
I went into Latte to try to see what options I had for customization, and I was looking for how to change the window close, resize, and minimize buttons to always be with the window and not mount on the desktop menu bar. But what caught me off guard was at the bottom of the Latte Dock settings is a red box that says:

Layout Dr460nized is broken! Please remove it to improve stability.

I like the layout for the most part and don't want to trash it, but don't have any idea how to fix it and that is what I'm looking for help with for this issue.

Thanks in advance.

Hello, I'm no expert but I'll say a few things about your posts:

Issue 1: I didn't see anything about sudo in your comments. Are you running the driver install as sudo (root privileged user). For further advice on this issue, you will need to provide more information as to where you downloaded the package from and the exact steps you took. Also any troubleshooting you may have done already. There is the "Hardware Configuration" tool that may provide more information or let you know what drivers you have installed. I think it has the same info as running the sudo mhwd -li --pcicommand. You may need to post your inxi -Fxxxaz also just in case.

Issue 2: I'm not sure on this one. I don't run games on Linux currently. However, I would leave that one for last because if you are having driver issues, it may be related.

Issue 3: If you look for "Add/Remove Software" in your menu, that is the GUI packet manager that runs pacman in the background. Pacman is a CLI tool only and it has GUI interfaces. A note about Linux in general, most tools are CLI based first. All of the commands I mentioned above are CLI. Garuda developers have done a great job at integrating GUI apps in to the interface but for the dirty business, you will need to go in to the CLI a lot of times. It is similar in Windows how a lot of configurations are not available unless you go in to the registry. I would recommend finding a terminal text editor that you like, there are plenty (shot-out to nvim but I don't recommend for beginner use). When you have to pop open the hood on Linux, it usually involves the CLI.

Issue 4: Not sure, Deluge is a gtk3 app which is a different window manager than KDE. It should be supported but there may be some extra libraries that you will need to install to get it to work. It may not look as good as the native KDE GUI apps.

Issue 5: I think this is set in the Appearance or Window Decorations settings. You would probably need to change themes to change the behavior. Also I don't want to mess up my desktop so I'm not going to mess with it but you could right click on the panel and click Edit Dock. Move pointer over to the App Menu section and a pop up with a line circle settings should come up. You may be able to modify how the app menu behaves there. I turned a few things on/off but nothing changed. Maybe you need to log out and back in to take effect. Not sure why it says it is broken.

On a different note, Linux is like working on a hot-rod. You are always under the hood and some issue will come up here and there. I've been working with Linux for quite a few years and still the learning curve is steep. As previously mentioned, Garuda is cool in that it tries to make the jump easier but there are some things that just don't change when it comes to Linux in general. What I find frustrating is that it is disjointed and a lot of wasted effort goes in to reinventing the wheel even within the Linux community. Hence all of the window managers and disjointed tools/drivers etc. Good luck!

3 Likes

Use Forum search. It is solved


Please do not post multiple "problems" in one thread.

Read

please
and post

inxi -Fxxxza

as text!

How? Ultimate is old ISO.

Please post full ISO name.

2 Likes