New Firedragon major version

May not be related to Firedragon if you have nothing in there.
Unless you don’t have version 9.6 of /usr/lib/firedragon/firedragon.cfg or you have a firedragon.overrides.cfg in your .firedragon folder that overrides these.

Couple of hints:

  • Make sure you have v11.9.0 by checking paru -Qi firedragon
  • Close browser
  • Create a new browser Profile
  • Move away firedragon.overrides.cfg from your .firedragon folder
  • Make sure you have version 9.6 of firedragon.cfg
  • Restart browser and see if changes anything

There has been a Merge Request included to enable touchpad in Firefox based browser, it’s possible it affected this. If you have the file ~/.config/environment.d/firefox.conf on your system, delete it.
Plus, there are some Smoothfox tweaks to smooth out the scrolling.

Unfortunately I don’t have a laptop to test touchpad.

I got

╭─kevin@kevin in ~ took 6ms
╰─λ paru -Qi firedragon
Name            : firedragon
Version         : 1:11.9.0-1

Just investigating how to create new browser profile

Yeah it’s not the right size.
Maybe some conflicts happened, I have seen that a few times during my million tests but could never reproduce.

Can you download it from here. Linked removed.

Open Terminal and

firedragon -P

Follow instruction from kdialog pop-up.

That’s something else. I also have this since about 1-2 days… did not tell anyone yet.
I have no idea what that could be and whether it’s FD related or not. I don’t have errors on any other login pages of other websites, it could be Discourse related.

I love it that you are multitasking…
firedragon P, no k dialog, just error in connecting to site

What do you want me to do with the overrides file?

I have firedragon 11.9.0 , I don’t know how to check if firedragon.cfg is version 9.6 but I have not firedragon.overrides.cfg and considering I never use old firedragon on this laptop I assume is 9.6
For Codec missing this week I will install FireDragon on my father pc (with garuda on it) and I check Codec available on it that is a very old laptop to see if there are difference

1 Like

cat /usr/lib/firedragon/firedragon.cfg | grep firedragon.cfg.version

For version

Thanks, I can confirm is 9.6 version

1 Like

FGD. My bad I wasn’t putting a hyphen in front of the P :grinning:
Its late here.

New profile created. But still on Ver 8.2 but with your over-ride file as well.

Not OK?
How to get 9.6 config file?

You have copied the file from the link I provided and you still see 8.2? Where do you see that?

Hang on. Might have fixed it. I created a new profile and renamed the .cfg file. Then renamed the new over-ride file and removed 'override to leave a new firedragon.cfg file and it appears to have worked

I’m on 9.3 now

Its late…

You mean 9.6?


λ cat /usr/lib/firedragon/firedragon.cfg | grep firedragon.cfg.version
defaultPref("firedragon.cfg.version", "9.3");

That’s your downloaded overrides file renamed to just be a config file
And a new profile

Well if you sudo cp the file from the link I provided into /usr/lib/firedragon/ and it shows 9.3, then I think you have something corrupted somewhere.

The file from the link needs to overwrite firedragon.cfg in /usr/lib/firedragon/

Line No. 38 of the downloaded file says

defaultPref("firedragon.cfg.version", "9.3");

Yeah, it did.

Damn it, multitasking made me make an error. lolll

Plz use THIS file and trash the one from the other link, plz.