New FireDragon Google Meet Issues

A couple of days ago Google Meet stopped working in FireDragon and I am wondering if this has to do with the migration to floorp;

I have recreated the entire profile (completely fresh) and run through the regular Meet trouble shooting scenarios such as ensuring Camera, Microphone and Autoplay permissions. They are all granted yet I get “Microphone is blocked” and “Camera is blocked” notifications.

I tried the same with different browsers such as regular Firefox, Brave, etc with no issues whatsoever, thus this is not a hardware related issue. I also compared about:config between regular Firefox and Firedragon and can’t find any glaring differences when it comes to audio/video settings, but I may be missing something;

I vaguely remember a past instance where some or other setting needed to be edited in a config file that allowed camera / microphone access or something to do with cross-origin policy. However this was over a year ago and I do not recall the exact details…

If anybody else is experiencing a similar issue or know of a solution I would be grateful as I currently have to break into a different browser to conduct meetings which is rather annoying…

1 Like

Plz follow the installation procedure and at the end the troubleshooting steps if it still doesn’t work.


Hi There. I can confirm Google Meet does not work for me in FireDragon. It reports both the camera and the microphone are blocked.
Google Meet does work with a Chromium based browser though, that’s why we have two browsers installed!

So after trying the 4 troubleshooting steps it still does not work?

1 Like

same behavior experienced on my system. I tested the webcam and mic on they are working fine in the same browser. But google meet says “microphone is blocked”, “camera is blocked”, but i allowed them on permission popup… I dont understand.

[Bug] Google Meet can't access camera or microphone after floop v11.8.1 · Issue #766 · Floorp-Projects/Floorp · GitHub