Network dies after sleep

The title explains it pretty well, I'm on the KDE ultimate edition on my laptop and the network panel just comes out empty every time the laptop has gone to sleep. Only rebooting restores the internet.

Some system info:

OS: Garuda Linux x86_64 
Host: 81X2 IdeaPad Flex 5 14ARE05 
Kernel: 5.8.12-zen1-1-zen 
Packages: 2116 (pacman) 
Shell: zsh 5.8 
Resolution: 1920x1080 
DE: Plasma 5.19.5 
WM: KWin 
Theme: WhiteSurDark [Plasma], Breeze [GTK3] 
Icons: Tela-circle-dark [Plasma], Tela-circle-dark [GTK2/3] 
Terminal: konsole 
CPU: AMD Ryzen 3 4300U with Radeon Graphics (4) @ 2.700GHz 
GPU: AMD ATI 04:00.0 Renoir 
Memory: 3266MiB / 7383MiB

Please post

inxi -Fxxxza --no-host

too.
maybe a

systemctl start your.network.service

could be a workaround.

Oftentimes the only way to solve this is by using a different kernel version (or perhaps a bios update).

If testing different kernels brings no relief then usually writing your own systemd suspend service is the only workaround that doesn't require manual user intervention.

See my extensive thread on writing services here:

After you have posted your system information I may be able to give you further assistance as I have written many services in the past to mitigate exactly this type of issue.

3 Likes

What is the default network service?

System:    Kernel: 5.8.12-zen1-1-zen x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=496c577c-bf17-4275-b4c7-7a9802e4b0c9 rw 
           [email protected] splash loglevel=3 
           Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Garuda Linux 
Machine:   Type: Convertible System: LENOVO product: 81X2 v: IdeaPad Flex 5 14ARE05 serial: <filter> Chassis: type: 31 
           v: IdeaPad Flex 5 14ARE05 serial: <filter> 
           Mobo: LENOVO model: LNVNB161216 v: SDK0R32866 WIN serial: <filter> UEFI: LENOVO v: EECN21WW date: 04/22/2020 
Battery:   ID-1: BAT0 charge: 51.4 Wh condition: 51.4/52.6 Wh (98%) volts: 13.1/11.5 model: Sunwoda L19D3PD6 type: Li-poly 
           serial: <filter> status: Full cycles: 59 
CPU:       Info: Quad Core model: AMD Ryzen 3 4300U with Radeon Graphics bits: 64 type: MCP arch: Zen family: 17 (23) 
           model-id: 60 (96) stepping: 1 microcode: 8600102 L2 cache: 2048 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 21558 
           Speed: 2774 MHz min/max: 1400/2700 MHz boost: enabled Core speeds (MHz): 1: 2774 2: 3505 3: 2901 4: 3251 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Renoir vendor: Lenovo driver: amdgpu v: kernel bus ID: 04:00.0 
           chip ID: 1002:1636 
           Device-2: Syntek Integrated Camera type: USB driver: uvcvideo bus ID: 1-4:2 chip ID: 174f:243f serial: <filter> 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: amdgpu FAILED: ati unloaded: modesetting 
           alternate: fbdev,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 158 size: 309x173mm (12.2x6.8") diag: 354mm (13.9") 
           OpenGL: renderer: AMD RENOIR (DRM 3.38.0 5.8.12-zen1-1-zen LLVM 10.0.1) v: 4.6 Mesa 20.1.8 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] driver: snd_hda_intel v: kernel bus ID: 04:00.1 chip ID: 1002:1637 
           Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo 
           driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x bus ID: 04:00.5 chip ID: 1022:15e2 
           Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus ID: 04:00.6 chip ID: 1022:15e3 
           Sound Server: ALSA v: k5.8.12-zen1-1-zen 
Network:   Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: Lenovo driver: rtw_8822ce v: N/A 
           modules: rtw88_8822ce port: 2000 bus ID: 02:00.0 chip ID: 10ec:c822 
           IF: wlp2s0 state: up mac: <filter> 
Drives:    Local Storage: total: 238.47 GiB used: 179.09 GiB (75.1%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 vendor: Lenovo model: UMIS RPJTJ256MEE1OWX size: 238.47 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 2.0C0628 scheme: GPT 
Partition: ID-1: / raw size: 76.99 GiB size: 76.99 GiB (100.00%) used: 47.59 GiB (61.8%) fs: btrfs dev: /dev/nvme0n1p6 
           ID-2: /home raw size: 76.99 GiB size: 76.99 GiB (100.00%) used: 47.59 GiB (61.8%) fs: btrfs dev: /dev/nvme0n1p6 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 461.5 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 461.5 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 461.5 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 461.5 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
Sensors:   System Temperatures: cpu: 51.1 C mobo: 42.0 C gpu: amdgpu temp: 41.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 279 Uptime: 3m Memory: 7.21 GiB used: 2.51 GiB (34.8%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
           clang: 10.0.1 Packages: pacman: 2116 lib: 580 flatpak: 0 Shell: Zsh v: 5.8 running in: konsole inxi: 3.1.06

On plasma the default is network manager.

Network Manager may be restarted with:

systemctl restart NetworkManager

I believe your bios is out of date. You should ensure your BIOS is current before you do anything else as an update to your bios is one of the most likely things to correct this kind of issue:

2 Likes

Please don't give up on this. This issue is usually 95% resolvable with either a different kernel, a bios update, or writing a service.

I've helped many people resolve this issue. It's usually rare when it can't be corrected or worked around (so don't give up).

4 Likes

I am sorry it took this long to answer, thank you for your dedication!
At least changing kernel to only default linux nor restarting or re-enabling the NetworkManager service did yet resolve the issue. A BIOS update must be generally installed from windows, I presume? I came across this on the archwiki, but it seems kinda hard and unnecessary dangerous. Windows has had a bad habit of corrupting devices and GRUB lately :slight_smile: though, but I might want to risk that instead of corrupting my BIOS instead.

I was wondering if this might be caused by the young age of my wifi-card, for example our local exam software based on linux would currently need an adapter.

This is usually caused by one of a handful of things.

A kernel bug, that may eventually get resolved (or not).

Wifi driver not developed with full Linux support.

Bios not handling your power states properly

You could try changing your power state settings in your bios to see if it helps.

Generally it takes more than just a simple NetworkManager restart to initiate your wifi after suspend. Usually it takes unloading your Wifi driver and turning off your network before suspending to resolve this. The components are then restarted by the service after resuming and that usually will reinitiate your wifi connection without a reboot.

2 Likes

I tried updating my BIOS and now the BIOS doesn't find the garuda GRUB anymore...
I tried about all of the Garuda boot repair options from an USB, but none have worked.
For example running the MBR option on the only available drive outputs:


and then:

Installing for i386-pc platform.
grub-install: warning: this GPT partition label contains no BIOS Boot Partition; embedding won't be possible.
grub-install: error: filesystem `btrfs' doesn't support blocklists.
Maybe I need to create a new bootloader partition for some reason?

You try chroot too? With
sudo grub-install /dev/sdXx

Garuda is installed on/as (U)EFI?

All what :wink: ?

1 Like

Yes it should be installed as (U)EFI, I tried GRUB reinstall MBR (see the previous pic), root and ESP.
MBR and root complain about brtfs and ESP complains about the ssd not being uefi?

Installing for x86_64-efi platform.
grub-install: error: /boot/efi doesn't look like an EFI partition.

Also tried the "Repair GRUB cofiguration" just for the kicks, it completed succesfully but did not resolve the problem.

Chrooting and using grub-install returns

Installing for x86_64-efi platform.
grub-install: error: cannot find EFI directory.

Do I need to mount something for that to work?

1 Like
findmnt /boot/efi
test -d /sys/firmware/efi && echo UEFI || echo BIOS

to be shure :slight_smile:
But seems you must first create the /boot/efi folder.

But maybe wait fore more competent answer. :slight_smile:

UEFI it is:

sh-5.0# findmnt /boot/efi
sh-5.0# test -d /sys/firmware/efi && echo UEFI || echo BIOS
UEFI
sh-5.0#

Should the findmnt have outputted something though?
Thank you so far, I need to get some sleep :smiley:

1 Like

Yes, like this

findmnt /boot/efi                                                                             
TARGET    SOURCE    FSTYPE OPTIONS
/boot/efi /dev/sda1 vfat   rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro

While chrooting the garuda-installation, the folder /boot/efi does exist and contains the usual stuff. However findmnt doesn't output a single character.

:thinking:

It's times like this I wish my old friend @gohlip was around. I hate dealing with multi-boot issues, that's why I've always used a hardware based OS swap solution for over 15 years.

Perhaps @jonathon might have some idea of what's going on.

Which method did you use to update your bios?

I updated the bios by downloading the automatic updater from lenovos website. It ran for a moment, then rebooted to some kind of flasher, took some time to flash and then rebooted to windows.

It had reset all the settings so I went to BIOS to disable secureboot and arrange the boot-priority. It used to label the ssd as garuda, but now bios only sees the windows bootloader and the stock "nvme-xxxxx" ssd.

I have not used Windoze in ages, so I'm probably not the one for the best advice regarding this issue. However, is there not a recovery console for Windoze that you can use to correct boot errors.

Is Win10 booting properly.

Yes, fortunately windows has no problem booting.

I just noticed you are using an nmve drive as your boot device. I just built myself a new computer and even though they are faster I avoided using one of those because of the issues I've read about them not being detected in Linux.

I would perform some internet searches (especially on the Arch and Manjaro forums) for problems with those type of drives as the boot device.

I hate to say it, but depending on how long you've had your install for, it might just be way less effort to reinstall Garuda (if no one has any productive suggestions for your situation). The newly released ISO's have some really nice enhancements and you might like getting all the new improvements.

2 Likes