My laptop crashes when I try to shut it down and the sound equipment does not work

Hi everyone from Turkey. I’ve been using Garuda Linux KDE for about a year now and I really like it. I even prepared a review article about Garuda KDE and published it on, a very popular and large forum site in my country.

The link to the article is at Garuda Linux Kurulum Ve İncelemesi | DonanımHaber Forum

I bought myself a new notebook about 6 months ago. MSI Stealth 17M. This notebook is elegant and has a very powerful processor and graphics card. I installed the Garuda KDE distribution as soon as I received my device. Apparently it was working fine. However, after I started using my device, from time to time when I wanted to turn it off, the device would crash. Meanwhile, the small light on the CapsLock key was constantly blinking. I also had to press the power button for a long time to turn off my computer.

After using this method a few times to shut down my computer, when I turned it back on I noticed that the audio hardware was not working. First, I tried to reinstall the operating system to solve this problem, but it did not work. Then I went to the MSI official website and downloaded the BIOS upgrade file for my device, and when I applied the BIOS upgrade on my device, the audio hardware started working again.

However, as I continued to use my device, the same error repeated itself many times, and I continued to solve the problem by applying BIOS updates each time. Finally, the last time I had this audio hardware not working issue, I resorted to applying a BIOS update again. This time the BIOS update was interrupted before it could complete and my device refused to turn on again. It was not possible to enter the BIOS settings. Then I took my device to the technical service and they disassembled the computer there; They found the BIOS integrated circuit and rewrote the BIOS using the necessary equipment.

I placed an applications menu and a SHUTDOWN or SWITCH applet in the iconic task manager at the bottom of the desktop. I removed the App Launcher from the top panel and replaced it with an App Menu. If I tried to shut down or restart my computer using these items or the command line, this error would appear from time to time. There may be a relationship between the emergence of these errors and the fact that I put extra Application Menu and SHUTDOWN or SWITCH applets on the panels. Because I started experiencing almost all of the problems after making these adjustments. But it could also be a coincidence.

Although I have installed LTS next to it from time to time, I generally use the Linux Zen kernel. I keep my operating system up to date.

When Garuda started using Wayland, I had some problems shutting down or logging out. Also, VokoScreen screen recording program does not work with Wayland. That’s why I continue to stay on X11.

I have never used an operating system other than Garuda KDE on my device.

I would appreciate any information regarding this issue and am open to suggestions. I really like Garuda Linux KDE and want to continue using it. I’ll be happy if you can help me.

I wrote this text in my own language and translated it with Google Translate. There may have been some glitches in the translation. Thank you very much.

Operating System: Garuda Linux
KDE Plasma Version: 6.0.4
KDE Frameworks Version: 6.2.0
Qt Version: 6.7.0
Kernel Version: 6.8.9-zen1-2-zen (64-bit)
Graphics Platform: X11
Processors: 20 × 12th Gen Intel® Core™ i7-1280P
Memory: 15.3 GiB of RAM
Graphics Processor: Mesa Intel® Graphics
Manufacturer: Micro-Star International Co., Ltd.
Product Name: Stealth 17M A12UE
System Version: REV:1.0

Edit: I did’t know about garuda-inxi sorry. Here is:

Kernel: 6.8.9-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=e6639c04-e04f-4f0b-bc16-1233722763e4 rw rootflags=subvol=@
quiet resume=UUID=94adc4e7-21df-4d37-a002-4b1d6afc414f loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.2.0
wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Type: Laptop System: Micro-Star product: Stealth 17M A12UE v: REV:1.0
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Micro-Star model: MS-17R1 v: REV:1.0 serial: <superuser required>
part-nu: 17R1.1 uuid: <superuser required> UEFI: American Megatrends LLC.
v: E17R1IMS.10F date: 01/17/2024
ID-1: BAT1 charge: 47.6 Wh (88.0%) condition: 54.1/63.2 Wh (85.5%)
volts: 15.5 min: 15.2 model: MSI BIF0_9 type: Li-ion serial: N/A
status: discharging
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M325
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
Info: model: 12th Gen Intel Core i7-1280P bits: 64 type: MST AMCP
arch: Alder Lake level: v3 note: check built: 2021+
process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
microcode: 0x432
Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 426 high: 500 min/max: 400/4700:4800:3600 scaling:
driver: intel_pstate governor: powersave cores: 1: 468 2: 400 3: 481 4: 400
5: 494 6: 493 7: 400 8: 400 9: 487 10: 400 11: 500 12: 400 13: 400 14: 400
15: 400 16: 400 17: 400 18: 400 19: 400 20: 400 bogomips: 79872
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Alder Lake-P GT2 [Iris Xe Graphics] vendor: Micro-Star MSI
driver: i915 v: kernel alternate: xe arch: Gen-12.2 process: Intel 10nm
built: 2021-22+ ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0
chip-ID: 8086:46a6 class-ID: 0300
Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q]
vendor: Micro-Star MSI driver: nvidia v: 550.78
alternate: nouveau,nvidia_drm non-free: 550.xx+ status: current (as of
2024-04; EOL~2026-12-xx) arch: Ampere code: GAxxx process: TSMC n7 (7nm)
built: 2020-2023 pcie: gen: 4 speed: 16 GT/s lanes: 4 link-max: lanes: 16
ports: active: none empty: DP-1 bus-ID: 01:00.0 chip-ID: 10de:2520
class-ID: 0300
Device-3: Bison Integrated Camera driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:3 chip-ID: 5986:2149
class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: BOE Display 0x09a4 built: 2020 res: 1920x1080
hz: 144 dpi: 128 gamma: 1.2 size: 382x215mm (15.04x8.46")
diag: 438mm (17.3") ratio: 16:9 modes: 1920x1080
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 2 drv: iris device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia x11: drv: iris inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.0.7-arch1.3
glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (ADL GT2)
device-ID: 8086:46a6 memory: 14.97 GiB unified: yes
API: Vulkan v: 1.3.279 layers: 4 device: 0 type: integrated-gpu name: Intel
Graphics (ADL GT2) driver: mesa intel v: 24.0.7-arch1.3
device-ID: 8086:46a6 surfaces: xcb,xlib device: 1 type: discrete-gpu
name: NVIDIA GeForce RTX 3060 Laptop GPU driver: nvidia v: 550.78
device-ID: 10de:2520 surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe
(LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.7-arch1.3 (LLVM
17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel Alder Lake PCH-P High Definition Audio
vendor: Micro-Star MSI driver: sof-audio-pci-intel-tgl
alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
chip-ID: 8086:51c8 class-ID: 0401
Device-2: NVIDIA GA106 High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 4
link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:228e class-ID: 0403
API: ALSA v: k6.8.9-zen1-2-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.6 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:4 chip-ID: 8087:0026
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
status: discoverable: no pairing: no
Local Storage: total: 1.82 TiB used: 308.08 GiB (16.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SFYRD2000G
size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: EIFK31.6 temp: 31.9 C
scheme: GPT
ID-1: / raw-size: 100.59 GiB size: 100.59 GiB (100.00%) used: 7.2 GiB (7.2%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 1024 MiB size: 1022 MiB (99.80%)
used: 584 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 1.03 TiB size: 1.03 TiB (100.00%)
used: 3.79 GiB (0.4%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 100.59 GiB size: 100.59 GiB (100.00%)
used: 7.2 GiB (7.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 100.59 GiB size: 100.59 GiB (100.00%)
used: 7.2 GiB (7.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: partition size: 16.06 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p4 maj-min: 259:4
ID-2: swap-2 type: zram size: 15.33 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 20 dev: /dev/zram0
System Temperatures: cpu: 42.0 C mobo: N/A
Fan Speeds (rpm): N/A
Memory: total: 16 GiB note: est. available: 15.33 GiB used: 5.68 GiB (37.0%)
Processes: 417 Power: uptime: 2h 59m states: freeze,mem,disk
suspend: s2idle avail: deep wakeups: 0 hibernate: platform avail: shutdown,
reboot, suspend, test_resume image: 6.09 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1438 libs: 426 tools: octopi,pamac,paru
Compilers: gcc: 14.1.1 Shell: garuda-inxi default: fish v: 3.7.1
running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-05-14
Last full system update: 2024-05-18 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected

Please post your garuda-inxi as requested by the template.

Kernel panic…

Nope, everything is perfectly understandable. But the whole thing reads like a blog post :wink:

As @nepti said, please provide the inxi and also try out the lts-kernel by running sudo pacman -S linux-lts linux-lts-headers and reboot.

:slightly_smiling_face:Yes it was a kong post. The problem is kind of spesific, so I thought I should explain in detail

Please edit your start post and put the output of garuda-inxi in a code block.

Next time your laptop freezes during shutdown, restart it and post the output of:

journalctl -b -1 --no-pager

Upload this to and share the generated link here.

I just plugged in the power plug while updating the operating system and the machine was chrased again. Now the notebook is being updated and then I will install Linux-lts.

I’m going to install Linux-lts now.

journalctl -b -1 --no-pager output

1 Like

Thanks. I just installed linux-lts and rebooted. Should i run garuda-inxi again?

The log after this freeze is useless.

We need the output of journalctl -b -1 --no-pager after the laptop freezes during shutdown.

Do you only have freezes during shutdown when the laptop is running on battery or also when the power supply is connected?

And fix this, please:

I had freezes only just clicking on shut down restart buttons. But the latest freeze is new and it happened for the first time.

I advise against this. The OP has had this issue since the beginning, regardless of the Nvidia driver version - nothing suggests that it has anything to do with it.
His description matches a power management issue.


Hi. I’m using linux lts core now. It just crashed again. Then i opened my device and run

journalctl -b -1 --no-pager

Here is the output:

By the way, i performed some tweaks that “auto cpufreq, intel undervolt and thermald”. I dont know that was important or not. Thanks.

your nvme drive is erroring out? Try installing nvme-cli and run sudo nvme smart-log /dev/nvme0n1, and upload the output to the pastebin.

This should tell us if your drive is dying

also please share journalctl -k -b -1 --no-pager for the full kernel log that might contain further info


The whole log consists almost exclusively of pcieport/nvme errors:

kernel: pcieport 0000:00:06.2: AER: Corrected error message received from 0000:02:00.0
May 25 01:08:37 ilker-garuda kernel: nvme 0000:02:00.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, (Receiver ID)
May 25 01:08:37 ilker-garuda kernel: nvme 0000:02:00.0:   device [2646:5013] error status/mask=00000001/00006000
May 25 01:08:37 ilker-garuda kernel: nvme 0000:02:00.0:    [ 0] RxErr                  (First)

This smells to me like power management issues of the NVMe SSD.
Try disabling ASPM in BIOS. If you don’t have any ASPM options there, add this as a kernel parameter:

1 Like

Thanks a lot. Here is:

Smart Log for NVME device:nvme0n1 namespace-id:ffffffff
critical_warning                        : 0
temperature                             : 27 °C (300 K)
available_spare                         : 100%
available_spare_threshold               : 10%
percentage_used                         : 0%
endurance group critical warning summary: 0
Data Units Read                         : 7027171 (3.60 TB)
Data Units Written                      : 6528265 (3.34 TB)
host_read_commands                      : 26663132
host_write_commands                     : 106907716
controller_busy_time                    : 609
power_cycles                            : 556
power_on_hours                          : 1906
unsafe_shutdowns                        : 138
media_errors                            : 0
num_err_log_entries                     : 1404
Warning Temperature Time                : 0
Critical Composite Temperature Time     : 0
Temperature Sensor 2           : 57 °C (330 K)
Thermal Management T1 Trans Count       : 0
Thermal Management T2 Trans Count       : 0
Thermal Management T1 Total Time        : 0
Thermal Management T2 Total Time        : 0


I don’t know what is aspm. I did it with fish.

╭─ilker@ilker in ~ as 🧙 took 47ms
╰─λ pcie_aspm=off
fish: Unsupported use of '='. In fish, please use 'set pcie_aspm off'.

╭─ilker@ilker in ~ as 🧙 took 47ms
[🔴] × set pcie_aspm off

╭─ilker@ilker in ~ as 🧙
[🔴] ×

Is this works only current core? Should i make it for each kernel updates? Thanks.

Hmm the nvme smart data seems absolutely fine, good for you :slight_smile:

you set that in your kernel parameters.
For that edit /etc/default/grub and on the line that starts with GRUB_CMDLINE_LINUX_DEFAULT add pcie_aspm=off after the last entry, but before the closing quotation mark (e.g. GRUB_CMDLINE_LINUX_DEFAULT='foo bar baz pcie_aspm=off'
Afterwards run sudo update-grub


I agree with UltraBlack, SMART is fine.
You can also simply insert the kernel parameter with “Garuda Boot Options”.


Should i apply this one too?

╭─root@ilker in /etc/default as 🧙 took 37ms
╰─λ sudo update-grub
Grub yapılandırma dosyası oluşturuluyor ...
Bulunan tema: /usr/share/grub/themes/garuda-dr460nized/theme.txt
Bulunan linux kalıbı: /boot/vmlinuz-linux-zen
Bulunan initrd kalıbı: /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot:  initramfs-linux-zen-fallback.img
Bulunan linux kalıbı: /boot/vmlinuz-linux-lts
Bulunan initrd kalıbı: /boot/initramfs-linux-lts.img
Found fallback initrd image(s) in /boot:  initramfs-linux-lts-fallback.img
Uyarı: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Adding boot menu entry for UEFI Firmware Settings ...
Detecting snapshots ...
Found snapshot: 2024-05-25 23:30:13 | @/.snapshots/46/snapshot | post | nvme-cli                              |
Found snapshot: 2024-05-25 23:29:40 | @/.snapshots/45/snapshot | pre  | /usr/bin/pacman -S --noconfirm extra/nvme-cli         |
Found snapshot: 2024-05-22 19:55:57 | @/.snapshots/44/snapshot | post | libconfig libev picom qt5-remoteobjects xcompmgr zoom |
Found snapshot: 2024-05-22 19:55:50 | @/.snapshots/43/snapshot | pre  | /usr/bin/pamac-daemon                 |
Found snapshot: 2024-05-22 01:10:49 | @/.snapshots/42/snapshot | post | stacer-bin                            |
Found snapshot: 2024-05-22 01:10:47 | @/.snapshots/41/snapshot | pre  | /usr/bin/pamac-daemon                 |
Found snapshot: 2024-05-22 01:09:55 | @/.snapshots/40/snapshot | post | qt5-charts                            |
Found snapshot: 2024-05-22 01:09:53 | @/.snapshots/39/snapshot | pre  | /usr/bin/pamac-daemon                 |
Found 8 snapshot(s)
Unmount /tmp/grub-btrfs.uSOt765Ycq .. Success
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: uyarı: bilinmeyen aygıt türü (mean- warning: unknown device type): nvme0n1.
bitti (mean: done)

now reboot and check if you can’t shut down normally now

1 Like