My headphone is not detected

Hello Garuda users.

i'm using a hp chromebook 14a-na0142nd. with a Intel Celeron/Pentium Silver Processor High Definition Audio. (garuda kde Dr460nized) and my problem is that my headphone willn't be detected but both of my speakers from my chromebook will be work only the jack input willn't be worl.

System:
Kernel: 5.19.2-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=99c21d0e-b3b1-4a4e-8ad6-87220531d225 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=77fb1fac-55dd-408a-933c-e04c5986e4b2 loglevel=3
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Google product: Blooglet v: rev4
serial: <superuser required> Chassis: type: 9 serial: <superuser required>
Mobo: HP model: Blooglet v: rev4 serial: <superuser required>
UEFI: coreboot v: MrChromebox-4.17.2 date: 07/18/2022
Battery:
ID-1: BAT0 charge: 18.1 Wh (45.0%) condition: 40.2/47.4 Wh (84.9%)
volts: 8.2 min: 7.7 model: 333-1D- GH02047 type: Li-ion serial: <filter>
status: charging cycles: 43
CPU:
Info: model: Intel Celeron N4020 bits: 64 type: MCP arch: Goldmont Plus
built: 2017 process: Intel 14nm family: 6 model-id: 0x7A (122) stepping: 8
microcode: 0x20
Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 112 KiB
desc: d-2x24 KiB; i-2x32 KiB L2: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 1498 high: 1753 min/max: 800/2800 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 1244 2: 1753
bogomips: 4377
Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel GeminiLake [UHD Graphics 600] driver: i915 v: kernel
arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1
empty: DP-1,DP-2 bus-ID: 00:02.0 chip-ID: 8086:3185 class-ID: 0380
Device-2: Luxvisions Innotech HP Wide Vision HD Camera type: USB
driver: uvcvideo bus-ID: 1-7:3 chip-ID: 30c9:0016 class-ID: 0e02
serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: LG Display 0x060f built: 2018 res: 1920x1080
hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel UHD Graphics 600 (GLK 2) v: 4.6 Mesa 22.1.7
direct render: Yes
Audio:
Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio
driver: sof-audio-pci-intel-apl
alternate: snd_hda_intel,snd_soc_skl,snd_soc_avs,snd_sof_pci_intel_apl
bus-ID: 00:0e.0 chip-ID: 8086:3198 class-ID: 0401
Sound Server-1: ALSA v: k5.19.2-zen1-2-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.57 running: yes
Network:
Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: rtw_8822ce v: N/A modules: rtw88_8822ce
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 01:00.0
chip-ID: 10ec:c822 class-ID: 0280
IF: wlp1s0 state: up mac: <filter>
Bluetooth:
Device-1: Realtek 802.11ac WLAN Adapter type: USB driver: btusb v: 0.8
bus-ID: 1-3:2 chip-ID: 0bda:b00c class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 3 state: up address: <filter>
Drives:
Local Storage: total: 58.31 GiB used: 17.38 GiB (29.8%)
ID-1: /dev/mmcblk0 maj-min: 179:0 vendor: Kingston model: TA2964
size: 58.31 GiB block-size: physical: 512 B logical: 512 B type: SSD
serial: <filter> rev: 0x8 scheme: MBR
SMART Message: Unknown smartctl error. Unable to generate data.
Partition:
ID-1: / raw-size: 19.53 GiB size: 19.53 GiB (100.00%) used: 16.44 GiB
(84.2%) fs: btrfs dev: /dev/mmcblk0p3 maj-min: 179:3
ID-2: /boot/efi raw-size: 1000 MiB size: 998 MiB (99.80%) used: 608 KiB
(0.1%) fs: vfat dev: /dev/mmcblk0p1 maj-min: 179:1
ID-3: /home raw-size: 29.99 GiB size: 29.99 GiB (100.00%) used: 967.2 MiB
(3.1%) fs: btrfs dev: /dev/mmcblk0p4 maj-min: 179:4
ID-4: /var/log raw-size: 19.53 GiB size: 19.53 GiB (100.00%) used: 16.44
GiB (84.2%) fs: btrfs dev: /dev/mmcblk0p3 maj-min: 179:3
ID-5: /var/tmp raw-size: 19.53 GiB size: 19.53 GiB (100.00%) used: 16.44
GiB (84.2%) fs: btrfs dev: /dev/mmcblk0p3 maj-min: 179:3
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 3.7 GiB used: 1.84 GiB (49.7%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 7.81 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/mmcblk0p2 maj-min: 179:2
Sensors:
System Temperatures: cpu: 75.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 235 Uptime: 2h 43m wakeups: 64741 Memory: 3.7 GiB used: 2.44 GiB
(66.0%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pacman: 1679 lib: 441 Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.20
Garuda (2.6.6-1):
System install date:     2022-09-05
Last full system update: 2022-09-05 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            systemd-vconsole-setup.service

What commands did you find?

It is important to explain what you have already tried so far. It can be frustrating to offer a suggestion and hear back something like "I already tried that."

3 Likes

sudo pacman -S alsamixer
sudo pacman pipemixer

So basically you haven't tried anything yet, since neither of those commands will even do anything. Neither one of those is even the name of a package, and your second command you didn't even specify an argument for pacman.

Does the sound work out of the speakers? That would be a helpful bit of information to know.

First, reboot your device and test again.

Next, try unmuting the sound card. Copy and paste the input and output of the commands into the thread if it doesn't work.

amixer sset Master unmute
amixer sset Headphone unmute

If that doesn't work, try this:

sudo alsactl restore

There probably will not be any output, if there is for some reason paste it in the thread.

Try some of the troubleshooting advice noted here: Chrome OS devices - ArchWiki

Describe your efforts in the thread so if you get stuck someone can take a look and try to help.

Try installing the LTS kernel.

First take a fresh update:

garuda-update

Then install the kernel and headers:

sudo pacman -S linux-lts linux-lts-headers

Reboot, the in the grub menu choose advanced boot options and pick the LTS kernel.

2 Likes

its doesn't work

Preparing setup..

[sudo] password for linux:

Installing packages..

warning: linux-lts-5.15.64-1 is up to date -- skipping
warning: linux-lts-headers-5.15.64-1 is up to date -- skipping
there is nothing to do

Enabling services..

Press enter to return to setup assistant.

and its cant detect my headphone

This is not enough information. I suggested three commands to try and asked you to put output into the thread--where is it?

Why am I putting in more effort than you are? My headphones work fine. :thinking:

You haven't tried LTS yet, the output you showed only says it is installed. You have to reboot the device choose the LTS kernel on the grub menu.

If you are booted into Garuda and haven't selected the LTS kernel yet, you have gone too far.

Go back through the rest of the suggestions and add more information to the thread. The LTS kernel was actually the last suggestion on the list; try the other stuff too. You also never answered this question:

4 Likes

wait first i will reinstall my chromebook and try it agian but i doesn't now the partition and i have 58gb

try it all
but doesn't work. the problem is my chromebook cant detect my headphon jack 3.5mm

3 Likes

i use a chromebook with a system garuda kde Dr460nized. (hp chromebook 14a-0142nd) and both of my speaker of my chromebook work, but my headphone jack doesn't be detected. with pipeware. i have try much ways but they are all useless

its work on a bluethooth speaker, but i dont have a normal speaker. i have try the lts kernel but it doesn't work. is it the problem of my chromebook or my system

Either a hardware issue or it might be related to the JamesDSP issue :man_shrugging:

Have you also tried changing from PipeWire support to PulseAudio support in the System Components of Garuda Assistant?

yes i tried but both cant detect my headphone jack

and i cant find my output device