Most of the task switcher animations do not work

Hi guys, there's one thing I could not solve in this months with Garuda and it's just bothering me. A couple of weeks ago, I tried to change the task switching animation since the one I was getting was extremely simple, so I went to check the available animations and i saw that half of the animations in the list were all the same "default" simple look. Sweetified Plasma and the 3 Brezza do not work (they all look the same just like "Informative").
Everything is up to date, I searched on google but nothing solved the issue; most of what I read was about "compositors" so I tried to change rendering engine to OpenGL 3.1 but did not work. Here on the forum I found someone that said that some of the animations where removed but on the official KDE web page says that at least Brezza should work; I don't even have FlipSwitch or CoverSwitch in the list but oh well.
I was thinking about changing compositor (kwin) but after some reading I now think it's kind of a bad idea.
So, I can easly stay with a simple switching animation but if I could solve this issue I would feel better :smiley:

Thanks in advance to anyone wanting to help!

╰─λ inxi -Faz
System:
Kernel: 5.15.15-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
root=UUID=d24cedcc-4118-4e84-a921-9e7003479bbe rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1
resume=UUID=842159cf-5e13-436d-92e9-8c28ffcc8ee6 loglevel=3
mitigations=off
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Dell product: Latitude E6320 v: 01
serial: <superuser required> Chassis: type: 9 serial: <superuser required>
Mobo: Dell model: 0GJF11 v: A00 serial: <superuser required> UEFI: Dell
v: A22 date: 09/12/2018
Battery:
ID-1: BAT0 charge: 10.9 Wh (100.0%) condition: 10.9/58.0 Wh (18.9%)
volts: 12.3 min: 11.1 model: Samsung SDI DELL 7M0N514 type: Li-ion
serial: <filter> status: Full
CPU:
Info: model: Intel Core i5-2520M bits: 64 type: MT MCP arch: Sandy Bridge
family: 6 model-id: 0x2A (42) stepping: 7 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 2727 high: 2946 min/max: 800/3200 scaling:
driver: intel_cpufreq governor: performance cores: 1: 2946 2: 2628 3: 2744
4: 2590 bogomips: 19954
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: vulnerable
Type: mds status: Vulnerable; SMT vulnerable
Type: meltdown status: Vulnerable
Type: spec_store_bypass status: Vulnerable
Type: spectre_v1 status: Vulnerable: __user pointer sanitization and
usercopy barriers only; no swapgs barriers
Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0126
class-ID: 0300
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: :0
screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
s-diag: 414mm (16.3")
Monitor-1: LVDS1 res: 1366x768 hz: 60 dpi: 120
size: 290x160mm (11.4x6.3") diag: 331mm (13")
OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2)
v: 3.3 Mesa 21.3.4 compat-v: 3.0 direct render: Yes
Audio:
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:1c20 class-ID: 0403
Sound Server-1: ALSA v: k5.15.15-1-lts running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.43 running: yes
Network:
Device-1: Intel 82579LM Gigabit Network vendor: Dell driver: e1000e
v: kernel port: 4080 bus-ID: 00:19.0 chip-ID: 8086:1502 class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
v: kernel bus-ID: 02:00.0 chip-ID: 8086:0082 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Drives:
Local Storage: total: 119.24 GiB used: 63.19 GiB (53.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung
model: SSD PM810 2.5 7mm 128GB size: 119.24 GiB block-size: physical: 512 B
logical: 512 B speed: 3.0 Gb/s type: SSD serial: <filter> rev: 8D1Q
scheme: GPT
Partition:
ID-1: / raw-size: 110.19 GiB size: 110.19 GiB (100.00%)
used: 63.19 GiB (57.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%)
used: 562 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 110.19 GiB size: 110.19 GiB (100.00%)
used: 63.19 GiB (57.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 110.19 GiB size: 110.19 GiB (100.00%)
used: 63.19 GiB (57.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 110.19 GiB size: 110.19 GiB (100.00%)
used: 63.19 GiB (57.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 1 (default 60) cache-pressure: 50 (default 100)
ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda3 maj-min: 8:3
ID-2: swap-2 type: zram size: 7.64 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 62.0 C mobo: 33.0 C sodimm: SODIMM C
Fan Speeds (RPM): cpu: 2997
Info:
Processes: 238 Uptime: 55m wakeups: 1 Memory: 7.65 GiB
used: 3.53 GiB (46.2%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1535 lib: 442 Shell: fish
v: 3.3.1 running-in: yakuake inxi: 3.3.12

You can edit your post, please.

2 Likes

My bad! Is it good now?

2 Likes

For some reason global themes seem to be listed there, Sweetified Plasma definitely does not provide a switcher animation. Also, KDE recently removed the cover effect and another one to rewrite them in QML I think - these will return in the next release though (already present in KDE-git)

4 Likes

Ah! Now, that makes sense :neutral_face:
I guess I'll wait for the next release then.
Thank you so much for the help!

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.