Monitor blurry and zoomed in on start-up

hello, every time i startup mu computer my monitor becomes a bit zoomed in and gets blurry, to fix this i just have to run xrandr --output eDP1 --auto which is tedious to have to run every time i turn on the computer. Is there any settings to fix this? Is it possible to run a batch script on start-up?

output:

System:
Kernel: 5.16.3-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=3d7f37ea-6ec9-4e7c-abfb-36c47e2e627b rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Dell product: Latitude E7470 v: N/A
serial: <superuser required> Chassis: type: 9 serial: <superuser required>
Mobo: Dell model: 0T6HHJ v: A00 serial: <superuser required>
UEFI-[Legacy]: Dell v: 1.31.3 date: 10/13/2021
Battery:
ID-1: BAT0 charge: 48.0 Wh (100.0%) condition: 48.0/55.0 Wh (87.4%)
volts: 8.4 min: 7.6 model: SMP DELL MC34Y51 type: Li-poly serial: <filter>
status: Full
ID-2: hidpp_battery_0 charge: 53% condition: N/A volts: 3.8 min: N/A
model: Logitech G502 LIGHTSPEED Wireless Gaming Mouse type: N/A
serial: <filter> status: Discharging
CPU:
Info: model: Intel Core i5-6300U bits: 64 type: MT MCP arch: Skylake
family: 6 model-id: 0x4E (78) stepping: 3 microcode: 0xEA
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1200 min/max: 400/3000 scaling: driver: intel_pstate
governor: powersave cores: 1: 1200 2: 1200 3: 1200 4: 1200 bogomips: 19999
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Graphics:
Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Dell Latitude E7470
driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:1916 class-ID: 0300
Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
bus-ID: 1-2:3 chip-ID: 0bda:5686 class-ID: 0e02 serial: <filter>
Device-3: Microsoft Microsoft LifeCam Cinema type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 1-4.1:7 chip-ID: 045e:0812
class-ID: 0102
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: :0
screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.9x11.2")
s-diag: 1052mm (41.4")
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 157
size: 310x170mm (12.2x6.7") diag: 354mm (13.9")
Monitor-2: HDMI1 res: 1920x1080 hz: 60 dpi: 92
size: 530x300mm (20.9x11.8") diag: 609mm (24")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell Latitude E7470
driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
chip-ID: 8086:9d70 class-ID: 0403
Device-2: Logitech G935 Gaming Headset type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-3:4 chip-ID: 046d:0a87
class-ID: 0300
Device-3: Microsoft Microsoft LifeCam Cinema type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 1-4.1:7 chip-ID: 045e:0812
class-ID: 0102
Sound Server-1: ALSA v: k5.16.3-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.44 running: yes
Network:
Device-1: Intel Ethernet I219-LM vendor: Dell Latitude E7470 driver: e1000e
v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:156f class-ID: 0200
IF: enp0s31f6 state: down mac: <filter>
Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel bus-ID: 01:00.0
chip-ID: 8086:24f3 class-ID: 0280
IF: wlp1s0 state: up mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
bus-ID: 1-8:8 chip-ID: 8087:0a2b class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 5 state: up address: <filter>
RAID:
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
v: 3.0 port: f060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A
class-ID: 0104
Drives:
Local Storage: total: 465.76 GiB used: 19.71 GiB (4.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WDS500G2B0B-00YS70 size: 465.76 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 00WD
scheme: MBR
Partition:
ID-1: / raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
used: 19.71 GiB (4.2%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
used: 19.71 GiB (4.2%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
used: 19.71 GiB (4.2%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
used: 19.71 GiB (4.2%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.3 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 59.0 C pch: 51.0 C mobo: N/A
Fan Speeds (RPM): cpu: 0
Info:
Processes: 236 Uptime: 5h 20m wakeups: 42 Memory: 15.3 GiB
used: 4.93 GiB (32.2%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1447 lib: 423 Shell: fish
v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.12
Garuda (2.5.3-1):
System install date:     2022-01-30
Last full system update: 2022-01-31
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:

Again.

Hello.

Post your terminal/konsole in- and output as text (no pictures) from:

garuda-inxi

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.

4 Likes

From your previous thread, Monitor not working after running xrandr

Do the DE's display settings not help here?

1 Like

BTW, define your "future"

4 Likes

To be fair, he didn't say when in the future... :joy:

5 Likes

no, nothing of what i have tried worked, but i can always give it another look ig, also the colour is off before i run xrandr.

This is just as helpful as the missing issue of garuda-inxi in the first post.

I am quite calm,
it breathes me,
nothing can shake me,
I feel better from day to day.

I am completely calm,
...

2 Likes

Ive tried the different resolutions, but as the colour is off as well i dont think thats the problem, and i have googled around but xrander is the only "real" solution ive found. What is garuda-inxi?

like this? `[email protected]
.%;888:8898898: ----------------------------
x;XxXB%89b8:b8%b88: OS: Garuda Linux
.8Xxd 8X:. Host: Latitude E7470
.8Xx; 8x:. Kernel: 5.16.3-zen1-1-zen
.tt8x .d x88; Uptime: 5 hours, 10 mins
.@8x8; .db: [email protected]; Packages: 1447 (pacman)
,tSXX° [email protected]; Shell: bash
.SXxx bBBBBBBBBBBBBBBBBBBBbSBX8; DE: Plasma 5.23.5
,888S pd! WM: KWin
8X88/ q WM Theme: Sweet-Dark
GBB. Terminal: konsole
x%88 [email protected]@[email protected]@[email protected]@XX@@X@[email protected] CPU: Intel i5-6300U (4) @ 3.0GHz
dxXd dB8b8b8B8B08bB88b998888b88x. GPU: Intel Skylake GT2 [HD Graphics 520]
dxx8o [email protected]@;. Memory: 4.91GiB / 15.30GiB
dx88 [email protected]
d:[email protected]
.d988999889889899dd.

[email protected] in ~
λ xrandr --output eDP1 --auto

[email protected] in ~ took 4ms
λ xrandr --output HDMI1 --auto

[email protected] in ~ took 59ms
λ xrandr --output HDMI1 --auto

[email protected] in ~ took 68ms
λ`?

or should it be the output from garuda -inix?

No, this is taken from the terminal on the right when you open it (neofetch).
You should type garuda-inxi and copy the result here, with
~~~
before and after that text block.

its on the post now :slight_smile:

Maybe you could start from here and create a proper /etc/X11/xorg.conf.d/10-monitor.conf based on the suggestions here:
https://wiki.archlinux.org/title/Xrandr#Permanently_adding_undetected_resolutions
It is going to be a little challenging, but it could be a good learning exercise...

PS: I took the freedom to format your inxi as suggested above with ~~~
:slight_smile:

1 Like

i tried going to the folder and right click create new, but i cant click it, and after googleing how to create a folder from the terminal i found the touch command, however it gives me this error touch: cannot touch '10-monitor.conf': Permission denied

sudo micro /etc/X11/xorg.conf.d/10-monitor.conf

If needed check how to use micro here

2 Likes

is there a good way to see what options my monitor is using?

Maybe

xrandr -q

could help...
Read also that wiki page in general, and maybe also
https://wiki.archlinux.org/title/Multihead

1 Like

i've read the article and watched a yt tutorial on how to do it, I made a conf file which sets the resolution to 1920x1080, but this isnt fixing it, the colour is still off and its a bit zoomed in, is there any command/tool which i could use to automatically create a conf file from my current xrandr settings?

As far as I can say, as an alternative approach, you could consider using Autostart in the System Settings and add an application launching xrandr --output eDP1 --auto.
The same you could do with a login script or a systemd service.

2 Likes

i guess, but that would still make the login screen have the bad settings? I'll try to look into it more tomorrow and if u cant find how to do it from the conf file i guess ill have to resort to this

For this, you should check this

which you could use also for your xrandr --output eDP1 --auto if necessary... but probably is already handled there.

3 Likes