Monitor not working after running xrandr

Earlier to day i noticed that my screen seemed a bit zoomed in, and i could only see about the bottom half the the icons at the top, so i did a quick google and the xrandr command came up.

I ran zrandr -s 0, which fixed my screen being zoomed in, but the laptop screen went black and i cant find it in the settings. I tried to fix this by restarting the machine. at the login screen both screens were working but they were mirrored which isnt what it did before, and when logging in, the laptop monitor went black again, and my main monitor returned to being zoomed in.

So my question is, how do i get the laptop monitor to display again and is there a permanent solution to fix the zoomed in screen on the main monoitor?

i got the laptop monoitor to display again using xrandr to set its display mode, the external monitor is not showing up in the settings and is just mirroring the laptop screen

Both are now showing up in the settings, but they are still mirroring even though replica is set to none

Normally the best approach to setting monitor resolutions and arrangements is to use the DE's display settings.

You haven't provided any of the information requested in the template text so I assume you'll be able to work out where those are yourself?


Yep, ill do that in the future. Do you have any ideas on how i can get it to not mirror the screens?

Disable that option, or set the screens to "extend" or "join" or whatever.


it works now :slight_smile: ty

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.