Missing windows decorations for Sweet-Dark theme and similars

Good evening to everybody!
I recently installed Garuda Linux KDE Dragonized (love it!) and I am experiencing an issue with windows decorations.
If I choose the Brezza theme, everything is ok as in the image below:

Though if I swich to Sweet-Dark theme (and similars, as Sweet Ambar Blue Aurorae, Sweet Mars KDE, etc...), windows decorations are not shown as well as windows control buttons:

I also experience a little bug when a windows is maximized: the central violet button is missing; I don't know if this issue is somehow related to the previous one:

Finally, my system data:

Kernel: 6.0.10-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=0ef4bf53-8eab-4c2e-8bf2-8e5b3822e8f7 rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=a6f35b6b-c465-4161-9912-7f938f40809a loglevel=3
Desktop: KDE Plasma v: 5.26.3 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: PC Specialist product: Vyper 15 v: Standard
serial: <superuser required>
Mobo: Tong Fang model: GJ5CN6E v: Standard serial: <superuser required>
UEFI: American Megatrends v: N.1.03 date: 08/31/2018
ID-1: BAT0 charge: 35.3 Wh (100.0%) condition: 35.3/46.7 Wh (75.6%)
volts: 12.7 min: 11.4 model: standard type: Li-ion serial: <filter>
status: full
Info: model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Coffee Lake
gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF0
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 9 MiB desc: 1x9 MiB
Speed (MHz): avg: 1470 high: 2200 min/max: 800/4100 scaling:
driver: intel_pstate governor: powersave cores: 1: 1000 2: 974 3: 1000
4: 900 5: 900 6: 2200 7: 900 8: 971 9: 2200 10: 2200 11: 2200 12: 2200
bogomips: 52799
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630]
vendor: Tongfang Hongkong driver: i915 v: kernel arch: Gen-9.5
process: Intel 14nm built: 2016-20 ports: active: eDP-1 empty: none
bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile]
vendor: Tongfang Hongkong driver: nvidia v: 520.56.06
alternate: nouveau,nvidia_drm non-free: 520.xx+
status: current (as of 2022-10) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-21 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1c20
class-ID: 0300
Device-3: Acer HD Webcam type: USB driver: uvcvideo bus-ID: 1-13:4
chip-ID: 5986:069e class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1182x380mm (46.54x14.96")
s-diag: 1242mm (48.88")
Monitor-1: HDMI-1-0 pos: primary,top-left res: 2560x1440 hz: 60 dpi: 109
size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
Monitor-2: eDP-1 pos: bottom-r res: 1920x1080 hz: 60 dpi: 142
size: 344x193mm (13.54x7.6") diag: 394mm (15.53") modes: N/A
API: OpenGL v: 4.6 Mesa 22.2.3 renderer: Mesa Intel UHD Graphics 630 (CFL
GT2) direct render: Yes
Device-1: Intel Cannon Lake PCH cAVS vendor: Tongfang Hongkong
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:10f1 class-ID: 0403
Sound API: ALSA v: k6.0.10-zen2-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.60 running: yes
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Tongfang Hongkong driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-2: Intel Wireless-AC 9260 vendor: Rivet Networks driver: iwlwifi
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 04:00.0
chip-ID: 8086:2526 class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb
v: 0.8 bus-ID: 1-14:6 chip-ID: 8087:0025 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 3 state: up address: <filter>
Local Storage: total: 1.39 TiB used: 183.18 GiB (12.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDS500G2X0C-00L350 size: 465.76 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 101110WD temp: 44.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM049-2GH172
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: SDM1 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: SanDisk model: USB 3.2Gen1
size: 14.32 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: Verbatim model: STORE N GO
size: 14.92 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: 1.01 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-1: / raw-size: 100 GiB size: 100 GiB (100.00%) used: 14.71 GiB (14.7%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 608 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 317.26 GiB size: 317.26 GiB (100.00%)
used: 28.22 GiB (8.9%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-4: /var/log raw-size: 100 GiB size: 100 GiB (100.00%)
used: 14.71 GiB (14.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 100 GiB size: 100 GiB (100.00%)
used: 14.71 GiB (14.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 48 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: swap-2 type: zram size: 31.24 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 51.0 C pch: 63.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 377 Uptime: 9h 34m wakeups: 3 Memory: 31.24 GiB
used: 8.01 GiB (25.7%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
pkgs: 1415 libs: 349 tools: octopi,paru Shell: fish v: 3.5.1
running-in: konsole inxi: 3.3.23
Garuda (2.6.9-1):
System install date:     2022-11-26
Last full system update: 2022-11-27 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

Try if reboot help, its KDE :smiley:

1 Like

Thanks, I have tried it: solved the bug when a window is maximized, now the central violet button is shown properly.
Still experiencing the issue with Sweet-Dark theme

Trying to deeper investigate the issue, I set up a virtual machine using the same ISO file as the one I used to install my primary OS and ran it live (proprietary drivers):

On the left the primary system without any windows border decorations and control buttons; on the right the virtual machine with the same theme (Sweet-Dark), but with properly displayed windows decorations and control buttons.

Create a new user on the system and log in as the new user to test if the issue persists between different local profiles.

1 Like

Thanks for the suggestion. I tried to create a new user, but sadly the issue still exists even with the new user.

I used diff to compared the contents of my system's /etc and /usr with those given here and I couldn't find any differences...

Maybe a reinstallation could help

sudo pacman -S sweet-theme-full-git sweet-gtk-theme-dark

Or try to uninstall and reinstall your theme in the system settings.

1 Like

Thanks for the suggestion. I get the following error:

sweet-theme-full-git and sweet-gtk-theme are in conflict

I tried reinstalling sweet-theme-full-git only, but nothing changed—the problem remains the same.

Did you try to log out and log in again? Sometimes window decorations don't apply correctly without a new login. When I change my theming the window decorations sometimes do not apply. I have to log out and log in again.

Yes, I log out and log in again, without any effect.
I noticed yet another odd behavior, I am not sure if it has anything to do with the Sweet-Dark theme issue. I am forced to use Brezza theme in place of Sweet-Dark because I cannot utilize and have windows decorations with Sweet-Dark. However, if I right click on a window's title bar, a blurred panel the size of the entire screen appears, no context menu:

Searching on the forum for similar related issue, I came across this one (first two items in the list), but no solution found. :slightly_frowning_face:

Bit of a shot in the dark here and there's a high chance these aren't the cause of the issue, but I reckon it's worth checking anyways.

In /usr/share/aurorae/themes/Sweet-Dark, are all the files present? I mainly ask this because I've noticed with other themes that if they don't have the appropriate file for a button, the button won't appear since it has nothing to use and no default to fall back on.
Here is what the folder should look like.

and Sweet-Darkrc should contain this:



Other than that, have you tried hitting alt+F3 and seeing whether more actions -> no border will do anything?
Have you also tried playing around with the compositor settings, such as accurate vs smooth scaling methods? I'm not sure if the compositor has any relation to window decorations, but you never know. It might solve the blur issue mentioned in your last post. :slight_smile:


i really appreciate the suggestions. :grinning:
All the files are present, and the Steet-Darkrc is set up as you instructed when I checked /usr/share/aurorae/themes/Sweet-Dark.
I attempted to use the compositor (Settings -> Display and video -> Compositor), but it had no noticeable impact.

1 Like

After days googling the issue, I found this: it appears to have something to do with Wayland and screen scaling (I use a secondary HiDPI monitor). I tried changing the scale to 106.25% and now everything works as it should: windows decorations are available with Sweet-Dark theme and a right click on a title bar opens a context menu (the issues were correlated indeed!). :partying_face:

The downside is that I lost some windows' blurred transparency, like Dolphin, as in the screenshot. Is there any way to restore the original blurred transparency?

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.