Fresh Install - no title bars

Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=232fced4-2c05-4e08-adb4-516f41f8f144 rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=1219109d-a128-4501-9e49-a71a1fc9bf9a loglevel=3
Desktop: KDE Plasma v: 5.26.2 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: ASUSTeK model: PRIME B250M-A v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 1205
date: 05/11/2018
ID-1: hidpp_battery_0 charge: 76% condition: N/A volts: 4.0 min: N/A
model: Logitech G Pro Wireless Gaming Mouse type: N/A serial: <filter>
status: discharging
Info: model: Intel Core i5-7400 bits: 64 type: MCP arch: Kaby Lake
gen: core 7 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 9 microcode: 0xF0
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 800 min/max: 800/3500 scaling: driver: intel_pstate
governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 bogomips: 24000
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT disabled
Type: retbleed mitigation: IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Device-1: Intel HD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel
arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: HDMI-A-3
empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 0000:00:02.0
chip-ID: 8086:5912 class-ID: 0300
Device-2: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: Micro-Star MSI driver: amdgpu v: kernel arch: GCN-4
code: Arctic Islands process: GF 14nm built: 2016-20 ports:
active: HDMI-A-4,HDMI-A-5 empty: DP-3,DP-4,DVI-D-1 bus-ID: 0000:01:00.0
chip-ID: 1002:67df class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_x11 driver: X: loaded: amdgpu,modesetting
alternate: fbdev,intel,vesa dri: iris,radeonsi gpu: amdgpu,i915
display-ID: :0 screens: 1
Screen-1: 0 s-res: 4480x900 s-dpi: 96 s-size: 1184x237mm (46.61x9.33")
s-diag: 1207mm (47.54")
Monitor-1: HDMI-A-3 mapped: HDMI-3 pos: center model: Asus VH196
serial: <filter> built: 2009 res: 1440x900 hz: 60 dpi: 89 gamma: 1.2
size: 410x256mm (16.14x10.08") diag: 483mm (19") ratio: 16:10 modes:
max: 1440x900 min: 720x400
Monitor-2: HDMI-A-4 mapped: HDMI-A-1-3 pos: primary,left model: HP 2009
serial: <filter> built: 2009 res: 1600x900 hz: 60 dpi: 92 gamma: 1.2
size: 442x249mm (17.4x9.8") diag: 507mm (20") ratio: 16:9 modes:
max: 1600x900 min: 720x400
Monitor-3: HDMI-A-5 mapped: HDMI-A-1-4 pos: right
model: ViewSonic VA1930wm serial: <filter> built: 2006 res: 1440x900 hz: 60
dpi: 89 gamma: 1.2 size: 410x260mm (16.14x10.24") diag: 485mm (19.1")
ratio: 16:10 modes: max: 1440x900 min: 720x400
OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 22.2.1
direct render: Yes
Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 1-5:4 bus-ID: 0000:00:1f.3
chip-ID: 31b2:0011 chip-ID: 8086:a2f0 class-ID: 0300 class-ID: 0403
serial: <filter>
Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 0000:01:00.1
chip-ID: 1002:aaf0 class-ID: 0403
Device-3: DCMT USB Condenser Microphone type: USB
driver: hid-generic,snd-usb-audio,usbhid
Device-4: Dell AC511 Sound Bar type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-7:6 chip-ID: 413c:a503
class-ID: 0300
Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel port: d000
bus-ID: 0000:03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Hardware-1: Intel SATA Controller [RAID mode] driver: intel_nvme_remap
v: N/A port: f060 bus-ID: 0000:00:17.0 chip-ID: 8086:2822 rev:
class-ID: 0104
Device-1: md127 maj-min: 9:127 type: mdraid level: N/A status: inactive
size: N/A
Info: report: N/A blocks: 2944 chunk-size: N/A
Components: Online: N/A Spare:
0: nvme0n1 maj-min: 259:0 size: 13.41 GiB state: S
Local Storage: total: 2.43 TiB used: 10.49 GiB (0.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: MEMPEK1W016GA
size: 13.41 GiB block-size: physical: 512 B logical: 512 B type: SSD
serial: <filter> rev: K3110310 temp: 50.9 C
ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: DT01ACA200
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: ABB0 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Samsung model: HM641JI
size: 596.17 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: HDD rpm: 5400 serial: <filter> rev: 0003 scheme: GPT
ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: Corsair
model: Flash Voyager size: 15.06 GiB block-size: physical: 512 B
logical: 512 B type: SSD serial: <filter> rev: 0.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-1: / raw-size: 1.79 TiB size: 1.79 TiB (100.00%) used: 10.49 GiB (0.6%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
(0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 1.79 TiB size: 1.79 TiB (100.00%) used: 10.49 GiB
(0.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 1.79 TiB size: 1.79 TiB (100.00%) used: 10.49
GiB (0.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 1.79 TiB size: 1.79 TiB (100.00%) used: 10.49
GiB (0.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 23.35 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 25.69 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda3 maj-min: 8:3
System Temperatures: cpu: 53.0 C mobo: N/A gpu: amdgpu temp: 54.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 207
Processes: 251 Uptime: 41m wakeups: 2 Memory: 23.35 GiB used: 9.38 GiB
(40.2%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1141 libs: 302
tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.22
Garuda (2.6.9-1):
System install date:     2022-11-06
Last full system update: 2022-11-06 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:
McFly: Importing shell history for the first time. This may take a minute or two...done.

After an update I suddenly had no title bars and my snapshots weren't there for some reason. Whatever no big deal, I tried setting the Latte > details > hide window border off, but didn't work. I tried setting Window Management > Window Rules to No Title Bar or Frames to Force No and that didn't work either.

I did a fresh install of Garuda and the titlebars still don't exist except for the Garuda Setup Assistant.

I'm not sure where to go to get the bar back from this point...

1 Like

Welcome :slight_smile:

First, reboot.
Second, try restore latte with garuda-assistant

Last, if no bar is visible, start latte-dock from terminal and switch to new or old settings.

Killed and restarted latte dock from the terminal - no change.

Added new dragonized, extended, unity, default, and plasma layouts none of which made the title bars appear.

Maybe, no, I am sure, I made a translation mistake. Sorry.

Its somewhere in the KDE Sytem Settings, I just can’t remember.
Did you search in the forum about?

I went to .config and deleted everything that had "plasma" in the name and the latte folder then reset - no change.

Please, post full ISO name.

There must be a reason.
Maybe other forum members can help you here.

I installed the most recent from torrent which seems to be: garuda-dr460nized-linux-zen-221019.iso

Someone might be able to help with the snapshots but that install and potential data is gone now so it seems a moot point. The new install is pulling up snapshots and the snapshots issue and missing title bar issue seem different since the title bar issue persisted through installs.

I tried downloading the dragonized gaming edition and noticed that even on the live boot the title bars are still missing.

I have a similar issue post update. First occurred around middle October (think it was 24th or even before that)... I restored my snapshot and continued working sans updates. Installing the updates results in a desktop environment that is badly broken.

Some of these issues have been addressed or are less severe as of 2022-11-06, here is the list of issues:

  1. Title bar missing (can get it to a semi-working condition by changing the window decoration from Sweet-Dark to Breeze -> Close, Full Screen, Minimize controls will be available, but nothing else);
  2. Right-Click Desktop Context menu is full screen and blank (no work-around or fix found since mid October);
  3. Running Garuda-Assistant crashes the desktop (also when doing so via terminal... a full screen black box slides in from bottom left, occupies the whole desktop, like a lay-over darkening everything else, then desktop crashes resulting in no terminal output being accessible);
  4. Opening a number of applications yield the same result / issue (namely a desktop crash -> must move to alternate terminal CTRL+F2, login as root and kill xorg to recover) and applications that do run yield QT and shared library errors...

Would be great if you could check / confirm for any of these issues as I suspect they are all related...


I haven't seen any crashing issues from garuda-assistant or any other applications actually; my context menu has performed normally without making itself fullscreen.

Changing to Breeze did make the title bar reappear with the close, full screen, and minimize buttons like you said; thank you for that. So does this mean the root issue is in the sweet configuration, or something with KDE?

looks like a configuration issue yes... my full screen context menu has something to do with fonts, as when I start messing with it the size and aspect ratio of the context menu changes, and then if I get lucky I get a normal context menu.

It might be an incompatibility or clash with KDE Plasma, Latte and some other programs around themes where these issues lie...

You where right when you said it has something to with fonts. The problems seams to stem from Anti-Aliasing from all thing. I discovered it by pure luck. But if you turn it off everything works as intended. But text looks bad as expected.

Yes, I also did that, but the issue persists... after reboot everything was broken again. Applying the same settings for the "fix" doesn't fix it again, I needed to select yet another font to get the interface working. Used "Terminus" mono space font on the second round.

I also deleted a load of config (kde, plasma, fontconfig, etc) files and reset to defaults using Garuda Assistant, but it only worked once... then reverted to broken state after reboot and apllying the same steps did not "fix" it again. So my guess is a clash between different apps/systems.

So I am back to my mid October snapshot... with a text-wall of pending updates and screaming alerts :face_with_spiral_eyes:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.