Missing Menu Bars

I'm setting up Garuda and noticed I do not have, nor can I enable any menu bars. I have rightclicked I don't know how many times on various apps to only find no setting to show the menu bar. Does anyone have a fix for this? Thanks

Which time is that?
Maybe it's one more like this?

Garuda uses Latte-dock at the top to handle Applications menu in Plasma desktop. Does this help? :grinning_face_with_smiling_eyes:

2 Likes

I'll have another look at the Latte settings, but I don'r remember seeing anything about the menu bars on secondary applications.

I just went through Latte's settings more times and there is nothing about the menu bars for the various applications. I'm back in EOS right now which has the same settings for Latte as in Garuda and I have my menu bars.

  1. Press Ctrl+Esc and check for a latte-dock instance running.
  2. RightClick on the bottom panel to check if it is a Latte-dock or a Standard Plasma panel.
  3. If latte-dock is running (1) and bottom panel is a latte-dock, choose a Unity profile for Latte, or create a new panel, place it at the top and add an appmenu widget.
  4. If latte-dock is running and bottom panel is a plasma panel, kill/terminate latte-dock. Then start latte-dock from kRunner (Alt+F2), following (3) advice.
  5. If latte-dock is not running, start latte-dock as in (3) and follow (2)
  6. Or... start System Settings and go to Window decoration. Add Applications menu button at Window border.

Or something else, if all the above fail.

6 Likes

OK so I should of left the appmenu widget. Easy fix. Thanks

Once I go back into Garuda and add that I'll let you know what I got. Thanks again.

2 Likes

OK back in Garuda and just realized I already have the default app menu that came with Latte that I just replaced with application menu. Rightckicked it, configure and there is noting about adding menu bars to the open applications. I'm going to have one more go at Google.

Side note the bottom panel was Plasma. I only created it to check some settings.

EDIT:

Just checked Firefox and the normal add menu bar by rightclicking the title bar isn't there either.

JUst found the below it added the menu bar back to Konsole and MKVToolNix.

cd ~/.config
sed -i 's/MenuBar=Disabled/MenuBar=Enabled/' *rc
1 Like

Good morning, some one must have some idea how to get the rest of the menu bars.

If you don't want appmenus, why not start with the Barebones edition? Otherwise, latte-dock-git is what handles most of the top panel appmenus, as long as you have them also installed. It's really difficult to break-down, piece by piece, someone else's work, you know.

3 Likes

I can't justify changing to the barebones edition over one minor component of LattDock?

I'm in EOS now and LatteDock is a panel with Tiled Menu(not Applications Menu), Display Configuration, Icons Only Task Manager, Gealech, Digital Clock, Systray, Pager, Show Desktop, Lock/Logout. All my apps have their menu bars without the use of Applications Menu. So from what I can determine Applications Menu is not the issue. The screenshot below is from EOS and everything there has it's Menu Bar.

Now I did also notice that Pamac in Garuda does not have it's minimize, maximize, close buttons while everything else does. I'm betting the two issues are related.

I just checked Firefox to confirm my experience. To get the Menu Bar back, right click on the right side of the tabs. The Menu Bar is the fifth item on the list. From time to time, I have had the same problem.

I run KDE and I prefer Plasma and its panels.

gary

2 Likes

I stuck with Latte in Garuda cause I like the idea of having one docking system for everything. Here in EOS a dock to replace the default Plasma panel, then two KSmoothdock docks that were created long before replacing the Plasma panel. First one on the left browsers, email, messaging, Second one on the right the apps that I would normally pin to the main panel. Created it to make the main panel look cleaner. Now that I'm use to how to set up Latte I really don't want to switch back to Plasma panels.

@petsam @c00ter @petsam booted back into Garuda checked Dolphin and Firefox still no way to add the Menubars back. Just got 216 updates, rebooted, check to see if it was back in the rightclick menu and it is. So looks like in the process of trying to fix Latte to my liking I broke something that today's updates fixed. Thank all 3 of you for trying to help, it's greatly appreciated.

1 Like

I decided to boot into the live environment and see if there were menu bars for the KDE apps and there are none. This means the issue wasn't something I did, but rather a deliberate removal those menu bars prior to the creation of the ISO.

Most live ISO's do not use panels. In KDE, right click on the Desktop, look towards the bottom, and find Add Panel, highlight it. It will display a list of 6 different panels that you can use. Try them all, customize it.

1 Like

Again this is not about the Plasma panel or LatteDock. This is about menu bars in open apps. The menu bars are not controled by the Plasma pane or LatteDock. The below image is from within the live environment.

This ended up being more of a pain in the ass than it should of been. Turns out a combination of getting rid of the Applications Menu on LatteDock, performing the below in Konsole, and then reboot to have the Menu Bars back.

cd ~/.config
sed -i 's/MenuBar=Disabled/MenuBar=Enabled/' *rc
2 Likes

We appreciate better solutions to old issues, but it is better to not necrobump old solved issues.