Mirror laptop screen

Hey so this may be a bad question that seems obvious to some but I've tried googling for the answer and going through the display settings for KDE. I'm on most up-to-date build and packages and am trying to 1 for 1 mirror my laptop screen on the TV. By default it shows a different screen like a second monitor but then I tried using the replica option to replicate the laptop screen to the HDMI input of the TV. But that screw's up the aspect ratio and has things like the dock bar towards the middle left of the screen. Is there an option to just make it like when you plug a laptop into a TV or monitor like how Windows does it by default? Thanks

Read

please
and post terminal in- and output from

inxi -Fza

as text!

Even if you personally think it is unnecessary.

Thanks, too.

2 Likes

Even in Windows I had to log-out and log-in. Even now in my brother's laptop this is the same.

For me this problem doesn't exist now (using noveau driver). I would suggest trying relogging, if not, rebooting.

2 Likes

AFAIK Windows don't have Latte-dock.

Have you tried connecting the same laptop with the same resolution as in Garuda and then Windows changes the resolution or the aspect ratio to a new one?

KDE/Plasma has a feature that when you plug in an external monitor, a popup asks you to select what do you want to do, with several options.
Didn't that work in your case? If not, we have to find if it's a configuration problem or a bug.

As already requested, read instructions for how to provide useful info to help us help you fix your problem.

1 Like

Sorry I'm not at my laptop currently but will get the information necessary soon. Not sure if there's a misunderstanding which is my fault for how I explained it. But basically, on Windows, plug a laptop into your TV with HDMI and you'll see it is mirroring exactly what is on the laptop screen. On Linux, it shows what seems like a blank wallpaper (maybe setup as a second monitor of sorts?) What I want is to basically mirror laptop on TV just like Windows does by default.

Then select this on the KDE-screen popup. If there is no popup on adding external cable, press Meta/Win+P

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.