Minecraft doesnt start

Hi, I installed the minecraft launcher via add/remove Software and it shows the launcher in the app thing but i cant start it. It just does nothing and i didnt find another way to install it. probably thats a dum question with an easy answer so i am sorry.

Did you install a compatible Java runtime?

What output do you get if you run the command in a terminal?

3 Likes

is that what you mean?

╭─[email protected] in repo: minecraft-launcher on  master [!?] took 2ms
╰─λ ./minecraft-launcher.desktop
Icon theme "gnome" not found.

╭─[email protected] in repo: minecraft-launcher on  master [!?] took 190ms
╰─λ
(code:47440): Gtk-WARNING **: 20:41:03.238: Theme parsing error: gtk-dark.css:5822:26: '-shadow' is not a valid colorname

(code:47440): Gtk-WARNING **: 20:41:03.238: Theme parsing error: gtk-dark.css:5825:14: not a number

(code:47440): Gtk-WARNING **: 20:41:03.238: Theme parsing error: gtk-dark.css:5826:13: not a number

(code:47440): Gtk-WARNING **: 20:41:03.238: Theme parsing error: gtk-dark.css:5827:11: Expected a length
[47502:1228/204103.445670:ERROR:vaapi_wrapper.cc(1068)] vaQuerySurfaceAttributes failed, VA error: invalid parameter
[47502:1228/204103.445847:ERROR:vaapi_wrapper.cc(1015)] FillProfileInfo_Locked failed for va_profile VAProfileH264Main and entrypoint VAEntrypointVLD
[47502:1228/204103.445902:ERROR:vaapi_wrapper.cc(1068)] vaQuerySurfaceAttributes failed, VA error: invalid parameter
[47502:1228/204103.445956:ERROR:vaapi_wrapper.cc(1015)] FillProfileInfo_Locked failed for va_profile VAProfileH264High and entrypoint VAEntrypointVLD
[main 2021-12-28T19:41:03.490Z] update#setState idle
[main 2021-12-28T19:41:03.558Z] ExtensionHostStarterWorker created
[main 2021-12-28T19:41:04.707Z] Starting extension host with pid 47593 (fork() took 14 ms).
[main 2021-12-28T19:41:12.458Z] Waiting for extension host with pid 47593 to exit.
[main 2021-12-28T19:41:13.198Z] Extension host with pid 47593 exited with code: 0, signal: null.

and it opens a text document

How did you install minecraft-launcher ? Why are you in a git repo with that name? :face_with_raised_eyebrow:

Not really - there should be an executable file installed by the package. A .desktop file is a desktop application launcher (which describes various bits of information, e.g. the icon to be shown in menus and the executable file to be run).

3 Likes

I installed it from the arch wiki following this guide:

All the Arch wiki says is that

OK, but what did you do?

There are also two questions and a pointer that you have overlooked from above, please go back and review.

3 Likes

the first thing i tried was installing it with add/remove software but that didnt work so i tried the video
well in the viedo he said to do git clone AUR-link and then makepkg -si. I guess that solves why its agit repo.

java -version
openjdk version "17.0.1" 2021-10-19
OpenJDK Runtime Environment (build 17.0.1+12)
OpenJDK 64-Bit Server VM (build 17.0.1+12, mixed mode)

The folder contains:

╭─[email protected] in repo: minecraft-launcher on  master [!?]
╰─λ ls
drwxr-xr-x    - muddy 28 Dec 20:02  .git
drwxr-xr-x    - muddy 28 Dec 20:03  pkg
drwxr-xr-x    - muddy 28 Dec 20:03  src
.rw-r--r--   55 muddy 28 Dec 20:02  .gitignore
.rw-r--r-- 1.3k muddy 28 Dec 20:02  .SRCINFO
.rw-r--r-- 577k muddy 28 Dec 20:03  minecraft-launcher-928-1-x86_64.pkg.tar.zst
.rwxr--r--  271 muddy 28 Dec 20:05  minecraft-launcher.desktop
.rw-r--r--  62k muddy 28 Dec 20:03  minecraft-launcher.svg
.rw-r--r-- 547k muddy 28 Dec 20:03  minecraft-launcher_928.tar.gz
.rw-r--r-- 1.4k muddy 28 Dec 20:02  PKGBUILD
.rw-r--r-- 1.4k muddy 28 Dec 20:02  PKGBUILD.template
.rw-r--r-- 1.3k muddy 28 Dec 20:02  SRCINFO.template
1 Like

OK, that makes sense, and the other good thing is you've found out how to install AUR packages "the Arch way" (using makepkg). :wink:

Next, let's find out the name of the script installed that runs the launcher, and then try running it.

pacman -Ql minecraft-launcher

If that list is too long, look for files installed under /usr/bin (which is where most executables are placed:

pacman -Ql minecraft-launcher | grep usr/bin

That should provide you with an executable to run, e.g. /usr/bin/minecraft-launcher - run that in a terminal and check the output.

1 Like

ok think thats it

usr/bin/minecraft-launcher
terminate called after throwing an instance of 'std::logic_error'
what():  basic_string::_M_construct null not valid
fish: Job 1, '/usr/bin/minecraft-launcher' terminated by signal SIGABRT (Abort)

1 Like

On testing the launcher, it seems to be working for me...

Just to rule it out, could you run it using bash?

bash -c /usr/bin/minecraft-launcher

Are you fully up-to-date?

1 Like

It even newer than uptodate

warning: garuda-settings-manager-git: local (1.0.0.r1.g15c4106-3) is newer than chaotic-aur (1.0.0.r1.g15c4106-1)
warning: garuda-settings-manager-kcm-git: local (1.0.0.r1.g15c4106-3) is newer than chaotic-aur (1.0.0.r1.g15c4106-1)

Ok changed the terminale and the error did change

/usr/bin/minecraft-launcher
terminate called after throwing an instance of 'std::logic_error'
what():  basic_string::_M_construct null not valid
Aborted (core dumped)
1 Like

This throws up some hits.

Can you try

LC_ALL=C /usr/bin/minecraft-launcher

?

If this works then it's this issue:

and you need to fix your locale settings. :grin:

2 Likes

Thanks that was the problem! how can i fix the locale settings?

Make sure that the first two steps from https://wiki.archlinux.org/title/Installation_guide#Localization are in place.

(The wiki link gives the minimal steps needed, you'll need to use your brain to work out the locale setting you want :stuck_out_tongue_winking_eye:)

These are my locale settings:

LANG=en_US.UTF-8
LC_ADDRESS=de_DE.UTF-8
LC_IDENTIFICATION=de_DE.UTF-8
LC_MEASUREMENT=de_DE.UTF-8
LC_MONETARY=de_DE.UTF-8
LC_NAME=de_DE.UTF-8
LC_NUMERIC=de_DE.UTF-8
LC_PAPER=de_DE.UTF-8
LC_TELEPHONE=de_DE.UTF-8
LC_TIME=de_DE.UTF-8

is it the problem that they dont match up? Like some german and some englisch?

Maybe - I haven't mixed locales, so you could try making them the same, but before doing that make sure that both

de_DE.UTF-8 UTF-8
...
en_US.UTF-8 UTF-8

are uncommented in /etc/locale.gen and then run sudo locale-gen . If that doesn't help then edit /etc/locale.conf and see if it helps. If none of those help then it's likely something in your DE, I seem to remember that KDE has its own way of setting the active locale...

1 Like

Ok they werent uncommented in locale.gen.
i tried starting now with /usr/bin/minecraft-launcher and it work but then died

/usr/bin/minecraft-launcher
https://launchermeta.mojang.com/v1/products/launcher/6f083b80d5e6fabbc4236f81d0d8f8a350c665a9/linux.json
terminate called after throwing an instance of 'std::logic_error'
what():  basic_string::_M_construct null not valid
https://launchermeta.mojang.com/v1/products/launcher/6f083b80d5e6fabbc4236f81d0d8f8a350c665a9/linux.json

(process:55190): Gtk-WARNING **: 21:36:50.756: Locale not supported by C library.
Using the fallback 'C' locale.

(minecraft-launcher:55190): Gtk-WARNING **: 21:36:50.780: Theme parsing error: gtk-dark.css:5822:26: '-shadow' is nota valid color name

(minecraft-launcher:55190): Gtk-WARNING **: 21:36:50.780: Theme parsing error: gtk-dark.css:5825:14: not a number

(minecraft-launcher:55190): Gtk-WARNING **: 21:36:50.780: Theme parsing error: gtk-dark.css:5826:13: not a number

(minecraft-launcher:55190): Gtk-WARNING **: 21:36:50.780: Theme parsing error: gtk-dark.css:5827:11: Expected a length
OK
https://launchermeta.mojang.com/v1/products/launcher/6f083b80d5e6fabbc4236f81d0d8f8a350c665a9/linux.json
terminate called after throwing an instance of 'std::logic_error'
what():  basic_string::_M_construct null not valid

Can I assume you also ran sudo locale-gen and it didn't output any error?

Try logging out and in (or rebooting) to make sure the new locales are known to the session.

It might also be useful to have a read through Locale - ArchWiki in case I'm missing something...

yes it didnt.
I just rebooted but still the same error.
I will look into the wiki if i can find anything but atleast i can start minecraft with LC_ALL=C

1 Like

Grand. As I say, it could be a KDE setting so make sure to check there too.

2 Likes