McFly no such table error

Hello! I just finished a fresh Garuda install to solve some issues i was having, which it did thankfully. However everytime i run Alacritty i get this error at the end.

McFly: Upgrading McFly DB to version 3, please wait...thread 'main' panicked at 'McFly error: Unable to add cmd_tpl to commands (no such table: commands)', src/history/schema.rs:41:17
note: run with `RUST_BACKTRACE=1` environment variable to display a backtrace

INXI

System:
  Kernel: 5.19.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=855a40ff-2fe4-4d97-a9f3-4e5d5c058c2c rw rootflags=[email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: STRIX Z270E GAMING v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 0906
    date: 03/22/2017
CPU:
  Info: model: Intel Core i7-7700K bits: 64 type: MT MCP arch: Kaby Lake
    gen: core 7 built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158)
    stepping: 9 microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 800 min/max: 800/4500 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800
    8: 800 bogomips: 67200
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
Graphics:
  Device-1: NVIDIA GP104 [GeForce GTX 1080] driver: nvidia v: 515.65.01
    alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current (as of
    2022-07) arch: Pascal code: GP10x process: TSMC 16nm built: 2016-21 pcie:
    gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1b80
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
    alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 4080x2013 s-dpi: 107 s-size: 969x478mm (38.15x18.82")
    s-diag: 1080mm (42.54")
  Monitor-1: DP-0 pos: primary,middle-c res: 1920x1080 hz: 60 dpi: 82
    size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
  Monitor-2: DP-2 pos: bottom-l res: 1080x1920 hz: 60 dpi: 93
    size: 296x527mm (11.65x20.75") diag: 604mm (23.8") modes: N/A
  Monitor-3: DP-5 pos: top-right res: 1080x1920 hz: 120 dpi: 82
    size: 336x598mm (13.23x23.54") diag: 686mm (27.01") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 1080/PCIe/SSE2 v: 4.6.0 NVIDIA
    515.65.01 direct render: Yes
Audio:
  Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 1-1:2 bus-ID: 00:1f.3
    chip-ID: b58e:9e84 class-ID: 0300 chip-ID: 8086:a2f0 class-ID: 0403
    serial: <filter>
  Device-2: NVIDIA GP104 High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:10f0 class-ID: 0403
  Device-3: Blue Microphones Yeti Stereo Microphone type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Device-4: Creative Sound Blaster X3 type: USB
    driver: cdc_acm,hid-generic,snd-usb-audio,usbhid bus-ID: 1-6:5
    chip-ID: 041e:3264 class-ID: 0102 serial: <filter>
  Sound Server-1: ALSA v: k5.19.2-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
    vendor: ASUSTeK driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 04:00.0 chip-ID: 168c:003e class-ID: 0280
  IF: wlp4s0 state: down mac: <filter>
Bluetooth:
  Device-1: ASUSTek Qualcomm Bluetooth 4.1 type: USB driver: btusb v: 0.8
    bus-ID: 1-7:6 chip-ID: 0b05:1825 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
RAID:
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0
    port: f020 bus-ID: 00:17.0 chip-ID: 8086:2822 rev: class-ID: 0104
Drives:
  Local Storage: total: 2.05 TiB used: 1.29 TiB (62.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM001-1ER164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC26 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 850 EVO 250GB
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 2B6Q scheme: GPT
Partition:
  ID-1: / raw-size: 232.59 GiB size: 232.59 GiB (100.00%) used: 13.52 GiB
    (5.8%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
    (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
  ID-3: /home raw-size: 232.59 GiB size: 232.59 GiB (100.00%) used: 13.52
    GiB (5.8%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
  ID-4: /var/log raw-size: 232.59 GiB size: 232.59 GiB (100.00%) used: 13.52
    GiB (5.8%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
  ID-5: /var/tmp raw-size: 232.59 GiB size: 232.59 GiB (100.00%) used: 13.52
    GiB (5.8%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.28 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 47.0 C mobo: N/A gpu: nvidia temp: 63 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 42%
Info:
  Processes: 293 Uptime: 24m wakeups: 0 Memory: 31.28 GiB used: 6.26 GiB
  (20.0%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.1.1 Packages: pacman: 1446 lib: 463 Shell: fish v: 3.5.1
  default: Bash v: 5.1.16 running-in: alacritty inxi: 3.3.20
Garuda (2.6.6-1):
  System install date:     2022-08-21
  Last full system update: 2022-08-21 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Timeshift
  Failed units:
McFly: Upgrading McFly DB to version 3, please wait...thread 'main' panicked at 'McFly error: Unable to add cmd_tpl to commands (no such table: commands)', src/history/schema.rs:41:17
note: run with `RUST_BACKTRACE=1` environment variable to display a backtrace

Everything works as intended, but this error is staggeringly annoying. Everytime I run a command I run into this.

I looked in the forums and online, but I do not have the duplicate McFly issue. This isnt pulling up anything that I can find.

Any help would be greatly appreciated, and thank you for all the help here. :slight_smile:

First thing, reboot.

3 Likes

Delete ~/.mcfly/history.db

4 Likes

No change after any reboot and sys updates.

@TNE

Doesnt work.

rm: cannot remove '/home/myusername/.mcfly/history.db': No such file or directory

to add onto this. I have seen that command to remove history.db from several sources when the error says duplicate detected. My McFly is throwing a different error.

BTW, I did not need McFly with fish, so, I remove it.
Maybe search your problem here.

Yep I just removed

/home/myusername/.config/fish/conf.d/mcfly.conf

Fixed it. Appreciate the help.

That's... not a fix. That's just kicking the mcfly down the road >.>

2 Likes

Welp, its gone now. So im happy haha.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.