May i have the wrong Hardware for this Distribution by now?

Hello Everyone.

i am having big Problems using Garuda Linux. Yes Garude 1st Time try. Many things cool and nice build. But i think i have the Worst Hardware for this Os at the Moment. In that Live installer everything worked Great! Wobbling Windows. Installer ist suoer cool, just overrides my Ubuntu und Works fine.
But, when i was in the fresh installed System after Reboot, things Changed.
The Welcome Sreen installer is - Very Cool !!! Never seen in other Distros doing so.

  • “unresolvable package conlicts detected” … “jre-openjdk and jre.openjdk-headless are in conflict”
    → So i am not that new to Linux, bit Googling and pacman Stuff done. all right. Thing goes on.

  • But i guessing, why so much Fan’s doing noisi Sound. “Ksys” answered me in ~80% CU load on all cores. Also i noticed my second sceen was a mirror of my first.
    Well okay, letz go on.

  • Went thru all setup stuff - nice an flawless - good job.
    System was hangy - My courser was laggy and FPS below 60.
    Got to HW Tab - it was shown Nvidia is installed - twices launched that Setup for Nvidia prp…installer - all fine.
    Rebootet, nothing changen.
    (i did some more stuff but not needen here)

  • I found on this forum, that i have sick Hardware at the Moment for this Linux.
    Ryzen 9 7600x and nVidia RTX3080ti
    i found a thread here: Reinstalling Nvidia Drivers - #6 by Hanuman
    and can confirm it all. Also i Downgraded the Drivers. The behavior became a bit better - But Dual Screen working no - Fluent 60 Hz no - wont talk about 165Hz on my main Screen.

So With the Ubuntu install before, i was not having trouble.
Arch - was super cool and Fast on my system last Year, thats why i really liked ist.
So is it aktual my Hardware having trouble with this Software or what am i doing wrong?

garuda-inxi - as this Forum wanted me to post.
  Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=6824a062-1090-4e78-b97f-e49032c4d1ce rw rootflags=subvol=@
    quiet loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_wayland vt: 1
    dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Desktop Mobo: ASRock model: X670E PG Lightning
    serial: <superuser required> UEFI: American Megatrends LLC. v: 1.28
    date: 07/27/2023
  Info: model: AMD Ryzen 9 7900X bits: 64 type: MT MCP arch: Zen 4 gen: 5
    level: v4 note: check built: 2022+ process: TSMC n5 (5nm) family: 0x19 (25)
    model-id: 0x61 (97) stepping: 2 microcode: 0xA601203
  Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
    L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 12 MiB desc: 12x1024 KiB
    L3: 64 MiB desc: 2x32 MiB
  Speed (MHz): avg: 4953 high: 4965 min/max: 400/5733 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 4965 2: 4965 3: 4965
    4: 4965 5: 4965 6: 4965 7: 4943 8: 4934 9: 4942 10: 4937 11: 4935 12: 4959
    13: 4965 14: 4965 15: 4965 16: 4965 17: 4965 18: 4965 19: 4933 20: 4935
    21: 4934 22: 4942 23: 4955 24: 4961 bogomips: 225174
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: NVIDIA GA102 [GeForce RTX 3080 Ti] driver: N/A alternate: nouveau
    non-free: 545.xx+ status: current (as of 2023-10; EOL~2026-12-xx)
    arch: Ampere code: GAxxx process: TSMC n7 (7nm) built: 2020-2023 pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:2208
    class-ID: 0300
  Device-2: AMD Raphael driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16
    ports: active: none empty: DP-1, DP-2, DP-3, HDMI-A-1 bus-ID: 18:00.0
    chip-ID: 1002:164e class-ID: 0300 temp: 39.0 C
  Display: wayland server: v: with: Xwayland v: 23.2.2
    compositor: kwin_wayland driver: X: loaded: amdgpu,modesetting,nouveau
    alternate: fbdev,nv,vesa dri: radeonsi gpu: amdgpu display-ID: 0
  Monitor-1: Unknown-1 res: 2560x1440 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast gbm: drv: kms_swrast surfaceless: drv: radeonsi
    wayland: drv: swrast x11: drv: swrast
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: mesa v: 23.2.1-arch1.2 glx-v: 1.4
    direct-render: yes renderer: llvmpipe (LLVM 16.0.6 256 bits)
    device-ID: ffffffff:ffffffff memory: 29.76 GiB unified: yes
    display-ID: :1.0
  API: Vulkan v: 1.3.269 layers: 10 device: 0 type: integrated-gpu name: AMD
    Radeon Graphics (RADV RAPHAEL_MENDOCINO) driver: mesa radv
    v: 23.2.1-arch1.2 device-ID: 1002:164e surfaces: wayland device: 1
    type: cpu name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
    v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000
    surfaces: xcb,xlib,wayland
  Device-1: NVIDIA GA102 High Definition Audio driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:1aef
    class-ID: 0403
  Device-2: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 18:00.1
    chip-ID: 1002:1640 class-ID: 0403
  Device-3: AMD Family 17h/19h HD Audio vendor: ASRock driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 18:00.6
    chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api with: aoss
    type: oss-emulator tools: N/A
  Server-1: PipeWire v: 0.3.84 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Aquantia AQC107 NBase-T/IEEE 802.3bz Ethernet [AQtion]
    vendor: ASUSTeK driver: atlantic v: kernel pcie: gen: 3 speed: 8 GT/s
    lanes: 4 port: N/A bus-ID: 02:00.0 chip-ID: 1d6a:07b1 class-ID: 0200
    temp: 44.2 C
  IF: enp2s0 state: down mac: <filter>
  Device-2: Realtek RTL8125 2.5GbE vendor: ASRock driver: r8169 v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 0f:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: enp15s0 state: down mac: <filter>
  Device-3: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 12:00.0 chip-ID: 8086:2725
    class-ID: 0280
  IF: wlp18s0 state: up mac: <filter>
  Device-1: Intel AX210 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-9:7 chip-ID: 8087:0032
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.3
    lmp-v: 12 status: discoverable: no pairing: no class-ID: 7c0104
  Local Storage: total: 5 TiB used: 19.49 GiB (0.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: WD BLACK SN850X 1000GB size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 620331WD temp: 37.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 840 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: DB6Q scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 870 QVO 4TB
    size: 3.64 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 2B6Q scheme: GPT
  ID-1: / raw-size: 142.15 GiB size: 142.15 GiB (100.00%)
    used: 19.46 GiB (13.7%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 31.9 MiB (33.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 142.15 GiB size: 142.15 GiB (100.00%)
    used: 19.46 GiB (13.7%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-4: /var/log raw-size: 142.15 GiB size: 142.15 GiB (100.00%)
    used: 19.46 GiB (13.7%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-5: /var/tmp raw-size: 142.15 GiB size: 142.15 GiB (100.00%)
    used: 19.46 GiB (13.7%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 30.47 GiB used: 2 MiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 24 dev: /dev/zram0
  System Temperatures: cpu: 46.2 C mobo: N/A gpu: amdgpu temp: 40.0 C
  Fan Speeds (rpm): N/A
  Processes: 471 Uptime: 1m wakeups: 0 Memory: total: 32 GiB note: est.
  available: 30.47 GiB used: 3.47 GiB (11.4%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1921 libs: 538 tools: octopi,paru Shell: fish v: 3.6.1
  running-in: konsole inxi: 3.3.31
Garuda (2.6.17-1):
  System install date:     2023-11-08
  Last full system update: 2023-11-08
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            

Hope someone has the same Problems and is able to help me.
This Distribution Goal i do like - The Appeariance and Look i Like - hating Windows i do too.

Thanks in Advance.

kind regards,
the Mofa^33

Heck, I’ll give you $50 & pay for shipping. Or trade you straight across for this 2019 Gen 9 Core i5-9400 Intel/Intel rig that does great with Linux (bought with Linux in mind).


sudo pacman -Rdd jre-openjdk-headless then garuda-update again worked for me.
edit: I’m not really sure why, but I guess the full jre now includes -headless rather than depending on it.

Can’t help with the nvidia though.


Try switching to the LTS kernel to test if it works any better.

  1. Is it the same hardware?
  2. If not, then what has changed?
  3. How did you install Arch?

Try x11 or with Wayland use the kernel boot parameter suggested here (maybe use the Garuda Boot Assistant, or micro as our default terminal editor instead of nano):

You don’t have that driver problem. This is just to explain what parameter to setup, how and why.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.