Make Windows default boot choice for dual boot

Hi
I had installed garuda on my windows 10 already installed machine but couldn't set up grub option to make windows 10 default boot os. I want to reinstall garuda but how can I adjust grub to boot to windows default . I need it for certain reasons . Any help? Thanks.

You need this:

https://wiki.archlinux.org/index.php/Dual_boot_with_Windows

and

https://wiki.archlinux.org/index.php/GRUB

3 Likes

https://www.gnu.org/software/grub/manual/grub/grub.html#Simple-configuration

Set GRUB_DEFAULT to a number, which is the main menu option line, starting from 0 (zero).
If Windows is 5th menu entry, set this to /etc/default/grub

GRUB_DEFAULT=4
GRUB_SAVEDEFAULT=false
6 Likes

Thanks. I tried it with the application offered by the os but when I tried to save the setting it didn't save the option. Oddly enough, other settings such as boot menu time out are saved but not grub default.

Is there a way to do this on terminal typing commands? I tried manjaro commands but apparently there are some differences.

Did you forget to

grub-mkconfig -o /boot/grub/grub.cfg

after making changes to /etc/default/grub ?

It happens to the best of us :wink:

2 Likes

No but how can I edit grub with command line first? Manjaro commands that I used before didn't work.

Which manjaro commands did you use? :face_with_raised_eyebrow:

Use a terminal text editor, like nano, or vim (or micro or joe or one of the million other terminal text editors out there), with sudo... Or a GUI text editor with polkit support like Kate (without sudo, of course).

1 Like

sudo nano /etc/default/grub
sudo update-grub

These worked on Manjaro

And which one does not work now?

The first one? Do you have nano installed? If not run: pacman -S nano

The second one? The command I posted above is the same as update-grub (it's just a script on manjaro that runs that exact command).

3 Likes

Doesn't Garuda Boot Options allow to boot to Windows? Sorry, I don't dual boot, but I do see an option called Boot to and assume that it also lists Windows.

@Kresimir , yes nano command was the problem. I'll try your suggestion when I get home. Thanks.

I have very little knowledge of linux and commands for now.

Replace nano with micro. So the command is

sudo micro /etc/default/grub

Also, you can manually go to /etc/default/grub using file manager

4 Likes

Terminal commands worked. Thanks

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.