[MacBookPro8,3] Issues with Radeon HD 6750M and stuck on Plymouth Boot Screen

I tried installing first time KDE BlackArch edition and is was frozen on "starting version 248-3-arch"

I then this may be because of the discrete graphics card Radeon HD 6750M, so I then click 'e' on boot screen and changed radeon.modeset = 0 to disable graphics card.

This then load text but it gets stuck on "starting Terminate Plymouth Boot Screen..."

Any help greatly appreciated

Maybe removing splash from boot options will help? There have been a number of cases of being stuck on the boot screen while booting up the computer recently. This could be related I guess. Check this thread if you want more info: Last update of sddm caused black screen after plymouth

1 Like

Read wiki
Reporting bugs
and post

inxi -Fxxxza


1 Like

inxi -Fxxxza

 Host: mx Kernel: 4.19.0-16-amd64 x86_64 bits: 64 compiler: gcc v: 8.3.0  
 parameters: BOOT_IMAGE=/boot/vmlinuz-4.19.0-16-amd64  
 root=UUID=55932dfd-406f-49b4-8f42-966ce2720cc7 ro quiet nomodeset splash  
 Desktop: KDE Plasma 5.14.5 tk: Qt 5.11.3 wm: kwin_x11 dm: LightDM 1.26.0  
 Distro: MX-19.4_x64 patito feo March 31  2021 base: Debian GNU/Linux 10 (buster)  
 Type: Laptop System: Apple product: MacBookPro8,3 v: 1.0 serial: <filter> Chassis:  
 type: 10 v: Mac-942459F5819B171B serial: <filter>  
 Mobo: Apple model: Mac-942459F5819B171B v: MacBookPro8,3 serial: <filter>  
 UEFI: Apple v: date: 06/13/2019  
 ID-1: BAT0 charge: 63.1 Wh condition: 65.8/92.1 Wh (71%) volts: 12.0/10.9  
 model: DP bq20z451 type: Li-ion serial: N/A status: Discharging cycles: 536  
 Topology: Quad Core model: Intel Core i7-2720QM bits: 64 type: MT MCP  
 arch: Sandy Bridge family: 6 model-id: 2A (42) stepping: 7 microcode: 2F  
 L2 cache: 6144 KiB  
 flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 35199  
 Speed: 1580 MHz min/max: 800/3300 MHz Core speeds (MHz): 1: 1580 2: 1774 3: 2078  
 4: 1944 5: 1409 6: 2277 7: 1774 8: 1841  
 Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages  
 Type: l1tf  
 mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable  
 Type: mds mitigation: Clear CPU buffers; SMT vulnerable  
 Type: meltdown mitigation: PTI  
 Type: spec_store_bypass  
 mitigation: Speculative Store Bypass disabled via prctl and seccomp  
 Type: spectre_v1  
 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
 Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW,  
 STIBP: conditional, RSB filling  
 Type: srbds status: Not affected  
 Type: tsx_async_abort status: Not affected  
 Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics  
 vendor: Apple driver: N/A bus ID: 00:02.0 chip ID: 8086:0126  
 Device-2: AMD Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M] vendor: Apple  
 driver: N/A bus ID: 01:00.0 chip ID: 1002:6741  
 Display: x11 server: X.Org 1.20.4 driver: none unloaded: fbdev  
 compositor: kwin_x11 resolution: 1920x1200~77Hz  
 OpenGL: renderer: llvmpipe (LLVM 7.0 256 bits) v: 3.3 Mesa 18.3.6 compat-v: 3.1  
 direct render: Yes  
 Device-1: Intel 6 Series/C200 Series Family High Definition Audio  
 driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20  
 Device-2: AMD Turks HDMI Audio [Radeon HD 6500/6600 / 6700M Series]  
 driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 1002:aa90  
 Sound Server: ALSA v: k4.19.0-16-amd64  
 Device-1: Broadcom Limited NetXtreme BCM57765 Gigabit Ethernet PCIe driver: tg3  
 v: 3.137 port: 2000 bus ID: 02:00.0 chip ID: 14e4:16b4  
 IF: eth0 state: down mac: <filter>  
 Device-2: Broadcom Limited BCM4331 802.11a/b/g/n vendor: Apple AirPort Extreme  
 driver: wl v: kernel port: 2000 bus ID: 03:00.0 chip ID: 14e4:4331  
 IF: wlan0 state: up mac: <filter>  
 Local Storage: total: 494.58 GiB used: 13.43 GiB (2.7%)  
 ID-1: /dev/sda vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB block size:  
 physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 032  
 scheme: GPT  
 ID-2: /dev/sdb type: USB vendor: Kingston model: DataTraveler 3.0 size: 28.82 GiB  
 block size: physical: 512 B logical: 512 B serial: <filter> scheme: MBR  
 ID-1: / raw size: 279.30 GiB size: 273.92 GiB (98.07%) used: 13.42 GiB (4.9%)  
 fs: ext4 dev: /dev/sda3  
 System Temperatures: cpu: 51.0 C mobo: N/A  
 Fan Speeds (RPM): N/A  
 Processes: 231 Uptime: 2m Memory: 5.74 GiB used: 665.0 MiB (11.3%) Init: SysVinit  
 v: 2.93 runlevel: 5 default: 5 Compilers: gcc: 8.3.0 alt: 8 Shell: bash v: 5.0.3  
 running in: konsole inxi: 3.0.36

I ran inxi command from MXLinux which is installed

Please read the pinned topic : Last update of sddm caused black screen after plymouth - #90 by Hitreno

Thanks c00ter, but I don't have garuda installed so therefore how am i going to fix as the base install is crashing? Apologies but from the usb with garuda how do i get it to install?


  1. Add 3 ~ before and after your inxi to make it correctly formatted.
  2. You should have mentioned

In your question.

  1. Which option did you choose open source drivers/ closed source?
  2. How did you make bootable pen drive?
  3. Also try different iso to see if it is Blackarch or KDE edition specific. (Preferably not KDE)
1 Like

We have an installation page specifically for Macbooks, thanks to one kind user.


Try the barebones editions as they use different kernels.

I have tried open source/closed source for KDE and gnome versions and not had any success.

I have created the usb using Mac OS Etcher and Fedora writer. I am am 100% confident that the usb pen drive is good as have managed to get Live copy running for other distros : endeavouros, Fedora 34 beta and MX Linux.

I have also tried barebones gnome. I have to press "e" and disable radeon by changing to 0. The good news is it boots to login. but when i type startx I get error message

"xinit: unable to connect to X server: connection refused".

I don't see why other distro's work fine (apart from wifi issues) but garuda just crashes and does not load live environment.

It's probably picking up your system as having hybrid graphics:

This is an additional complexity that may be tripping up the installer's tooling. Can you disable either of these GPUs in the BIOS/UEFI/whatever?

Otherwise, if Garuda simply doesn't work on your hardware then EndeavourOS is a perfectly good choice.


The amount of RAM in this machine? Did I miss it?

1 Like

I'm no expert of Apple stuff at all, but an internet search brought me to this:

Most likely you've already checked it, of course.
I just saw:
AMD Radeon HD 6750M and 6770M: works with xf86-video-ati.
if this can be of any interest...

1 Like

Ram is 6gb.

I remember I was able to install a previous version of garuda gnome on my Macbook Pro 2011 a few months ago. It worked flawlessly and i was very impressed.

Is there a link to previous releases? As mentioned, the previous gnome release worked 100%.