Load ICC profile system wide with "night color"

(let me start again, correctly this time... thanks to a moderator for clearing stuff up)

Is there a way to load the ICC calibration profile in a way that is not disabled by the system "night color"?

i have noticed that after using DisplayCAL the profile unloads when the blue light filter is engaged, i tried using Colord to load the ICC profile system wide but it still gets disabled...

System:    Kernel: 5.14.11-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=a2edb1d1-2b71-4078-8e7e-5c1eddf533f9  
rw [email protected] quiet
cryptdevice=UUID=53f62651-9e7c-4ac4-9ddc-9ae7a1225771:luks-53f62651-9e7c-4ac4-9ddc-9ae7a1225771
root=/dev/mapper/luks-53f62651-9e7c-4ac4-9ddc-9ae7a1225771 splash rd.udev.log_priority=3
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Desktop System: Micro-Star product: MS-7B79 v: 3.0 serial: <filter>  
Mobo: Micro-Star model: X470 GAMING PLUS MAX (MS-7B79) v: 3.0 serial: <filter>  
UEFI: American Megatrends v: H.60 date: 06/11/2020  
CPU:       Info: 8-Core model: AMD Ryzen 7 1800X bits: 64 type: MT MCP arch: Zen family: 17 (23)  
model-id: 1 stepping: 1 microcode: 8001138 cache: L2: 4 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 121595  
Speed: 3800 MHz min/max: N/A Core speeds (MHz): 1: 3800 2: 3800 3: 3800 4: 3800 5: 3513 6: 3800  
7: 3800 8: 3800 9: 3800 10: 3800 11: 3800 12: 3800 13: 3800 14: 3800 15: 3800 16: 3800  
Vulnerabilities: Type: itlb_multihit status: Not affected  
Type: l1tf status: Not affected  
Type: mds status: Not affected  
Type: meltdown status: Not affected  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling  
Type: srbds status: Not affected  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: NVIDIA TU104 [GeForce RTX 2080 Rev. A] vendor: ASUSTeK driver: nvidia v: 470.74  
alternate: nouveau,nvidia_drm bus-ID: 27:00.0 chip-ID: 10de:1e87 class-ID: 0300  
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: nvidia  
unloaded: modesetting alternate: fbdev,nouveau,nv,vesa display-ID: :0 screens: 1  
Screen-1: 0 s-res: 2560x1440 s-dpi: 122 s-size: 533x302mm (21.0x11.9") s-diag: 613mm (24.1")  
Monitor-1: DP-4 res: 2560x1440 dpi: 123 size: 527x296mm (20.7x11.7") diag: 604mm (23.8")  
OpenGL: renderer: NVIDIA GeForce RTX 2080/PCIe/SSE2 v: 4.6.0 NVIDIA 470.74 direct render: Yes  
Audio:     Device-1: NVIDIA TU104 HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 27:00.1  
chip-ID: 10de:10f8 class-ID: 0403  
Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel  
bus-ID: 29:00.3 chip-ID: 1022:1457 class-ID: 0403  
Sound Server-1: ALSA v: k5.14.11-zen1-1-zen running: yes  
Sound Server-2: JACK v: 1.9.19 running: no  
Sound Server-3: PulseAudio v: 15.0 running: yes  
Sound Server-4: PipeWire v: 0.3.38 running: yes  
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI  
driver: r8169 v: kernel port: f000 bus-ID: 22:00.0 chip-ID: 10ec:8168 class-ID: 0200  
IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter>  
Drives:    Local Storage: total: 1.56 TiB used: 497.39 GiB (31.0%)  
SMART Message: Unable to run smartctl. Root privileges required.  
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM003-1CH162 size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200
serial: <filter> rev: CC49 scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SA400S37480G size: 447.13 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 1103 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Kingston model: SUV400S37240G size: 223.57 GiB block-size:
physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 37R5
scheme: GPT
Partition: ID-1: / raw-size: 223.31 GiB size: 223.31 GiB (100.00%) used: 31.31 GiB (14.0%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-53f62651-9e7c-4ac4-9ddc-9ae7a1225771
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 706 KiB (0.3%) fs: vfat
dev: /dev/sdc1 maj-min: 8:33
ID-3: /home raw-size: 223.31 GiB size: 223.31 GiB (100.00%) used: 31.31 GiB (14.0%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-53f62651-9e7c-4ac4-9ddc-9ae7a1225771
ID-4: /var/log raw-size: 223.31 GiB size: 223.31 GiB (100.00%) used: 31.31 GiB (14.0%)
fs: btrfs dev: /dev/dm-0 maj-min: 254:0 mapped: luks-53f62651-9e7c-4ac4-9ddc-9ae7a1225771
ID-5: /var/tmp raw-size: 223.31 GiB size: 223.31 GiB (100.00%) used: 31.31 GiB (14.0%)
fs: btrfs dev: /dev/dm-0 maj-min: 254:0 mapped: luks-53f62651-9e7c-4ac4-9ddc-9ae7a1225771
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.57 GiB used: 1.22 GiB (7.9%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 37.4 C mobo: N/A gpu: nvidia temp: 53 C
Fan Speeds (RPM): fan-1: 0 gpu: nvidia fan: 0%
Info:      Processes: 399 Uptime: 6h 47m wakeups: 2 Memory: 15.57 GiB used: 7.46 GiB (47.9%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 Packages: 1720 pacman: 1714 lib: 493 flatpak: 6
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

Yes - use KDE's built-in colour management software: Color Management - KDE UserBase Wiki

2 Likes

mmmmh i think i'm doing something wrong, can't install Kolor-manager it gives me this error while using octopi

 -> Could not find all required packages:
        synnefo-git (Wanted by: kolor-manager-git)
Press any key to continue... ~~~

Oh. Maybe the KDE documentation is out-of-date. That's really not useful. :pensive:

$ pacman -Ss kolor-manager
$ yay -Ss kolor-manager
aur/kolor-manager-git 1.1.0.21.g246e3f1-1 (+11 0.00) (Orphaned) (Out-of-date: 2020-06-16) 
    Oyranos CMS cross desktop settings for the KDE system settings panel. (GIT version)

I'm downloading a fresh barebones image, give me a little while and I'll see how it works now.

3 Likes

OK, so, it's not as straightforward in KDE as with GNOME or MATE+DisplayCAL+Redshift.

Prerequisites

You have to be running a Wayland session for this to work correctly. If you're running with Xorg, you can have monitor calibration, or Night Color active, but not both.

Make sure a Wayland session is available, and install colord-kde:

sudo pacman -S colord-kde plasma-wayland-session --needed

Make sure that you're not starting/loading any other profile loading software. Check in Startup and Shutdown -> Autostart to make certain DisplayCAL or xcalib or whatever is not going to start automatically.

Now, log out and back in to a Wayland session.

Set up ICC profile

Open System Settings and you will see a new Color Corrections option:

Enter that section, and you will be able to add your ICC profile for your display. You should see the screen visibly change as you select different profiles - if not, you're probably running Xorg.

Set up Night Color

Go back up to Display and Monitor -> Night Color and enable. The colours should change without any flickering, and when you disable they should return back to the selected ICC profile. Again, if it returns back to the default then you're running Xorg.

3 Likes

omg thanks so much >.<

but there is an issue... when i try to switch to Plasma Wayland i put the password it goes black for a second and then it goes back to the login

if you don't mind what is the difference between Wayland and X11?

edit: wait i may be dumb, give me a s
edit2: welp, i thought it was not starting because displaycal profile loader but it wont start at all anyway, do i need to install it in Wayland to not make it kill itself? i try

Nope :wink: :smiley:

1 Like

Wayland session doesn't start T-T

i have done some research, will Wayland screw with my gaming experience? or Krita using the wacom tablet?
because this is getting fast into more stuff i don't understand

Edit: can be it that i have a Nvidia GPU? i've seen some things about not working well with Wayland

Oh, yeah... Nvidia+Wayland+KDE seems to have issues for a number of people (it's supposed to be getting better, but that relies on Nvidia releasing drivers with better Wayland support...)

In which case, ignore (entirely disable) KDE's Night Color settings, remove colord-kde, and use Redshift in combination with DisplayCAL. Redshift will "preserve" the current ICC curve set by DisplayCAL and they will play happily together.

5 Likes

okie dokie, will do that way...

sorry for making you do all that work, i have seen that Nvidia will release a driver to work better with Wayland, i think it's only a question of time...

thank you so much for your help :kissing_heart:

2 Likes

Ya Nvidia is well known for how well they support Linux. :rofl:

The wayland support will probably arive about a month before they deprecate support for your graphics card. :sob:

6 Likes

Nvidia releasing Wayland fixes and goodies....

5 Likes

Sorry for the OT:

My above response was mostly tongue in cheek. Nice to see Nvidia putting in some effort for their Linux users. Unfortunately, they still regularly drop Linux support for old cards to save costs and to boost new card sales. I have seriously had my fill of Nvidia depreciating my Nvidia purchases. Their sales boosting tactics has backfired in my case. No more Nvidia purchases for me from now on. Fool me once shame on you, fool me twice shame on me.

5 Likes

LOL, I love tongue in cheek. I have always used Nvidia (Gamer) and never really had a problem, but I know others have, especially installing drivers, particularly the hybrid drivers, etc. As of late, they seem to be on the ball with their linux drivers, which is great. Overall though, the macro picture, best to always stick with open source supporters. I still have a fondness for my Nvidia GPUs though, call me crazy. :crazy_face:

4 Likes

All together now...

5 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.