Live Boot of Garuda -> Install Issue

I have a 12,1 MBP that has successfully and delightfully installed Garuda from a Live Install USB stick choose the Dragonized KDE Plasma.

For fun I moved to try the same Garuda but with the Hyprland edition. The Hyprland Live Install boots fine, but the problem is, the install fails. By that I mean:

  • If I use the Application Manager to fine Install, and choose that App, nothing happens when executing that App
  • If I navigate to Garuda Assistant and click the link for Install provided there, the click just loops back to the Window, so it closes the Window and re-opens Garuda Assistant.

So there is some kind of blocker on this Live Install version of Garuda? I am trying to wrap my head around why a Live Install would not offer up the usual choices of “where do you want me to install Linux”, etc. Does anyone have any insights as to why a Live Install ISO on a USB stick would fail in this manner? I am sure it is something trivial, but I cannot seem to get over this little hump.


What’s the problem with not posting garuda-inxi?
It contains additional, useful information about the status of your system.

Use the live ISO for postig the garuda-inxi.

:warning: Missing information requested in the template may result in not receiving assistance

Make sure you have done the following before you post:

Issue still unresolved? Then:

  • ONE issue per topic.

  • Describe your issue in detail. The more we know, the better we can help

  • Show us the results of your searches, and what you’ve tried

  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)

  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

I would love to! The problem is, the Live Boot ISO now logs in to a black screen and frozen mouse. I have tried both choices, Open Source Drivers (appropriate as the MBP has Intel integrated graphics) and the NVideo proprietary version.

So nuts… cannot even get a garuda-inxi to add at this point… maybe I just try a new download of the ISO and today the version is better than the one I got a few days ago.

Check sha sum and use


The USB Live Install brings up Garuda Hyprland login manager screen. I provide the garuda password, and that is when I am faced with the black screen and frozen mouse.

So I can only assume that since this same process worked for KDE Plasma flawlessly, it has to do with the Hyprland version. The SHA256 checks out legit.

I was able to get Hyprland to boot, a few times, but as mentioned, it would never actually install, so that was the time to log a garuda-inxi, but sadly, now, at this point, I cannot even get past the login.

I assume something is now pooched on the HD for this Live Install, and attempts to move past login are freezing due to it “finding” something… something it does not like.

Nevermind… I will just use the KDE Plasma as it is a delight, and perhaps come back to Hyprland with something I can grab second-hand, like an old Thinkpad or something.

Thanks for trying though! I appreciate it.

I assume that an Nvidia GPU is installed. But guessing doesn’t help, maybe you can post the desired garuda-inxi from KDE.


No. It is strictly an Intel laptop with nothing weird in it save the Broadcom Wifi/Bluetooth chip, but that actually works fine in KDE Plasma, so why would it not work when exchanging KDE for Hyprland? Makes no sense. I am amazed Hyprland booted fine, a few times, but was unable to run the installer is all. Now that it does not even bring up the desktop though, that stumps me. I suppose an absolute clean wipe of the drive might be the ticket, but that would be cheating and would force me to re-install KDE Plasma too. A shame! My BTRFS drive has around 400GB unused so being able to dual boot into either KDE or Hyprland would be so awesome.

Again, post the garuda-inxi.
Also post the full name of the ISO and where you download them.


lsblk -f
NAME        FSTYPE FSVER LABEL        UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
zram0                                                                                     [SWAP]
├─nvme0n1p1 vfat   FAT32 SYSTEM_DRV   94BA-ECE1                             224,4M    12% /boot/efi
├─nvme0n1p3 ntfs         Windows-SSD  A2A8BB95A8BB6707                       84,7G    34% /run/media/sgs/Windows-SSD
├─nvme0n1p4 ntfs         WINRE_DRV    B8F6BC25F6BBE234                                    
├─nvme0n1p5 btrfs        KDE          fc62cc44-07ab-497b-ac89-15704c290993   81,4G    76% /run/media/sgs/KDE
├─nvme0n1p6 btrfs        Hyprland     4c17a9ec-6a7a-4114-8443-65c4d6e1d121   11,9G    73% /run/media/sgs/Hyprland
├─nvme0n1p7 btrfs        i3wm         21e02e96-0ed6-4629-9a39-85ffee7a4359  217,3G    25% /run/media/sgs/i3wm
└─nvme0n1p8 btrfs        Hyprland-SGS b147dd48-f302-484d-80b0-661e7ff40a76     49G    47% /var/tmp

M$, KDE, i3wm, 2x Hyprland
It cannot be due to Garuda Linux or Multiboot. What could be the problem then? :thinking:


I used the garuda website, direct download. checked the SHA256, it all matched. So I am confident the code I am running on the USB stick is fine.

If I could login to Hyperland, I could easily get a copy of garuda-inxi as per the rules. I could also run lsblk. From my KDE install, list blocks shows this:

lsblk -f
├─sda1 vfat   FAT32       2F2D-49AA                             298.8M     0% /boot/efi
├─sda2 btrfs              3ca8b255-f29c-4744-8324-8ca995444357  416.4G     6% /home
│                                                                             /var/cache
│                                                                             /srv
│                                                                             /root
│                                                                             /var/tmp
│                                                                             /var/log
│                                                                             /
└─sda3 swap   1     swap  88aa211a-5bdb-49f3-a5f5-d8ac5cf926a3                [SWAP]
zram0                                                                         [SWAP]

Try to run from the terminal:

sudo -E calamares

If when I provide the password “garuda” to the login for Hyprland, I get to Hyprland, which has happened on a few occasions, then yes, I appreciate the tip here, to try a terminal command like that to perhaps get past any problems present when using the GUI elements of Hyprland. My problem at the moment is login hangs on a blackscreen and frozen mouse! So I cannot access a terminal.

This actually only happens with Nvidia GPUs.

It worked for me just now when testing until after logging in, then the mouse pointer disappeared and the system gradually became unusable.

The best thing to do is to wait until Hyprland is out of the beta phase.

We still don’t have a garuda-inxi from you.

1 Like

As I mentioned. This laptop has zero NVidia HW. It is manufactured with an Intel graphics chip. So while it may be true that it fails with NVidia GPUs, it is also true that it fails with Intel integrated graphics. Strangely, KDE Plasma has no such problems.

And again, the reason I cannot provide the inxi is simply because the Live Install fails to even get me to a point where it makes sense to have a terminal.

I will keep trying to get back to where Hyprland actually booted and does not hang … some combo I tried had worked a few times, although as I say, that was a bit superficial in that none of the “INSTALL” options of the Live Boot were present.

Can you provide your


so that we may help you

1 Like

It does not fail on my intel/amd notebooks without nvidia GPU, so, I cant follow your problem.

1 Like

Understood. Clearly nothing jumped off the pages from my lsblk output. I am kinda miffed here that Hyprland did indeed successfully get past login a few times, as if I could get back to that point, I could indeed fire up a terminal and hopefully get a few more details to help on debugging why the install process does not kick off.

Ok. I figured out one thing for sure. If I assumed the Garuda Login for Hyperland had a User account set to garuda, and so all i needed to do was fill in the password as garuda, boy was I wrong. I used the Change User option, and explicitly provided garuda, and a password of garuda and then an only then did the login succeed. Who knew!

Wow. So now I am in Hyprland, where I can get a garuda-inxi to show off, and maybe learn why the install options just hangs from this Live Boot install attempt.

Goto to the terminal
and type


Copy and paste here?
I hope your next reply will include this?

  Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=garuda root=miso:LABEL=GARUDA_HYPRLAND_RAPTOR quiet
    systemd.show_status=1 ibt=off driver=free nouveau.modeset=1
    i915.modeset=1 radeon.modeset=1
  Desktop: Hyprland info: waybar vt: 1 dm: SDDM Distro: Garuda Linux
    base: Arch Linux
  Type: Laptop System: Apple product: MacBookPro12,1 v: 1.0
    serial: <superuser required> Chassis: type: 9 v: Mac-E43C1C25D4880AD6
    serial: <superuser required>
  Mobo: Apple model: Mac-E43C1C25D4880AD6 v: MacBookPro12,1
    serial: <superuser required> UEFI: Apple v: 486. date: 08/03/2023
  ID-1: BAT0 charge: 61.3 Wh (99.8%) condition: 61.4/74.8 Wh (82.2%)
    volts: 12.9 min: 11.4 model: DP bq20z451 type: Li-ion serial: N/A
    status: full cycles: 216
  Info: model: Intel Core i5-5287U bits: 64 type: MT MCP arch: Broadwell
    gen: core 5 level: v3 note: check built: 2015-18 process: Intel 14nm
    family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1250 high: 3300 min/max: 500/3300 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 700 2: 500 3: 3300
    4: 500 bogomips: 23200
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel Iris Graphics 6100 vendor: Apple driver: i915 v: kernel
    arch: Gen-8 process: Intel 14nm built: 2014-15 ports: active: eDP-1
    empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:162b
    class-ID: 0300
  Display: wayland server: v: with: Xwayland v: 23.2.2
    compositor: Hyprland driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: 1
  Monitor-1: eDP-1 model: Apple Color LCD built: 2013 res: 2560x1600 hz: 60
    dpi: 227 gamma: 1.2 scale: 1 size: 286x179mm (11.26x7.05")
    diag: 337mm (13.3") ratio: 16:10 modes: 2560x1600
  API: Vulkan v: 1.3.269 layers: 3 device: 0 type: integrated-gpu name: Intel
    Iris Graphics 6100 (BDW GT3) driver: mesa intel v: 23.2.1-arch1.2
    device-ID: 8086:162b surfaces: xcb,xlib,wayland device: 1 type: cpu
    name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
    v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000
    surfaces: xcb,xlib,wayland
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
  Device-1: Intel Broadwell-U Audio vendor: Apple driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
  Device-2: Intel Wildcat Point-LP High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
    class-ID: 0403
  Device-3: Broadcom 720p FaceTime HD Camera driver: N/A pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 14e4:1570 class-ID: 0480
  API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Broadcom BCM43602 802.11ac Wireless LAN SoC vendor: Apple
    driver: brcmfmac v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 03:00.0 chip-ID: 14e4:43ba class-ID: 0280
  IF: wlp3s0 state: down mac: <filter>
  Device-1: Apple Bluetooth Host Controller driver: btusb,hid-generic,usbhid
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-3:2
    chip-ID: 05ac:8290 class-ID: fe01
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.2
    lmp-v: 8 status: discoverable: no pairing: no class-ID: 6c010c
  Local Storage: total: 523.22 GiB used: 0 KiB (0.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Apple model: SSD SM0512G
    size: 465.92 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: JA0Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: SanDisk model: USB 3.2Gen1
    size: 57.3 GiB block-size: physical: 512 B logical: 512 B type: USB rev: 3.2
    spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
    fw-rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No partition data found.
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 15.53 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
  System Temperatures: cpu: 68.0 C pch: 64.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 167 Uptime: 5m wakeups: 2 Memory: total: 16 GiB
  available: 15.53 GiB used: 1.41 GiB (9.1%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1228 libs: 356 tools: paru Shell: fish v: 3.6.1
  running-in: alacritty inxi: 3.3.30
warning: database file for 'garuda' does not exist (use '-Sy' to download)
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.17-1):
  System install date:     2024-01-31
  Last full system update: 2024-01-31 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       <superuser required>
  Failed units:

going for calamares and it spit back some juice

ruda@garuda in ~ as 🧙 took 3s
 ╰─λ sudo -E calamares
QStandardPaths: runtime directory '/run/user/1000' is not owned by UID 0, but a directory permissions 0700 owned by UID 1000 GID 1000
QStandardPaths: runtime directory '/run/user/1000' is not owned by UID 0, but a directory permissions 0700 owned by UID 1000 GID 1000
Authorization required, but no authorization protocol specified

Cannot open display ":1"