Libwlroots.so.11 failed to commit transaction

This is owned by wlroots. I tried refreshing the mirrors, and got the same issue. I have seen similar “failed to commit transaction” posts, but am unsure which to follow. Just installed this to a new machine, but for some reason, I cannot do a simple system update because of this one package. This is my first time using an Arch distro, and I have no idea what I’m doing.

garuda-inxi output:

System:
Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c70eb515-37ec-4022-a15b-471e53b86e63 rw rootflags=subvol=@
quiet resume=UUID=d1fd6920-972d-40c8-90de-eb9e5b5e7602 loglevel=3 ibt=off
Desktop: Qtile v: 0.23.0 wm: LG3D vt: 2 dm: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Desktop Mobo: ASRock model: B650E PG Riptide WiFi
serial: UEFI: American Megatrends LLC. v: 1.30.AS02
date: 09/28/2023
CPU:
Info: model: AMD Ryzen 7 7800X3D bits: 64 type: MT MCP arch: Zen 4 gen: 5
level: v4 note: check built: 2022+ process: TSMC n5 (5nm) family: 0x19 (25)
model-id: 0x61 (97) stepping: 2 microcode: 0xA601203
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 8 MiB desc: 8x1024 KiB
L3: 96 MiB desc: 1x96 MiB
Speed (MHz): avg: 400 min/max: 400/5050 scaling: driver: amd-pstate-epp
governor: powersave cores: 1: 400 2: 400 3: 400 4: 400 5: 400 6: 400 7: 400
8: 400 9: 400 10: 400 11: 400 12: 400 13: 400 14: 400 15: 400 16: 400
bogomips: 134148
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Graphics:
Device-1: AMD Navi 31 [Radeon RX 7900 XT/7900 XTX] vendor: Sapphire PULSE
driver: amdgpu v: kernel arch: RDNA-3 code: Navi-3x process: TSMC n5 (5nm)
built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: DP-1
empty: DP-2,HDMI-A-1,HDMI-A-2 bus-ID: 03:00.0 chip-ID: 1002:744c
class-ID: 0300
Device-2: AMD Raphael driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16
ports: active: none empty: DP-3, DP-4, DP-5, HDMI-A-3 bus-ID: 11:00.0
chip-ID: 1002:164e class-ID: 0300 temp: 33.0 C
Display: x11 server: X.Org v: 21.1.9 compositor: Picom v: git-b700a
driver: X: loaded: amdgpu unloaded: modesetting,radeon alternate: fbdev,vesa
dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x571mm (40.00x22.48")
s-diag: 1165mm (45.88")
Monitor-1: DP-1 mapped: DisplayPort-0 model: Acer XV273K serial:
built: 2021 res: 3840x2160 hz: 120 dpi: 163 gamma: 1.2
size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9 modes:
max: 3840x2160 min: 640x480
API: Vulkan v: 1.3.269 layers: 3 device: 0 type: discrete-gpu name: AMD
Radeon RX 7900 XTX (RADV GFX1100) driver: mesa radv v: 23.2.1-arch1.2
device-ID: 1002:744c surfaces: xcb,xlib device: 1 type: integrated-gpu
name: AMD Radeon Graphics (RADV RAPHAEL_MENDOCINO) driver: mesa radv
v: 23.2.1-arch1.2 device-ID: 1002:164e surfaces: xcb,xlib device: 2
type: cpu name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
API: OpenGL Message: Unable to show GL data. glxinfo is missing.
Audio:
Device-1: AMD Navi 31 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab30
class-ID: 0403
Device-2: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 11:00.1
chip-ID: 1002:1640 class-ID: 0403
Device-3: AMD Family 17h/19h HD Audio vendor: ASRock driver: snd_hda_intel
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 11:00.6
chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api
tools: alsactl,alsamixer,amixer
Server-1: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: MEDIATEK MT7921K Wi-Fi 6E 80MHz driver: mt7921e v: kernel pcie:
gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 0c:00.0 chip-ID: 14c3:0608
class-ID: 0280
IF: wlp12s0 state: up mac:
Device-2: Realtek Killer E3000 2.5GbE vendor: ASRock driver: r8169
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: c000 bus-ID: 0d:00.0
chip-ID: 10ec:3000 class-ID: 0200
IF: enp13s0 state: down mac:
Bluetooth:
Device-1: MediaTek driver: btusb v: 0.8 type: USB rev: 2.1
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:2 chip-ID: 0e8d:0608
class-ID: e001 serial:
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: bt-v: 5.2
lmp-v: 11 status: discoverable: no pairing: no class-ID: 7c0104
Drives:
Local Storage: total: 1.86 TiB used: 4.35 GiB (0.2%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: solidgm model: SSDPFKKW020X7
size: 1.86 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: fw-rev: 001C temp: 38.9 C scheme: GPT
Partition:
ID-1: / raw-size: 1.83 TiB size: 1.83 TiB (100.00%) used: 4.35 GiB (0.2%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 1.83 TiB size: 1.83 TiB (100.00%)
used: 4.35 GiB (0.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 1.83 TiB size: 1.83 TiB (100.00%)
used: 4.35 GiB (0.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 1.83 TiB size: 1.83 TiB (100.00%)
used: 4.35 GiB (0.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 30.47 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
ID-2: swap-2 type: partition size: 33.52 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
System Temperatures: cpu: 38.5 C mobo: N/A
Fan Speeds (rpm): N/A
GPU: device: amdgpu temp: 40.0 C mem: 44.0 C fan: 0 watts: 17.00
device: amdgpu temp: 32.0 C
Info:
Processes: 372 Uptime: 1h 10m wakeups: 0 Memory: total: 32 GiB note: est.
available: 30.47 GiB used: 2.64 GiB (8.7%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1179 libs: 403 tools: paru Shell: fish v: 3.6.1
running-in: alacritty inxi: 3.3.30
Garuda (2.6.17-1):
System install date: 2023-11-22
Last full system update: 2023-11-22
Is partially upgraded: Yes
Relevant software: snapper NetworkManager dracut
Windows dual boot: No/Undetected
Failed units:

I’m not a qtile user but I see that wlroots has been updated so to include libwlroots.so.12.
In the meanwhile I see that qtile now depends on wlroots0.16, which will replace wlroots and still use so.11.

So, I’d try to manually reinstall qtile before updating again.

sudo pacman -S qtile

Then again

garuda-update
2 Likes

I tried

sudo pacman -S qtile

but all I get is

error: failed to commit transaction (conflicting files)
wlroots0.16: /usr/lib/libwlroots.so.11 exists in filesystem (owned by wlroots)
Errors occurred, no packages were upgraded.

Very similar to my original error, only now with wlroots0.16

im having same issue but with gamescope conflicting, just going to wait :slight_smile:

:

: There are 2 providers available for libwlroots.so=11:
:: Repository extra
   1) wlroots0.16
:: Repository chaotic-aur
   2) wayfire-git

Enter a number (default=1):
looking for conflicting packages...

Packages (17) faad2-2.11.1-1  gettext-0.22.4-1  gvim-9.0.2121-1  libde265-1.0.14-1  libdisplay-info-0.1.1-3  libksba-1.6.5-1  mujs-1.3.4-1  nwg-drawer-0.4.2-1  plymouth-git-22.02.122.r194.g5b5b133d-1  proton-ge-custom-2:GE.Proton8.25-1
              python-urllib3-1.26.18-1  sway-1:1.8.1-4  ttf-fantasque-nerd-3.1.0-1  vim-runtime-9.0.2121-1  wlroots-0.17.0-1  wlroots0.16-0.16.2-2  xdg-utils-1.2.0r17+g21fb316-1

Total Installed Size:  1169.21 MiB
Net Upgrade Size:         2.07 MiB

:: Proceed with installation? [Y/n]
(17/17) checking keys in keyring                                                                                                                       [--------------------------------------------------------------------------------------------] 100%
(17/17) checking package integrity                                                                                                                     [--------------------------------------------------------------------------------------------] 100%
(17/17) loading package files                                                                                                                          [--------------------------------------------------------------------------------------------] 100%
(17/17) checking for file conflicts                                                                                                                    [--------------------------------------------------------------------------------------------] 100%
error: failed to commit transaction (conflicting files)
libdisplay-info: /usr/bin/di-edid-decode exists in filesystem (owned by gamescope-git)
Errors occurred, no packages were upgraded.

This could be fixed/forced with

sudo pacman -S wlroots0.16 --overwrite '*'

But I guess something will be fixed shortly in those packages.

4 Likes

I forced the overwrite, then did

garuda-update

and it has stopped complaining about it being owned by wlroots. Not sure if it broke anything else, but the system update was successful. Much obliged!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.