LFS chapter 4.4 final prepartions error bash: vi command not found

I am Garuda beginner
I am making LFS on Garuda. I am currentla at chapter 4.4 Final preparations. There is command I should ran * source ~/.bash_profile* but when I ran it I got bash: vi command not found . Do you have suggestions how can I resolve this? Thanks for your answers and advices.

Why is this a Garuda issue? :face_with_raised_eyebrow:

Something is looking for vi; the easiest solution would be to install it.


I just wanted to clarify where I got that issue I mean I am making Linux from Scratch . Can you be more clear please ? What do you think is exactly looking for vi? How to find out?

Wouldn't this be better directed at LFS supports?

Did you look in ~/.bash_profile

1 Like

I don't know but it seems it's package problem in Garuda I mean some packages are missing i think.

That is nonsensical.

But you can certainly install vi. The package name is vi

1 Like

I just ran it I got permission denied

You ran what and got permission denied?

I don't know I am going step by step in LFS guide

I ran ~/.bash_profile

Why would you run it? I told you to look inside it.

If you don't know how to open a text file and read a basic shell script, you probably aren't ready for LFS yet.


Please provide the result from the terminal command


We will be able to assist and see where your issue is linked to Garuda, whereas you mention LFS.

I looked inside and got -rw-r--r-- 1 lfs lfs 59 Jan 26 22:37 /home/lfs/.bash_profile It is what you need?

I got bash: command not found

I honestly believe that this is where you have most chances to post for LFS questions:

However, some people here in this community are still trying to help you.

1 Like

Thank you I appriciate that. I thought it would be correct to post here because I am making it on Garuda .

That is a directory listing. Look inside means open it up and see what is inside it.

Open it on a text editor. However, I don't need to know what is inside it.

You need to read and understand what is inside it. Once you do, it should be obvious what the problem is.

1 Like

I opened it it'¸s nothing secret there so this is what I got


[[ -f ~/.bashrc ]] && . ~/.bashrc

The next step is for you to figure out what that line does.