Latte-dock freezing randomly

Hello!

I've been dealing with this since installing Garuda and have tried searching and solving this problem multiple times already. My latte-dock keeps freezing randomly, sometimes a few minutes after booting up, sometimes multiple hours later. Yesterday for example, I only had a freeze when booting up. I had to do killall latte-dock && latte-dock -d, then it worked well for the rest of the day.

Today, it froze up on boot and hasn't stopped freezing since. In the past hour, I've had to kill and restart latte-dock four times. Each time I kill it and restart it, it gets increasingly longer for it to start being responsive. At boot for example, everything is ready within a few seconds. After having it killed a fourth time, it took almost two minutes for the new process to become responsive again.

Anytime this happens, the taskbar and status bar are completely unresponsive, and even the clock freezes. As I'm writing this, the clock is 20 minutes behind, meaning that latte-dock has been frozen for a while now and isn't recovering on its own. When killing and restarting latte-dock with -d, I can look at the logs when the freeze occurs but usually nothing is particularly telling about what could cause it.

Around the time latte-dock froze, only these two lines are present:

[Warning : 10:06:49.713713] - "QXcbConnection: XCB error: 3 (BadWindow), sequence: 46360, resource id: 90179417, major code: 3 (GetWindowAttributes), minor code: 0"
[Warning : 10:06:49.713713] - "QXcbConnection: XCB error: 3 (BadWindow), sequence: 46361, resource id: 90179417, major code: 2 (ChangeWindowAttributes), minor code: 0"

I've tried updating latte-dock and switching to latte-dock-git. I first thought it was caused by a CUPS (printer service) error that kept showing up when I had a VPN on and local printers couldn't be retrieved, but I have it on all the time and the freeze only occurs sometimes. I'm kind of out of ideas as nothing even shows up in the logs.

Output of inxi -Faz:

╭─[email protected] in ~ took 1ms
╰─λ inxi -Faz
System:    Kernel: 5.14.9-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=8a0a4f23-e4b4-468d-a55d-308b2de6b338  
rw [email protected] quiet
cryptdevice=UUID=06b5b85e-d9c6-4b3d-8ad4-9160c300f9fc:luks-06b5b85e-d9c6-4b3d-8ad4-9160c300f9fc
root=/dev/mapper/luks-06b5b85e-d9c6-4b3d-8ad4-9160c300f9fc splash rd.udev.log_priority=3
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
resume=/dev/mapper/luks-a775b892-c6c9-43c9-8c98-189505509025 loglevel=3
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Laptop System: Dell product: XPS 13 9370 v: N/A serial: <filter> Chassis: type: 10  
serial: <filter>  
Mobo: Dell model: 0W970W v: A06 serial: <filter> UEFI: Dell v: 1.15.0 date: 06/07/2021  
Battery:   ID-1: BAT0 charge: 48.4 Wh (100.0%) condition: 48.4/52.0 Wh (93.1%) volts: 8.5 min: 7.6  
model: LGC-LGC6.73 DELL H754V05 type: Li-ion serial: <filter> status: Full  
CPU:       Info: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake note: check  
family: 6 model-id: 8E (142) stepping: A (10) microcode: EA cache: L2: 8 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31999  
Speed: 3785 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 3785 2: 3794 3: 3861 4: 3793  
5: 3790 6: 3968 7: 3786 8: 3825  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable  
Type: mds mitigation: Clear CPU buffers; SMT vulnerable  
Type: meltdown mitigation: PTI  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling  
Type: srbds mitigation: Microcode  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0  
chip-ID: 8086:5917 class-ID: 0300  
Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-5:2  
chip-ID: 0bda:58f4 class-ID: 0e02 serial: <filter>  
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel  
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1  
Screen-1: 0 s-res: 1920x1944 s-dpi: 96 s-size: 506x513mm (19.9x20.2") s-diag: 721mm (28.4")  
Monitor-1: eDP1 res: 1536x864 dpi: 135 size: 290x170mm (11.4x6.7") diag: 336mm (13.2")  
Monitor-2: DP1-1 res: 1920x1080 hz: 60 dpi: 81 size: 600x340mm (23.6x13.4") diag: 690mm (27.2")  
OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.2.3 direct render: Yes  
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel  
alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403  
Device-2: Realtek USB Audio type: USB driver: snd-usb-audio bus-ID: 3-1.3.4:7  
chip-ID: 0bda:402e class-ID: 0102 serial: <filter>  
Sound Server-1: ALSA v: k5.14.9-zen2-1-zen running: yes  
Sound Server-2: JACK v: 1.9.19 running: no  
Sound Server-3: PulseAudio v: 15.0 running: no  
Sound Server-4: PipeWire v: 0.3.38 running: yes  
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter  
vendor: Rivet Networks Killer 1435 Wireless-AC driver: ath10k_pci v: kernel port: f040  
bus-ID: 02:00.0 chip-ID: 168c:003e class-ID: 0280  
IF: wlp2s0 state: up mac: <filter>  
Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 bus-ID: 4-1.4:4  
chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>  
IF: enp57s0u1u4 state: up speed: 1000 Mbps duplex: full mac: <filter>  
Bluetooth: Device-1: Foxconn / Hon Hai type: USB driver: btusb v: 0.8 bus-ID: 1-7:3 chip-ID: 0489:e0a2  
class-ID: e001  
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 476.94 GiB used: 31.37 GiB (6.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: PC611 NVMe 512GB size: 476.94 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 11002111 temp: 46.9 C scheme: GPT
Partition: ID-1: / raw-size: 459.81 GiB size: 459.81 GiB (100.00%) used: 31.37 GiB (6.8%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-06b5b85e-d9c6-4b3d-8ad4-9160c300f9fc
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 708 KiB (0.3%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 459.81 GiB size: 459.81 GiB (100.00%) used: 31.37 GiB (6.8%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-06b5b85e-d9c6-4b3d-8ad4-9160c300f9fc
ID-4: /var/log raw-size: 459.81 GiB size: 459.81 GiB (100.00%) used: 31.37 GiB (6.8%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-06b5b85e-d9c6-4b3d-8ad4-9160c300f9fc
ID-5: /var/tmp raw-size: 459.81 GiB size: 459.81 GiB (100.00%) used: 31.37 GiB (6.8%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-06b5b85e-d9c6-4b3d-8ad4-9160c300f9fc
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.33 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 16.86 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/dm-1
maj-min: 254:1 mapped: luks-a775b892-c6c9-43c9-8c98-189505509025
Sensors:   System Temperatures: cpu: 59.0 C mobo: 42.0 C sodimm: SODIMM C
Fan Speeds (RPM): cpu: 4697
Info:      Processes: 285 Uptime: 51m wakeups: 9 Memory: 15.33 GiB used: 7.81 GiB (50.9%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1408 lib: 341
Shell: fish v: 3.3.1-393-g86a442fb6 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

Thanks!

Please check if the info in this post help, both the link with the hints on autostart, but also the suggestion on the possible problematic widgets (if you have your own widgets, you could start removing them all and if the problem is solved add one by one to find the problematic one).
In addition to that, you could make sure that your system is fully up-to-date (I see the kernel is a bit outdated) and just in case perform a full btrfs balance.

2 Likes

I had everything done from the latte-dock autostart hints except excluding it from restoring on start. Would it really be the cause of the problem though since it doesn't just happen at start but multiple times, even after I kill latte-dock and restart it manually?

I'm not using any widgets as far as I know. At least I haven't enabled anything. Since krunner is mentioned in the topic you linked, I should point out that even trying to run it using alt + space is incredibly slow after latte-dock freezes. Even now after restarting latte-dock for the fifth time, krunner takes over 30 seconds to show up.

I'll try the full update, thanks.


Edit with the new inxi output post-full system upgrade

System:    Kernel: 5.14.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=8a0a4f23-e4b4-468d-a55d-308b2de6b338 
rw [email protected] quiet 
cryptdevice=UUID=06b5b85e-d9c6-4b3d-8ad4-9160c300f9fc:luks-06b5b85e-d9c6-4b3d-8ad4-9160c300f9fc 
root=/dev/mapper/luks-06b5b85e-d9c6-4b3d-8ad4-9160c300f9fc splash rd.udev.log_priority=3 
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 
resume=/dev/mapper/luks-a775b892-c6c9-43c9-8c98-189505509025 loglevel=3 
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: Dell product: XPS 13 9370 v: N/A serial: <filter> Chassis: type: 10 
serial: <filter> 
Mobo: Dell model: 0W970W v: A06 serial: <filter> UEFI: Dell v: 1.15.0 date: 06/07/2021 
Battery:   ID-1: BAT0 charge: 48.4 Wh (100.0%) condition: 48.4/52.0 Wh (93.1%) volts: 8.5 min: 7.6 
model: LGC-LGC6.73 DELL H754V05 type: Li-ion serial: <filter> status: Full 
CPU:       Info: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake note: check 
family: 6 model-id: 8E (142) stepping: A (10) microcode: EA cache: L2: 8 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31999 
Speed: 3659 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 3659 2: 3747 3: 3724 4: 3614 
5: 3719 6: 3754 7: 3630 8: 3604 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
Type: meltdown mitigation: PTI 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Type: srbds mitigation: Microcode 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 
chip-ID: 8086:5917 class-ID: 0300 
Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-5:2 
chip-ID: 0bda:58f4 class-ID: 0e02 serial: <filter> 
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel 
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
Screen-1: 0 s-res: 1920x1944 s-dpi: 96 s-size: 506x513mm (19.9x20.2") s-diag: 721mm (28.4") 
Monitor-1: eDP1 res: 1536x864 dpi: 135 size: 290x170mm (11.4x6.7") diag: 336mm (13.2") 
Monitor-2: DP1-1 res: 1920x1080 hz: 60 dpi: 81 size: 600x340mm (23.6x13.4") diag: 690mm (27.2") 
OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.2.3 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403 
Device-2: Realtek USB Audio type: USB driver: snd-usb-audio bus-ID: 3-1.3.4:7 
chip-ID: 0bda:402e class-ID: 0102 serial: <filter> 
Sound Server-1: ALSA v: k5.14.12-zen1-1-zen running: yes 
Sound Server-2: JACK v: 1.9.19 running: no 
Sound Server-3: PulseAudio v: 15.0 running: no 
Sound Server-4: PipeWire v: 0.3.38 running: yes 
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
vendor: Rivet Networks Killer 1435 Wireless-AC driver: ath10k_pci v: kernel port: f040 
bus-ID: 02:00.0 chip-ID: 168c:003e class-ID: 0280 
IF: wlp2s0 state: up mac: <filter> 
Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 bus-ID: 4-1.4:4 
chip-ID: 0bda:8153 class-ID: 0000 serial: <filter> 
IF: enp57s0u1u4 state: up speed: 1000 Mbps duplex: full mac: <filter> 
IF-ID-1: wg-mullvad state: unknown speed: N/A duplex: N/A mac: N/A 
Bluetooth: Device-1: Foxconn / Hon Hai type: USB driver: btusb v: 0.8 bus-ID: 1-7:3 chip-ID: 0489:e0a2 
class-ID: e001 
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 476.94 GiB used: 34.53 GiB (7.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: PC611 NVMe 512GB size: 476.94 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 11002111 temp: 52.9 C scheme: GPT
Partition: ID-1: / raw-size: 459.81 GiB size: 459.81 GiB (100.00%) used: 34.53 GiB (7.5%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-06b5b85e-d9c6-4b3d-8ad4-9160c300f9fc
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 708 KiB (0.3%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 459.81 GiB size: 459.81 GiB (100.00%) used: 34.53 GiB (7.5%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-06b5b85e-d9c6-4b3d-8ad4-9160c300f9fc
ID-4: /var/log raw-size: 459.81 GiB size: 459.81 GiB (100.00%) used: 34.53 GiB (7.5%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-06b5b85e-d9c6-4b3d-8ad4-9160c300f9fc
ID-5: /var/tmp raw-size: 459.81 GiB size: 459.81 GiB (100.00%) used: 34.53 GiB (7.5%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-06b5b85e-d9c6-4b3d-8ad4-9160c300f9fc
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.33 GiB used: 2.2 MiB (0.0%) priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 16.86 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/dm-1
maj-min: 254:1 mapped: luks-a775b892-c6c9-43c9-8c98-189505509025
Sensors:   System Temperatures: cpu: 71.0 C mobo: 46.0 C sodimm: SODIMM C
Fan Speeds (RPM): cpu: 4812
Info:      Processes: 302 Uptime: 2m wakeups: 6 Memory: 15.33 GiB used: 4.69 GiB (30.6%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1408 lib: 341
Shell: fish v: 3.3.1-417-g7ccf001bc default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

Second edit: 20 minutes after full system upgrade, I just experienced another latte-dock freeze. Used krunner to run killall latte-dock && latte-dock and it froze again not even a minute after...

It might be worth testing a standard KDE theme.

Delay latte start up by 3 secs+ at login helps prevent crashes.

Try a plasma restart.

Just switched to Breeze Dark. I'll delay the latte startup too but as I said the problem occurs even when I manually run latte-dock after boot. For example, I just had to restart it again for the third time since it booted an hour ago. What's weird is that each time I kill and restart it, it takes increasingly longer. This time the dock was drawn after around 30 seconds, yet it took almost four minutes for it to be responsive.

Just restarted plasma too, will see if the theme change improves anything. Thanks!


Edit: well, I realized just after replying that my clock is now three minutes behind, which means it's been frozen since then and I hadn't noticed.

I am everything but a fan of reddit, but maybe you could try this one...

I have "None" there, in Task -> Actions -> Hover.
You could also try switching to a different kernel, maybe the lts...

1 Like

I had already found that Reddit thread, unfortunately the action was already set to "None" for me.

As a last resort and since I noticed that the freezes started happening a lot more when I started using xrandr for my 4k integrated screen (down-scaling it to make it readable), I simply set it back to its native scale. I can't read anything anymore on that screen because of how small it is but it seems to have fixed the freezes (at least for the past few hours now).

Why?

3 Likes

My laptop has a 4k screen but the external monitor that's connected to it is only 1080p. If I set the global scale to 200%, everything looks huge on the 1080p monitor - and there is no fractional scaling option. I've tried many things to get both displays to be readable but in the end scaling down the 4k display with xrandr was what worked the best.

Well, I guess it was just dumb luck that nothing froze for a few hours after I stopped using xrandr. It's back and already froze twice in less than 10 minutes. Is there anything I can do to get latte-dock to be more verbose (other than -d)?


Edit:

An observation: just before latte-dock starts freezing, system functions such as Alt-Tab, Alt-Space and media keys start to feel sluggish and take multiple seconds to become responsive. Alt-Space (krunner) takes over 30 seconds to show the dialog immediately after latte-dock becomes frozen. Even pausing my music using the earphones' command didn't work when latte-dock started freezing.

I ended up resetting the latte layout to the default one and things seem to have settled. Some of the changes I had included adding a top bar and a dock to my secondary screen. Since I reset the layout controls now disappear again when an app is in fullscreen on my secondary screen. It seems that the freezes occur due to the second top bar as it started freezing again as soon as I added back the second top bar. Overall latte-dock seems pretty unstable to me...

Latte has a special troubleshooting function and auto-discovers possible problems.
Check for such a button in Latte configuration window. (Something about layouts?)
It is possible there are old shadowed/hidden latte panels/docks that create this mess (even if you can't see them), mostly confused because of add/remove monitors, something that is a real PITA in Plasma currently).

3 Likes

Latte-dock did notify me about a problem in the layout but that was a while ago, before the problems even started. When it notified me I applied the fix and everything still worked fine. It's only when I started looking into adding a dock/top bar to my second screen that things started to freeze it seems.

To be clear, adding a second top bar to a brand new layout still causes freezes. I'm not sure what the numbers in "Includes" refer to but they keep increasing:

I was (and still am) fan of Latte project. For the most time, it was a path to overcome certain plasma disabilities and improve the daily work functionality, while using Plasma/KDE.
Unfortunately, Plasma has not recovered yet, from the multihead management difficulty and since they have focused on this subject in order to solve it, they eventually get into subsequent issues because of the new fixes. That's a development path for every program.
I could not handle it and moved to other DEs, for improving my everyday work. You lose something, to get something more valuable... :man_shrugging:
Gnome is more stable. I currently am on Cinnamon, which has such functionality that can mimic Plasma/kWin/Latte ones.

Choose your poison! :laughing:

3 Likes

It really is a shame because latte-dock is one of the most elegant and beautiful solution out there.

It's exactly what I'm thinking of doing if the problems continue as it seems too big of a hassle. I'm running Garuda on a work laptop and due to latte/KDE problems I've had to reboot countless times.

Cinnamon as in Linux Mint? Do you not recommend simply switching to Garuda Gnome?

Mint develops cinnamon.

Switching to any Garuda ISO version, from an installed Garuda system, is equivaled to installing the specific DE and Garuda that-DE settings. Search in packages and/or the forum/wiki for more.

2 Likes

I had problems with Latte-Dock. After removing the latte-dock, they disappeared. Just create a lower panel in the edit mode of KDE. But in addition to friezes there were memory leaks at 30 GB. Before removing Latte-Dock, turn off endless windows in its settings.

1 Like

I have no problems but maybe this is the solution

2 Likes

Thanks! If I have no other choice then that's what I'll do. I'm not sure what "endless windows" is though as I can't find that setting.

I updated the applet, will see if it changes anything. Thanks!

No! I suggest if you decide to do this, spend a day with Gnome. I did recently, and came away with the new found opinion it is the WORST linux desktop available. I know that is a trigger for some, but out of the box, it is either lacking functionality (how can you live with out a status tray?) or demands multiple clicks to do a task. You will eventually need to install an extension, which automatically makes KDE's GUI mishaps a pleasure, as any of Gnome's extensions could and most likely will break your system down the road. The extensions have gotten worse, as the new 40 Gnome will not allow you to install via browsers as in the past, so it is a hunting game trying to find one that works either on the website or in the repos. User friendly? Think not.

The only way to use Gnome is to use a variation, Cinnamon, Mate, Budgie, etc. I went running back to KDE with a new found appreciation. ....and end rant, cut scene. :clapper:

8 Likes