Latest Update breaks dependency required by garuda-dr460nized

That's a first for me.

The update today is not going through cuz

removing nerd-fonts-fira-code breaks dependency 'nerd-fonts-fira-code' required by garuda-dr460nized

╰─λ upd
:: Synchronizing package databases...
garuda 95.6 KiB 119 KiB/s 00:01 [---------------------------------------------------------------------------------] 100%
core 157.7 KiB 287 KiB/s 00:01 [---------------------------------------------------------------------------------] 100%
extra 1760.9 KiB 2.02 MiB/s 00:01 [---------------------------------------------------------------------------------] 100%
community 7.2 MiB 5.66 MiB/s 00:01 [---------------------------------------------------------------------------------] 100%
multilib 167.5 KiB 304 KiB/s 00:01 [---------------------------------------------------------------------------------] 100%
chaotic-aur 1989.2 KiB 2.14 MiB/s 00:01 [---------------------------------------------------------------------------------] 100%
looking for conflicting packages...

Package (1) Old Version New Version Net Change Download Size

garuda/garuda-update 3.0.7-1 3.1.3-1 0.00 MiB 0.01 MiB

Total Download Size: 0.01 MiB
Total Installed Size: 0.02 MiB
Net Upgrade Size: 0.00 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages...
garuda-update-3.1.3-1-any 8.9 KiB 21.3 KiB/s 00:00 [---------------------------------------------------------------------------------] 100%
(1/1) checking keys in keyring [---------------------------------------------------------------------------------] 100%
(1/1) checking package integrity [---------------------------------------------------------------------------------] 100%
(1/1) loading package files [---------------------------------------------------------------------------------] 100%
(1/1) checking for file conflicts [---------------------------------------------------------------------------------] 100%
(1/1) checking available disk space [---------------------------------------------------------------------------------] 100%
:: Running pre-transaction hooks...

[...]

--> Refreshing mirrorlists using reflector, please be patient..
:: Synchronizing package databases...
garuda 95.6 KiB 166 KiB/s 00:01 [---------------------------------------------------------------------------------] 100%
core 157.7 KiB 374 KiB/s 00:00 [---------------------------------------------------------------------------------] 100%
extra 1760.9 KiB 3.00 MiB/s 00:01 [---------------------------------------------------------------------------------] 100%
community 7.2 MiB 10.1 MiB/s 00:01 [---------------------------------------------------------------------------------] 100%
multilib 167.5 KiB 378 KiB/s 00:00 [---------------------------------------------------------------------------------] 100%
chaotic-aur 1989.2 KiB 2.50 MiB/s 00:01 [---------------------------------------------------------------------------------] 100%
spawn pacman -Su
:: Starting full system upgrade...
warning: garuda-fastfetch-git: local (1.5.5.r399.g8f4cdc2-1) is newer than garuda (r1314.d746d5b-1)
:: Replace nerd-fonts-fira-code with community/ttf-firacode-nerd? [Y/n] y
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nerd-fonts-fira-code breaks dependency 'nerd-fonts-fira-code' required by garuda-dr460nized

I cannot hit "N" as it sends automatically "Y".
Never encountered such an issue with garuda packages, so the only thing I think of is to ignore nerd-fonts-fira-code in pacman.conf, but I have no idea if it will work.

Before I try that I wanted to seek assistance and see how you masters would get around this cleanly. I didn't see any topic related to any of those 2 specific packages, but I'm sure there are topics with similar issue and different packages. I could not find them, though. :frowning:

If you know such a topic exists, would it be too much asked to redirect me to it?

Thanks

System:
Kernel: 6.0.7-272-tkg-bore arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: it87.force_id=0x8686 mitigations=off amd_pstate.shared_mem=1
BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bore-amd
root=UUID=27cfff44-6eda-4ada-8ae8-e7b01a8e8acd rw [email protected] rw
quiet splash loglevel=3
Desktop: KDE Plasma v: 5.26.3 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_wayland vt: 2 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Gigabyte product: X570 AORUS ELITE v: -CF
serial: <superuser required>
Mobo: Gigabyte model: X570 AORUS ELITE serial: <superuser required>
BIOS: American Megatrends LLC. v: F37d date: 07/27/2022
Battery:
Device-1: hidpp_battery_0 model: Logitech Wireless Illuminated Keyboard K800
serial: <filter> charge: 10% (should be ignored) rechargeable: yes
status: discharging
Device-2: hidpp_battery_1 model: Logitech Wireless Mouse MX Master
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: AMD Ryzen 9 5900X bits: 64 type: MT MCP arch: Zen 3 gen: 4
level: v3 note: check built: 2021-22 process: TSMC n7 (7nm)
family: 0x19 (25) model-id: 0x21 (33) stepping: 2 microcode: 0xA20120A
Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 2685 high: 3680 min/max: 550/3701 boost: disabled
scaling: driver: amd-pstate governor: ondemand cores: 1: 2937 2: 582 3: 3669
4: 2940 5: 3675 6: 2752 7: 2935 8: 2930 9: 2933 10: 2940 11: 2940 12: 1651
13: 2940 14: 2940 15: 3680 16: 865 17: 3655 18: 3675 19: 2939 20: 2940
21: 2057 22: 550 23: 1658 24: 3675 bogomips: 177600
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass status: Vulnerable
Type: spectre_v1 status: Vulnerable: __user pointer sanitization and
usercopy barriers only; no swapgs barriers
Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled,
PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 24 [Radeon RX 6400/6500 XT/6500M] vendor: Gigabyte
driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm)
built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: DP-1
empty: HDMI-A-1 bus-ID: 0a:00.0 chip-ID: 1002:743f class-ID: 0300
Display: wayland server: X.org v: 1.21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_wayland driver: X: loaded: amdgpu dri: radeonsi gpu: amdgpu
display-ID: 0
Monitor-1: DP-1 res: 3840x2160 size: N/A modes: N/A
API: OpenGL v: 4.6 Mesa 22.2.3 renderer: AMD Radeon RX 6500 XT (navi24
LLVM 14.0.6 DRM 3.48 6.0.7-272-tkg-bore) direct render: Yes
Audio:
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0a:00.1 chip-ID: 1002:ab28
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
Sound API: ALSA v: k6.0.7-272-tkg-bore running: yes
Sound Server-1: JACK v: 1.9.21 running: no
Sound Server-2: PulseAudio v: 16.1 running: yes
Sound Server-3: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Intel I211 Gigabit Network vendor: Gigabyte driver: igb v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 04:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: nordlynx state: unknown speed: N/A duplex: N/A mac: N/A
Drives:
Local Storage: total: 931.51 GiB used: 662.34 GiB (71.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 type: SSD serial: <filter> rev: 1B2QGXA7 temp: 36.9 C scheme: MBR
Partition:
ID-1: / raw-size: 122.07 GiB size: 122.07 GiB (100.00%)
used: 34.04 GiB (27.9%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-2: /home raw-size: 122.07 GiB size: 122.07 GiB (100.00%)
used: 34.04 GiB (27.9%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /var/log raw-size: 122.07 GiB size: 122.07 GiB (100.00%)
used: 34.04 GiB (27.9%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-4: /var/tmp raw-size: 122.07 GiB size: 122.07 GiB (100.00%)
used: 34.04 GiB (27.9%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 50 (default 100)
ID-1: swap-1 type: zram size: 15.56 GiB used: 228.9 MiB (1.4%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 31.1 C mobo: 27.0 C gpu: amdgpu temp: 37.0 C
mem: 36.0 C
Fan Speeds (RPM): cpu: 261 fan-1: 582 fan-3: 274 fan-4: 0 fan-5: 340
gpu: amdgpu fan: 443
Power: 12v: N/A 5v: N/A 3.3v: N/A vbat: 3.24 gpu: amdgpu watts: 8.00
Info:
Processes: 452 Uptime: 23h 48m wakeups: 61 Memory: 15.56 GiB
used: 6.95 GiB (44.7%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
pkgs: 1428 libs: 341 tools: pamac,paru,yay Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: yakuake inxi: 3.3.23
Garuda (2.6.9-1):
System install date:     2022-05-15
Last full system update: 2022-11-11
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:

Hum, can't recall how to collapse the inxi into a chevron.

3 Likes

Just had the same exact problem.

I thought of that too. Considering its required by garuda-dr460nized, I hesitated though. I'm sure the team will fix this issue after seeing this.

1 Like

I have the same problem when i try to update or install anything from pamac

could not satisfy dependencies:

  • removing nerd-fonts-fira-code breaks dependency 'nerd-fonts-fira-code' required by garuda-dr460nized
System:
Kernel: 6.0.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-linux-zen
root=UUID=79255f42-88b2-4fea-9fb5-09967815bea8 rw quiet quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.26.3 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Gigabyte model: B550 AORUS MASTER
serial: <superuser required> UEFI: American Megatrends LLC. v: F15d
date: 05/11/2022
CPU:
Info: model: AMD Ryzen 9 5900X bits: 64 type: MT MCP arch: Zen 3 gen: 4
level: v3 note: check built: 2021-22 process: TSMC n7 (7nm)
family: 0x19 (25) model-id: 0x21 (33) stepping: 0 microcode: 0xA201016
Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 3683 high: 3693 min/max: N/A cores: 1: 3693 2: 3693
3: 3693 4: 3693 5: 3693 6: 3593 7: 3693 8: 3693 9: 3693 10: 3693 11: 3693
12: 3693 13: 3693 14: 3693 15: 3568 16: 3693 17: 3693 18: 3693 19: 3693
20: 3693 21: 3693 22: 3693 23: 3693 24: 3693 bogomips: 177266
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GA102 [GeForce RTX 3080 Lite Hash Rate] vendor: ASUSTeK
driver: nvidia v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 520.xx+
status: current (as of 2022-10) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
lanes: 16 bus-ID: 06:00.0 chip-ID: 10de:2216 class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_x11 driver: N/A display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 108 s-size: 602x341mm (23.70x13.43")
s-diag: 692mm (27.24")
Monitor-1: DP-0 res: 2560x1440 dpi: 65024 size: 1x1mm (0.04x0.04")
diag: 1mm (0.06") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 520.56.06 renderer: NVIDIA GeForce RTX
3080/PCIe/SSE2 direct render: Yes
Audio:
Device-1: NVIDIA GA102 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel bus-ID: 3-1:2 v: kernel pcie: chip-ID: 1852:7022
gen: 4 class-ID: 0102 speed: 16 GT/s lanes: 16 bus-ID: 06:00.1
chip-ID: 10de:1aef class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 08:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: GYROCOM C&C Fiio E10 type: USB
driver: hid-generic,snd-usb-audio,usbhid
Device-4: Kingston HyperX QuadCast type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-2:3 chip-ID: 0951:16df
class-ID: 0300 serial: <filter>
Sound API: ALSA v: k6.0.8-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: f000 bus-ID: 04:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 05:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp5s0 state: down mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-5:2
chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter note: tool can't run ID: hci0 rfk-id: 1 state: down
bt-service: disabled rfk-block: hardware: no software: no address: N/A
Drives:
Local Storage: total: 5.65 TiB used: 4.18 TiB (74.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Corsair model: Force MP510
size: 894.25 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: <filter> rev: ECFM12.2 temp: 44.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS721010A9E630
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: A3J0 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD4005FZBX-00K5WB0 size: 3.64 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
rev: 1A01 scheme: GPT
ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: Kingston model: SNV2S250G
size: 232.89 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: 1.00 scheme: MBR
Partition:
ID-1: / raw-size: 326.92 GiB size: 320.72 GiB (98.10%)
used: 157.43 GiB (49.1%) fs: ext4 dev: /dev/nvme0n1p6 maj-min: 259:6
ID-2: /boot/efi raw-size: 868 MiB size: 858 MiB (98.85%)
used: 71 MiB (8.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.25 GiB used: 1.23 GiB (3.9%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 4 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p5 maj-min: 259:5
Sensors:
System Temperatures: cpu: 43.6 C mobo: N/A gpu: nvidia temp: 47 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
Processes: 458 Uptime: 5h 47m wakeups: 0 Memory: 31.25 GiB
used: 4.99 GiB (16.0%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 1573
pm: pacman pkgs: 1566 libs: 431 tools: octopi,pamac,paru pm: flatpak pkgs: 7
Shell: fish v: 3.5.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.23```
1 Like

Ok so I am not alone. That's good... thanks Kayo and MR-Root! :slight_smile:

1 Like

Should be fixed!

@MR-Root please avoid using pamac for updating your system. Use garuda-update.

7 Likes

It's fixed!
How on earth can you do that so quickly??? :smiley:

2 Likes

Nice. I was given the option to skip over the conflict. You are super quick!

Edit: I just get a partial upgrade notice now, but I'm sure that is superficial considering I've just skipped over the conflict.

1 Like

Use garuda repo for this: pacman -S garuda/garuda-fastfetch-git. The version is different, but you can see yours is much older at r399.

6 Likes

Ha! Yeah I kept getting that warning for a long time and didn't know whether it was important or not. Turns out it was!

Thanks for the hint, Technetium!

2 Likes

Just ran garuda-update again and the problem is completely solved. Great work!

3 Likes

Trying garuda-update and still showing the same problem as OP.

1 Like

Please post the exact output as well as the output of curl https://status.chaotic.cx/geo @chicagonyc

Just ran Garuda Setup Assistant. Same problem as OP.

:: Synchronising package databases...
 garuda                                 95.7 KiB  18.9 KiB/s 00:05 [------------------------------------] 100%
 core is up to date
 extra                                1760.9 KiB   346 KiB/s 00:05 [------------------------------------] 100%
 community                               7.2 MiB   540 KiB/s 00:14 [------------------------------------] 100%
 multilib is up to date
 chaotic-aur                          1990.1 KiB   133 KiB/s 00:15 [------------------------------------] 100%
error: failed retrieving file 'garuda.db' from geo-mirror.chaotic.cx : SSL connection timeout

--> Refreshing mirrorlists using rate-mirrors, please be patient..
:: Synchronising package databases...
 garuda                                 95.7 KiB  11.4 KiB/s 00:08 [------------------------------------] 100%
 core                                  157.7 KiB  50.7 KiB/s 00:03 [------------------------------------] 100%
 extra                                1760.6 KiB   319 KiB/s 00:06 [------------------------------------] 100%
 community                               7.2 MiB   900 KiB/s 00:08 [------------------------------------] 100%
 multilib                              167.5 KiB  69.8 KiB/s 00:02 [------------------------------------] 100%
 chaotic-aur                          1990.1 KiB   356 KiB/s 00:06 [------------------------------------] 100%
spawn pacman -Su
:: Starting full system upgrade...
:: Replace nerd-fonts-fira-code with community/ttf-firacode-nerd? [Y/n] y
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nerd-fonts-fira-code breaks dependency 'nerd-fonts-fira-code' required by garuda-gnome-settings
Press enter to exit

```text
System:
  Kernel: 6.0.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=e0aa6bf1-e32d-48b2-a659-01e4322f83f8
    rw [email protected] quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=31f5f81c-4fb3-4a39-893a-3e7c25a0feb6 loglevel=3
  Desktop: GNOME v: 43.1 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM v: 43.0 Distro: Garuda Linux
    base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X513UA_M513UA v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: X513UA v: 1.0 serial: <superuser required> UEFI: American Megatrends LLC.
    v: X513UA.312 date: 04/26/2022
Battery:
  ID-1: BAT0 charge: 26.0 Wh (62.7%) condition: 41.5/42.1 Wh (98.6%) volts: 11.8 min: 11.8
    model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: charging cycles: 18
CPU:
  Info: model: AMD Ryzen 5 5500U with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2 gen: 3
    level: v3 note: check built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
    model-id: 0x68 (104) stepping: 1 microcode: 0x8608103
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache: L1: 384 KiB
    desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 8 MiB desc: 2x4 MiB
  Speed (MHz): avg: 1665 high: 4007 min/max: 1400/4056 boost: enabled scaling:
    driver: acpi-cpufreq governor: powersave cores: 1: 1834 2: 4007 3: 1483 4: 1400 5: 1468 6: 1400
    7: 1397 8: 1400 9: 1397 10: 1400 11: 1397 12: 1400 bogomips: 50306
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP protection
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP: always-on, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Lucienne vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-5.1 code: Vega-2
    process: TSMC n7 (7nm) built: 2018-21 pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:164c
    class-ID: 0300 temp: 40.0 C
  Device-2: Quanta USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus-ID: 3-3:3
    chip-ID: 0408:30d4 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5 compositor: gnome-shell driver:
    X: loaded: amdgpu unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: Samsung 0x4161 built: 2020 res: 1920x1080 hz: 60 dpi: 142
    gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9 modes: max: 1920x1080
    min: 640x480
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: ASUSTeK driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x, snd_acp_pci,
    snd_rpl_pci_acp6x, snd_sof_amd_renoir pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie:
    gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound API: ALSA v: k6.0.8-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 01:00.0 chip-ID: 8086:2725 class-ID: 0280
  IF: wlp1s0 state: down mac: <filter>
  Device-2: ZTE WCDMA MSM DEMO Mobile Boardband type: USB driver: cdc_ether,usb-storage
    bus-ID: 1-3:3 chip-ID: 19d2:1405 class-ID: 0806 serial: <filter>
  IF: enp3s0f3u3 state: up speed: 150 Mbps duplex: half mac: <filter>
Bluetooth:
  Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-2:2 chip-ID: 8087:0032
    class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 11.82 GiB (2.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLQ512HALU-00000 size: 476.94 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: FXV7101Q temp: 33.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 146.49 GiB size: 146.49 GiB (100.00%) used: 10.74 GiB (7.3%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 1024 MiB size: 1022 MiB (99.80%) used: 608 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 321.45 GiB size: 321.45 GiB (100.00%) used: 1.08 GiB (0.3%) fs: btrfs
    dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-4: /var/log raw-size: 146.49 GiB size: 146.49 GiB (100.00%) used: 10.74 GiB (7.3%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 146.49 GiB size: 146.49 GiB (100.00%) used: 10.74 GiB (7.3%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3
    maj-min: 259:3
  ID-2: swap-2 type: zram size: 7.15 GiB used: 9.2 MiB (0.1%) priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 43.5 C mobo: N/A gpu: amdgpu temp: 40.0 C
  Fan Speeds (RPM): cpu: 2300
Info:
  Processes: 364 Uptime: 15h 37m wakeups: 3 Memory: 7.15 GiB used: 3.48 GiB (48.7%) Init: systemd
  v: 252 default: graphical tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1180
  libs: 328 tools: pamac,paru Client: shell wrapper v: 5.1.16-release inxi: 3.3.23
Garuda (2.6.9-1):
  System install date:     2022-11-12
  Last full system update: 2022-11-12 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            

I don't think that's normal. I didn't have that DB issue.

What's your output of curl https://status.chaotic.cx/geo ?

Same here.

error: failed to prepare transaction (could not satisfy dependencies)
:: removing nerd-fonts-fira-code breaks dependency 'nerd-fonts-fira-code' required by garuda-gnome-settings
curl https://status.chaotic.cx/geo
us-va-3-mirror 1668298152 Healthy

╰─λ curl https://status.chaotic.cx/geo
fr-3-mirror 1668298709 Healthy

Right, your issue is with garuda and not chaotic. I don't know how to check garuda mirror...

similar issue as op


--> Refreshing mirrorlists using rate-mirrors, please be patient..
:: Synchronizing package databases...
garuda                                 95.7 KiB   121 KiB/s 00:01 [------------------------------------] 100%
core                                  157.7 KiB   421 KiB/s 00:00 [------------------------------------] 100%
extra                                1759.9 KiB  2.48 MiB/s 00:01 [------------------------------------] 100%
community                               7.2 MiB  5.68 MiB/s 00:01 [------------------------------------] 100%
multilib                              167.5 KiB   441 KiB/s 00:00 [------------------------------------] 100%
chaotic-aur                          1992.5 KiB  2.10 MiB/s 00:01 [------------------------------------] 100%
blackarch                               3.7 MiB  1665 KiB/s 00:02 [------------------------------------] 100%
spawn pacman -Su
:: Starting full system upgrade...
warning: burpsuite: local (1:2022.5.2-1) is newer than chaotic-aur (2022.9.5-1.1)
warning: leftwm: local (1:0.3.0-1) is newer than chaotic-aur (0.4.0-4)
warning: python-limits: local (2.6.3-1) is newer than blackarch (2.6.2-1)
warning: python-minidump: local (1:0.0.21-2) is newer than community (0.0.21-2)
warning: python-pynput: local (1.7.6-2) is newer than blackarch (1.7.6-1)
resolving dependencies...
looking for conflicting packages...
:: ttf-firacode-nerd and nerd-fonts-complete are in conflict (nerd-fonts-fira-code). Remove nerd-fonts-complete? [y/N] y
y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nerd-fonts-complete breaks dependency 'nerd-fonts-fantasque-sans-mono' required by garuda-fish-config

Seems like you manually installed nerd-fonts-complete from the AUR. I have let the author of that package know and told them how to fix this. In the meantime, you can rebuild the package with ttf-firacode-nerd added to the provides array to fix this on your end.

Thanks for the detailed logs @Colin, this issue is now fixed too.

1 Like

@redragonx alternatively, you can make use of a fancy new garuda-update feature and switch back to the official packages for those fonts: garuda-update -- ttf-firacode-nerd nerd-fonts-fantasque-sans-mono

1 Like