Last update of sddm caused black screen after plymouth

I just hope no one will port there the patches causing the issue in sddm :blush:

1 Like

Yeah, I hope so too. Although it's unlikely

1 Like

@ExistingDude please stop posting your issues on this thread. You have opened your own separate thread on your issue.

As I see it your issue has the same root cause, but you have reused your home directory from a prior installation which may be contributing to your problems.

Please don't muddy the waters here. Keep your issues on your own thread. If you persist posting here I will purge all your posts from this thread.

Edit:

As I suspected your home directory issues were preventing you from correcting your problem. I am purging your posts from this thread so that others looking for a solution to this issue aren't confused by your unrelated posts.

2 Likes

When you remove splash from grub command line, I believe you have to also replace sddm-plymouth with sddm.
This should logically be done properly (during boot), if you also add 3 at grub command line, so you will boot to TTY (before SDDM), login and disable sddm-plymouth. Start sddm.service. If it succeeds, you can enable it (to permanently be in charge), but you should also remove splash at /etc/default/grub and plymouth from mkinitcpio (re-create images and grub after that).

Can someone confirm this works? (I cannot confirm and so I am not certain).

1 Like

Well, actually I removed splash as a first step only to check possibile error messages during the booting process.
By chance, I discovered that the issue was not occurring anymore in that way, so I took the chance to downgrade sddm, which had just been updated before the issue.
So, for me removing splash was only temporary and I'd prefer avoiding to change things now...

1 Like

So I restored the snapshot, did a -Syu update (which did indeed upgrade SDDM to 0.19.0-5) but when I am going to downgrade back to 0.19.0-4 it says package does not exist. I can confirm that as much as all that currently exists in the /var/cache/pacman/pkg directory are:

sddm-0.19.0-5-x86_64.pkg.tar.zst
sddm-kcm-5.21.4-1-x86_64.pkg.tar.zst

I am wondering if maybe this is due to an over zealous cache cleaning hook but I honestly don't know. In any case, I have not been able to find a source for sddm-0.19.0-4-x86_64.pkg.tar.zst so if anyone has any suggestions I would sincerely appreciate it.

I had this problem, couldn't restore snapshots and couldn't even access tty, had to reinstall from dragonized 210406... Should I be fine proceeding with a full update like this:

pacman -Syu --ignore sddm

?

I do not have a snapshot, I have no choice but to re-install?

Read the above posts for other options to try.
Remove splash from grub. Boot to TTY. Downgrade sddm, or install sddm-git.

I was never able to find the package for sddm-0.19.0-4 so I went ahead and just installed the git version through AUR. I was able to reboot normally and this along with the other issues which brought me to this thread no longer appear to be, so hopefully everything is fixed. Ive been a Garuda user for about a month now after several years of distro-hopping and just set up this forum account today to resolve this issue , but I gotta say I am very impressed with everything so far and I'm excited to watch the future of this project as it continues to evolve and develop. Thanks to everyone who provided information , I appreciate your help.

6 Likes

Is this mean I need to re-install ot I just need to wait the fix update?

So I have the same problem although I pressed the power button to turn the laptop off and when I turn it back on again it shows up the login screen but it takes longer than normal. Should I change to sddm-git ? how do I do that through pamac ? Can I just uninstall the sddm package and install sddm-git and restart ?

Ok, can confirm

pacman -Sy sddm-git && pacman -Syu

Works as a straight upgrade from the latest image.

Pacman will say there's a conflict and ask to replace sddm with sddm-git, so no need to remove prior.

4 Likes

Thanks for the support and testing! I love this community. Going to restart If it works flawlessly I will report back

1 Like

That's kind of strange, because I updated to sddm-0.19.0-5 and KDE boots normally.

So, I did exchange them and this time the restart worked flawlessly.

I did have a problem sddm-0.19.0-5 when it comes to show the login screen but after a hard turn off and turn back on It shows up, I don't know if it was something that does require a cold boot or not but strangely It showed up but it took some time.

I got that. But I can register without any problems, other users cannot. That is why I wonder what is going on differently with me than with your system.

1 Like

Well let's compare with inxi:

System:
  Kernel: 5.10.32-1-lts x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts 
  root=UUID=30f871dd-7d1e-48fd-8a77-9fcbb44a5f1a rw rootflags=subvol=@ quiet splash 
  rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 
  loglevel=3 
  Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 
  dm: SDDM Distro: Garuda Linux base: Arch Linux 
Machine:
  Type: Laptop System: Dell product: Inspiron 15 7000 Gaming v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 0P84C9 v: A01 serial: <filter> UEFI: Dell v: 1.12.1 
  date: 06/19/2020 
CPU:
  Info: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake 
  family: 6 model-id: 9E (158) stepping: 9 microcode: DE cache: L2: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44798 
  Speed: 3407 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 3407 2: 3418 3: 3419 
  4: 3435 5: 3417 6: 3404 7: 3436 8: 3415 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 
  chip-ID: 8086:591b class-ID: 0300 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Dell driver: nvidia 
  v: 460.67 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1c8c 
  class-ID: 0300 
  Device-3: Realtek Integrated Webcam type: USB driver: uvcvideo bus-ID: 1-12:4 
  chip-ID: 0bda:568a class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: 
  loaded: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa display-ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 dpi: 142 size: 344x193mm (13.5x7.6") 
  diag: 394mm (15.5") 
  OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 21.0.2 
  direct render: Yes 
Audio:
  Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
  bus-ID: 00:1f.3 chip-ID: 8086:a171 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.32-1-lts running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.25 running: yes 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell 
  driver: r8169 v: kernel port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Dell 
  driver: ath10k_pci v: kernel port: d000 bus-ID: 03:00.0 chip-ID: 168c:003e 
  class-ID: 0280 
  IF: wlp3s0 state: down mac: <filter> 
  IF-ID-1: docker0 state: down mac: <filter> 
Bluetooth:
  Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-4:3 
  chip-ID: 0cf3:e007 class-ID: e001 
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: <filter> 
Drives:
  Local Storage: total: 1.82 TiB used: 231.58 GiB (12.4%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: KingDian model: NGFF 2280 1TB SSD 
  size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 9A0 scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB 
  block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm 
  serial: <filter> rev: 3D scheme: GPT 
Partition:
  ID-1: / raw-size: 100.59 GiB size: 100.59 GiB (100.00%) used: 46.66 GiB (46.4%) 
  fs: btrfs dev: /dev/sda3 maj-min: 8:3 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 560 KiB (0.2%) 
  fs: vfat dev: /dev/sda1 maj-min: 8:1 
  ID-3: /home raw-size: 830.63 GiB size: 830.63 GiB (100.00%) used: 184.91 GiB (22.3%) 
  fs: btrfs dev: /dev/sda2 maj-min: 8:2 
  ID-4: /var/log raw-size: 100.59 GiB size: 100.59 GiB (100.00%) 
  used: 46.66 GiB (46.4%) fs: btrfs dev: /dev/sda3 maj-min: 8:3 
  ID-5: /var/tmp raw-size: 100.59 GiB size: 100.59 GiB (100.00%) 
  used: 46.66 GiB (46.4%) fs: btrfs dev: /dev/sda3 maj-min: 8:3 
Swap:
  Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100) 
  ID-1: swap-1 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram0 
  ID-2: swap-2 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram1 
  ID-3: swap-3 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram2 
  ID-4: swap-4 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram3 
  ID-5: swap-5 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram4 
  ID-6: swap-6 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram5 
  ID-7: swap-7 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram6 
  ID-8: swap-8 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram7 
Sensors:
  System Temperatures: cpu: 52.0 C mobo: 41.0 C sodimm: SODIMM C 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 289 Uptime: 6m wakeups: 1 Memory: 23.35 GiB used: 2.94 GiB (12.6%) 
  Init: systemd v: 248 tool: systemctl Compilers: gcc: 10.2.0 clang: 11.1.0 
  Packages: 1925 pacman: 1914 lib: 545 flatpak: 6 snap: 5 Shell: Zsh v: 5.8 
  running-in: konsole inxi: 3.3.04
╰─λ inxi -Fxxxza
System:    Kernel: 5.11.15-zen1-2-zen x86_64 bits: 64 compiler: gcc v: 10.2.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=f49fa305-3726-4c06-8883-e7d6bebd8dee  
rw rootflags=subvol=@ quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 2 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Laptop System: Acer product: Aspire A517-51G v: V2.03 serial: <filter>  
Mobo: KBL model: Dragonite_KL v: V2.03 serial: <filter> UEFI: Insyde v: 2.03 date: 05/22/2019  
Battery:   ID-1: BAT1 charge: 45.9 Wh (100.0%) condition: 45.9/48.9 Wh (93.7%) volts: 15.9 min: 15.2  
model: LG 004B384234314341 type: Li-ion serial: <filter> status: Full  
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: <filter>  
charge: 55% (should be ignored) rechargeable: yes status: Discharging  
CPU:       Info: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake note: check  
family: 6 model-id: 8E (142) stepping: A (10) microcode: E0 cache: L2: 8 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31999  
Speed: 3890 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 3890 2: 3861 3: 4001 4: 3996  
5: 3974 6: 3819 7: 3899 8: 3915  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable  
Type: mds mitigation: Clear CPU buffers; SMT vulnerable  
Type: meltdown mitigation: PTI  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling  
Type: srbds mitigation: Microcode  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Acer Incorporated ALI driver: i915 v: kernel  
bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300  
Device-2: NVIDIA GP108M [GeForce MX150] vendor: Acer Incorporated ALI driver: nvidia  
v: 465.24.02 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1d10 class-ID: 0302  
Device-3: Quanta HD Webcam type: USB driver: uvcvideo bus-ID: 1-7:6 chip-ID: 0408:a060  
class-ID: 0e02 serial: <filter>  
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: intel,nvidia  
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa display-ID: :0 screens: 1  
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")  
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 128 size: 380x210mm (15.0x8.3") diag: 434mm (17.1")  
OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.0.2 direct render: Yes  
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel  
v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403  
Sound Server-1: ALSA v: k5.11.15-zen1-2-zen running: yes  
Sound Server-2: JACK v: 0.125.0 running: no  
Sound Server-3: PulseAudio v: 14.2 running: yes  
Sound Server-4: PipeWire v: 0.3.25 running: yes  
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI  
driver: r8169 v: kernel port: 3000 bus-ID: 02:00.1 chip-ID: 10ec:8168 class-ID: 0200  
IF: enp2s0f1 state: up speed: 1000 Mbps duplex: full mac: <filter>  
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lite-On  
driver: ath10k_pci v: kernel port: 3000 bus-ID: 03:00.0 chip-ID: 168c:0042 class-ID: 0280  
IF: wlp3s0 state: down mac: <filter>  
Bluetooth: Device-1: Lite-On Qualcomm Atheros QCA9377 Bluetooth type: USB driver: btusb v: 0.8  
bus-ID: 1-5:5 chip-ID: 04ca:3015 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:    Local Storage: total: 1.37 TiB used: 11.71 GiB (0.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10SPZX-21Z10T0 size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter>
rev: 1A02 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: SK Hynix model: HFS256G39TND-N210A size: 238.47 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter>
rev: 1P10 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Hitachi model: HTS543225A7A384 size: 232.89 GiB
block-size: physical: 512 B logical: 512 B rotation: 5400 rpm serial: <filter> rev: ESBO
scheme: MBR
Partition: ID-1: / raw-size: 116.4 GiB size: 116.4 GiB (100.00%) used: 10.95 GiB (9.4%) fs: btrfs
dev: /dev/sda5 maj-min: 8:5
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 832 KiB (0.3%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 116.4 GiB size: 116.4 GiB (100.00%) used: 10.95 GiB (9.4%) fs: btrfs
dev: /dev/sda5 maj-min: 8:5
ID-4: /var/log raw-size: 116.4 GiB size: 116.4 GiB (100.00%) used: 10.95 GiB (9.4%) fs: btrfs
dev: /dev/sda5 maj-min: 8:5
ID-5: /var/tmp raw-size: 116.4 GiB size: 116.4 GiB (100.00%) used: 10.95 GiB (9.4%) fs: btrfs
dev: /dev/sda5 maj-min: 8:5
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: zram size: 1.45 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-2: swap-2 type: zram size: 1.45 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-3: swap-3 type: zram size: 1.45 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-4: swap-4 type: zram size: 1.45 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
ID-5: swap-5 type: zram size: 1.45 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4
ID-6: swap-6 type: zram size: 1.45 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5
ID-7: swap-7 type: zram size: 1.45 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6
ID-8: swap-8 type: zram size: 1.45 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C
Fan Speeds (RPM): N/A
Info:      Processes: 299 Uptime: 8h 30m wakeups: 33 Memory: 11.57 GiB used: 3.94 GiB (34.0%)
Init: systemd v: 248 tool: systemctl Compilers: gcc: 10.2.0 clang: 11.1.0 Packages:
pacman: 1272 lib: 310 flatpak: 0 Shell: fish v: 3.2.1 running-in: konsole inxi: 3.3.04

╭─bima@bima in ~ took 2s
╰─λ