Laptop Slow When Charging

Hello there!
Currently i have a weird and really annoying issue that i wasn’t able to solve.

Problem :

  • The second i plug my laptop into charge, the performance of the entire system drops drastically;
  • The second i unplug it, the system becomes lightning fast.

(the battery level has no impact on this phenomenon)

Weirder : Sometimes it happens that i plug my pc to charge, and it runs at its full potential. I can’t tell what’s going on.

Garuda-inxi :

  Kernel: 6.7.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=12228323-29ff-4f5f-86b3-55f915eadd01 rw rootflags=subvol=@
    quiet loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 wm: kwin_wayland vt: 1
    dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: SAMSUNG product: 750XED v: P13CFG
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: SAMSUNG model: NP750XED-KB7FR
    v: SAMSUNG_SW_REVISION_12345+10.0.22621 serial: <superuser required>
    UEFI: American Megatrends LLC. v: P13CFG.039.230726.HQ date: 07/26/2023
  ID-1: BAT1 charge: 37.9 Wh (68.3%) condition: 55.5/54.4 Wh (102.2%)
    volts: 15.8 min: 15.4 model: SAMSUNG Electronics SR Real Battery
    type: Li-ion serial: <filter> status: discharging cycles: 49
  Info: model: 12th Gen Intel Core i7-1255U bits: 64 type: MST AMCP
    arch: Alder Lake level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 4
    microcode: 0x430
  Topology: cpus: 1x cores: 10 mt: 2 tpc: 2 st: 8 threads: 12 smt: enabled
    cache: L1: 928 KiB desc: d-8x32 KiB, 2x48 KiB; i-2x32 KiB, 8x64 KiB
    L2: 6.5 MiB desc: 2x1.2 MiB, 2x2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 497 high: 927 min/max: 400/4700:3500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 600 2: 400 3: 927 4: 400
    5: 400 6: 400 7: 400 8: 532 9: 711 10: 400 11: 400 12: 400 bogomips: 62668
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel Alder Lake-UP3 GT2 [Iris Xe Graphics] vendor: Samsung Co
    driver: i915 v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+
    ports: active: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:46a8 class-ID: 0300
  Device-2: SunplusIT 720p HD Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-8:3 chip-ID: 5959:1502
    class-ID: 0e02 serial: <filter>
  Display: wayland server: v: with: Xwayland v: 23.2.4
    compositor: kwin_wayland driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: 0
  Monitor-1: eDP-1 res: 1920x1080 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast surfaceless: drv: iris wayland: drv: iris x11:
    drv: iris inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.3.5-arch1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (ADL GT2)
    device-ID: 8086:46a8 memory: 14.96 GiB unified: yes display-ID: :1.0
  API: Vulkan v: 1.3.276 layers: 4 device: 0 type: integrated-gpu name: Intel
    Graphics (ADL GT2) driver: mesa intel v: 23.3.5-arch1.1
    device-ID: 8086:46a8 surfaces: xcb,xlib,wayland device: 1 type: cpu
    name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
    v: 23.3.5-arch1.1 (LLVM 16.0.6) device-ID: 10005:0000
    surfaces: xcb,xlib,wayland
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Samsung Co
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51c8 class-ID: 0401
  API: ALSA v: k6.7.4-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:4 chip-ID: 8087:0026
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
    status: discoverable: no pairing: no
  Local Storage: total: 476.94 GiB used: 65.15 GiB (13.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLQ512HBLU-00B
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: FXM7AK1Q temp: 24.9 C
    scheme: GPT
  ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 65.15 GiB (13.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 65.15 GiB (13.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 65.15 GiB (13.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 65.15 GiB (13.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 15.32 GiB used: 46.5 MiB (0.3%)
    priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12
    dev: /dev/zram0
  System Temperatures: cpu: 35.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 313 Uptime: 5m wakeups: 1 Memory: total: 16 GiB
  available: 15.32 GiB used: 4 GiB (26.1%) Init: systemd v: 255
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: dpkg pkgs: 0 pm: pacman pkgs: 1520 libs: 428
  tools: octopi,pamac,paru,yay Shell: fish v: 3.7.0 running-in: konsole
  inxi: 3.3.31
Garuda (2.6.23-1):
  System install date:     2023-11-12
  Last full system update: 2024-02-08
  Is partially upgraded:   No
  Relevant software:       snapper tlp NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:            vmware.service 

What I tried :

  • Change the cpu frequency
    sudo cpupower frequency-set -g performance
  • Followed (most) tbg tutorial
    • Disable BTRFS quotas
    • Install various kernels (lts / mainline / linux)
    • BIOS is up to date
    • No overheat when runing sensors.
    • (and more, but don’t think it has any correlation with the current issue)
  • Look over google and chat-gpt to figure out other solutions, but seems like i am the only with this issue.

Thank you, and i appreciate any other help (other than garuda-update).

Have you tried it in x11 not wayland

1 Like

Wow, that’s crazy fast answer! No i didn’t, I’m new to Garuda, still learning. I’ll give it a try.

Just use performance mode.

1 Like

I did, changing the mode, does not change the lagginess when in charge :frowning:

New issue : After swapping from Wayland to X11, and trying to login, my screen becomes completely dark (had to force reboot, and go back to Wayland).

Check garuda-assistant / settings / Apply

1 Like

Alright, i did enable performance tweaks (had to remove tlp), and i did reboot :

Unfortunately it did not solve my issue.

It looks suspicious, maybe there is a problem with the hardware. I will investigate on that. If i find something that works for me, i will post the solution.

Thank you very much for your time, and help (If some other ideas comes in your mind later on, i will be glad to test them out).

What’s this about?

If you solve this failure, will Garuda load using x11?


Great point! Progress has been made. I was able to launch Garuda with X11 session
by simply running :

sudo vmware-modconfig --console --install-all
sudo systemctl restart vmware.service

Although another problem arose. It’s hard to explain what’s happening, when using the X11 protocol it seems there is a GPU drivers problem (which is strange, because I did update them) : Application icons on the desktop are shifted and not fully displayed. Application windows flicker and shake.

I tried to use OBS to record the problem, but the software does not capture the desktop or any window.

I don’t have this problem on the Wayland session. Any thoughts ?

I don’t know if this gives any clues, but running cat /var/log/Xorg.0.log | grep -i driver gives me :

[  2399.483] 	X.Org Video Driver: 25.2
[  2399.483] 	X.Org XInput driver : 24.4
[  2399.497] (==) Matched intel as autoconfigured driver 0
[  2399.497] (==) Matched modesetting as autoconfigured driver 1
[  2399.497] (==) Matched fbdev as autoconfigured driver 2
[  2399.497] (==) Matched vesa as autoconfigured driver 3
[  2399.497] (==) Assigned the driver to the xf86ConfigLayout
[  2399.497] (II) Loading /usr/lib/xorg/modules/drivers/
[  2399.497] 	Module class: X.Org Video Driver
[  2399.497] 	ABI class: X.Org Video Driver, version 25.2
[  2399.497] (II) Loading /usr/lib/xorg/modules/drivers/
[  2399.497] 	Module class: X.Org Video Driver
[  2399.497] 	ABI class: X.Org Video Driver, version 25.2
[  2399.498] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
[  2399.498] (II) intel: Driver for Intel(R) HD Graphics
[  2399.498] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[  2399.498] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[  2399.498] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[  2399.513] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20230929
[  2399.532] (II) intel(0): [DRI2]   DRI driver: i965
[  2399.532] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[  2399.534] (EE) AIGLX error: unable to load driver i965
[  2399.580] 	Module class: X.Org XInput Driver
[  2399.580] 	ABI class: X.Org XInput driver, version 24.4
[  2399.580] (II) Using input driver 'libinput' for 'Power Button'
[  2399.594] (II) Using input driver 'libinput' for 'Video Bus'
[  2399.605] (II) Using input driver 'libinput' for 'Power Button'
[  2399.606] (II) No input driver specified, ignoring this device.
[  2399.606] (II) Using input driver 'libinput' for 'ELAN0B00:00 04F3:3261 Mouse'
[  2399.622] (II) No input driver specified, ignoring this device.
[  2399.622] (II) Using input driver 'libinput' for 'ELAN0B00:00 04F3:3261 Touchpad'
[  2399.633] (II) Using input driver 'libinput' for 'ELAN0B00:00 04F3:3261 Touchpad'
[  2399.647] (II) No input driver specified, ignoring this device.
[  2399.647] (II) No input driver specified, ignoring this device.
[  2399.647] (II) No input driver specified, ignoring this device.
[  2399.647] (II) No input driver specified, ignoring this device.
[  2399.647] (II) No input driver specified, ignoring this device.
[  2399.647] (II) Using input driver 'libinput' for 'AT Translated Set 2 keyboard'

Have you tested plugging into the power supply with the battery removed from your laptop?


This driver is intended for Intel chipsets much older than yours (exc. special needs cases). Why is it installed?


What a challenge disassembling this laptop, I was skeptical about this solution, however your hypothesis was correct!

Indeed, plugging the power supply with the battery removed made the PC run smoothly. Better yet : after re-connecting the battery to the motherboard, the problem disappeared! I don’t know what caused such a change, it was originally well connected though.

However, as I mentioned at the very beginning, there were times when I didn’t have this kind of problem.

To be more precise, most days, when the battery is charging, system resources are reduced. However, it happens (less often) that the system works correctly, but the problem resurfaces the next day. Therefore it could well be that this phenomenon returns…

1 Like

I have installed my GPU drivers through pacman with the following command

sudo pacman -S mesa xf86-video-intel

Now I’m not entirely sure if it is the right one.

By the way, I want to thank you all for your help, you guys are legends! I can’t wait to learn more about Garuda, it’s a wonderful OS. I can’t imagine going back to Windows.

Thanks a lot <3


No! Do NOT install that–it my or will preclude modesetting which is what you do want. Leave the driver installs to Garuda.

Quit blindly installing stuff.

Wow that’s an interesting fix! I hope it sticks :slight_smile:

Could it be that your laptop’s power supply is faulty and is not delivering the correct wattage? A lot of laptop CPUs and other components will downclock if the power supply is not supplying enough power. If the laptop is still under warranty, it could be worth contacting Samsung support about the issue if it persists.

Then again, if removing the battery fixed it then maybe it’s not your PSU at fault… :person_shrugging:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.