Laptop microphone system is not recognized

I have serious problems with pipewire interference over-writing my audio driver by garuda which blocks the onboard mic capture device. (Millions of old sturdy Lenovo laptop users are out here)

When I checked with alsamixer, it shows the pipewire loaded instead of my onboard. But when I tried to deselect the pipewire from Garuda settings, it also did not work.

I will try next week with a plug and play mic-camera with on chip drivers, and see if that will bypass this.



(upload://81u4Eh8QOGYZwO9tPNo4taJtKMy.jpeg)

Here are the specs for the onboard devices garuda will not load. (generic pipewire will load the speakers but not the microphone "capture" device - neither on board nor headphones.

Please, do not post pictures from terminal output.


From the template that appears when you open a new topic. You could not see this because your post was posted in a wrong post.

Post your terminal/konsole in- and output as text (no pictures) from:

inxi -Faz

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.

1 Like

fixed!

(however i cannot save the alsamixer output as text. )

That is correct in so far, but why therefore post the complete screen?
But you have now neither the console images nor the output of inxi -Faz posted as text.

Based on your second image I would guess that you are using BSPWM, but who knows, maybe you just liked my wallpaper :slight_smile:

1 Like

Thanks for your interest, @SGS,

The alsamixer image was inteded to show that pipewire has colonized/occupied my audio system. I admit i am too lazy to crop the image before posting. I did shrink the size for your convenience.

Nevertheless, in garuda settings, I have de-selected pipewire, yet it still runs by default, i.e.,

Audio: Device-1: Intel Broadwell-U Audio vendor: Lenovo driver: snd_hda_intel v: kernel
bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0 class-ID: 0403
Sound Server-1: ALSA v: k5.10.75-1-lts running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: JACK v: 1.9.19 running: no
Sound Server-4: PulseAudio v: 15.0 running: no
Sound Server-5: PipeWire v: 0.3.39 running: yes

I am removing the pipewire as per cli advice to prior poster.

inxi -Faz

System:    Kernel: 5.10.75-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts root=UUID=26c06638-92a0-4b9a-9fec-2b081fcb54f6 rw
[email protected] quiet
cryptdevice=UUID=37290e15-ff21-495b-b74a-51e22765c218:luks-37290e15-ff21-495b-b74a-51e22765c218
root=/dev/mapper/luks-37290e15-ff21-495b-b74a-51e22765c218 splash rd.udev.log_priority=3
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:   Type: Laptop System: LENOVO product: 20CMS06V00 v: ThinkPad X250 serial: <filter> Chassis: type: 10
serial: <filter>
Mobo: LENOVO model: 20CMS06V00 v: SDK0E50510 WIN serial: <filter> UEFI-[Legacy]: LENOVO v: N10ET54W (1.33 )
date: 09/18/2018
Battery:   ID-1: BAT0 charge: 15.5 Wh (92.3%) condition: 16.8/23.2 Wh (72.5%) volts: 12.3 min: 11.1 model: SANYO 45N1773
type: Li-ion serial: <filter> status: Unknown
ID-2: BAT1 charge: 9.2 Wh (52.3%) condition: 17.6/23.2 Wh (75.6%) volts: 11.2 min: 11.1 model: SANYO 45N1775
type: Li-ion serial: <filter> status: Discharging
CPU:       Info: Dual Core model: Intel Core i5-5300U bits: 64 type: MT MCP arch: Broadwell family: 6 model-id: 3D (61)
stepping: 4 microcode: 2F cache: L2: 3 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 18357
Speed: 798 MHz min/max: 500/2200 MHz Core speeds (MHz): 1: 798 2: 798 3: 798 4: 798
Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable
Graphics:  Device-1: Intel HD Graphics 5500 vendor: Lenovo driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:1616
class-ID: 0300
Device-2: Acer Integrated Camera type: USB driver: uvcvideo bus-ID: 2-8:5 chip-ID: 5986:0366 class-ID: 0e02
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel unloaded: modesetting
alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3")
Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 124 size: 280x160mm (11.0x6.3") diag: 322mm (12.7")
OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 21.2.4 direct render: Yes
Audio:     Device-1: Intel Broadwell-U Audio vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:03.0
chip-ID: 8086:160c class-ID: 0403
Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Lenovo driver: snd_hda_intel v: kernel
bus-ID: 00:1b.0 chip-ID: 8086:9ca0 class-ID: 0403
Sound Server-1: ALSA v: k5.10.75-1-lts running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: JACK v: 1.9.19 running: no
Sound Server-4: PulseAudio v: 15.0 running: no
Sound Server-5: PipeWire v: 0.3.39 running: yes
Network:   Device-1: Intel Ethernet I218-LM vendor: Lenovo driver: e1000e v: kernel port: 3080 bus-ID: 00:19.0
chip-ID: 8086:15a2 class-ID: 0200
IF: enp0s25 state: down mac: <filter>
Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel bus-ID: 03:00.0 chip-ID: 8086:095b class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
IF-ID-1: wwp0s20u4 state: down mac: <filter>
Drives:    Local Storage: total: 476.94 GiB used: 93.03 GiB (19.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Apacer model: AS350 512GB size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 3PE0 scheme: MBR
Partition: ID-1: / raw-size: 476.93 GiB size: 476.93 GiB (100.00%) used: 93.03 GiB (19.5%) fs: btrfs dev: /dev/dm-0
maj-min: 254:0 mapped: luks-37290e15-ff21-495b-b74a-51e22765c218
ID-2: /home raw-size: 476.93 GiB size: 476.93 GiB (100.00%) used: 93.03 GiB (19.5%) fs: btrfs dev: /dev/dm-0
maj-min: 254:0 mapped: luks-37290e15-ff21-495b-b74a-51e22765c218
ID-3: /var/log raw-size: 476.93 GiB size: 476.93 GiB (100.00%) used: 93.03 GiB (19.5%) fs: btrfs dev: /dev/dm-0
maj-min: 254:0 mapped: luks-37290e15-ff21-495b-b74a-51e22765c218
ID-4: /var/tmp raw-size: 476.93 GiB size: 476.93 GiB (100.00%) used: 93.03 GiB (19.5%) fs: btrfs dev: /dev/dm-0
maj-min: 254:0 mapped: luks-37290e15-ff21-495b-b74a-51e22765c218
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.47 GiB used: 864 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 53.0 C mobo: 0.0 C
Fan Speeds (RPM): cpu: 4149
Info:      Processes: 234 Uptime: 5h 52m wakeups: 5 Memory: 7.48 GiB used: 3.19 GiB (42.7%) Init: systemd v: 249
tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1588 lib: 366 Shell: fish v: 3.3.1
running-in: kate inxi: 3.3.08

What exactly is the issue? Is the microphone displayed in audio settings? Does the microphone work? How do you know?

1 Like

No, microphone was not displaying in settings. Pretty sure it was working before in earlier garuda versions installed on this same machine. Only garuda is installed on the computer - no dual boot OS or such.

Looks like i have to go fishing for Realtek ALC3232 driver to load to over write the pipewire.

The wierd thing is that pipewire still runs even though it is deselected in garuda settings.

Found this https://bugzilla.kernel.org/show_bug.cgi?id=198611

and this linux/patch_realtek.c at master · torvalds/linux · GitHub

https://wiki.archlinux.org/title/Advanced_Linux_Sound_Architecture#Set_the_default_sound_card

will sludge through them

1 Like

I solved this problem by installing the pulse audio packages.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.