Wireplumber and pipewire-media-session are in conflict

My system information-

Operating System: Garuda Linux
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2
Kernel Version: 5.14.11-zen1-1-zen (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i3-8145U CPU @ 2.10GHz
Memory: 7.5 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620

When I tried to update the system (Pacman -Syu) , it happened

sudo pacman -Syu
:: Synchronizing package databases...
testing is up to date
core is up to date
extra is up to date
community-testing is up to date
community is up to date
multilib-testing is up to date
multilib is up to date
chaotic-aur is up to date
blackarch is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: wireplumber and pipewire-media-session are in conflict. Remove pipewire-media-session? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'pipewire-media-session' required by kwin

and putting n , it shows -


sudo pacman -Syu
:: Synchronizing package databases...
testing is up to date
core is up to date
extra is up to date
community-testing is up to date
community is up to date
multilib-testing is up to date
multilib is up to date
chaotic-aur is up to date
blackarch is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: wireplumber and pipewire-media-session are in conflict. Remove pipewire-media-session? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: wireplumber and pipewire-media-session are in conflict

I tried to upgrade it defferently but the conflict continues

sudo pacman -S wireplumber
resolving dependencies...
looking for conflicting packages...
:: wireplumber and pipewire-media-session are in conflict. Remove pipewire-media-session? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pipewire-media-session breaks dependency 'pipewire-media-session' required by gst-plugin-pipewire
:: removing pipewire-media-session breaks dependency 'pipewire-media-session' required by kwin
:: removing pipewire-media-session breaks dependency 'pipewire-media-session' required by pipewire-alsa
:: removing pipewire-media-session breaks dependency 'pipewire-media-session' required by pipewire-jack
:: removing pipewire-media-session breaks dependency 'pipewire-media-session' required by pipewire-pulse

and i tried to remove one of them differently but the conflict continues


sudo pacman -R pipewire-media-session
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pipewire-media-session breaks dependency 'pipewire-media-session' required by gst-plugin-pipewire
:: removing pipewire-media-session breaks dependency 'pipewire-media-session' required by kwin
:: removing pipewire-media-session breaks dependency 'pipewire-media-session' required by pipewire-alsa
:: removing pipewire-media-session breaks dependency 'pipewire-media-session' required by pipewire-jack
:: removing pipewire-media-session breaks dependency 'pipewire-media-session' required by pipewire-pulse


sudo pacman -R wireplumber
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing wireplumber breaks dependency 'wireplumber' required by pipewire-support

at last i tried to disable(systemctl) one of them but, it didn't solve my problem.
Now I can't update my system. I tried to use the gui for system update but the result is same.

2 Likes

I think it's fixed in testing, so will be available soon....
https://bugs.archlinux.org/task/72283
In the meanwhile maybe you could restore a snapshot if you are stuck.

2 Likes

he is using testing repo
either kwin needs to change its depends
or we dont depend on wireplumber

4 Likes

Next time just post output from

inxi -Faz

as text :slight_smile:

And welcome to the forum :slight_smile:

3 Likes

So, what do I do now wait for new update ? Or anything else ?

To confirm,

If you are using the testing repo then you should know what you're doing and what it involves: https://wiki.archlinux.org/title/Official_repositories#Testing_repositories

Garuda doesn't come with the testing repo enabled, so if you enable it you are basically on your own.

Yes.

4 Likes

If there was no specific reason to use the testing repos, wouldn't it be better to disable them? Or it would be too risky?
https://wiki.archlinux.org/title/Official_repositories#Disabling_testing_repositories

1 Like

2 posts were split to a new topic: Laptop microphone system is not recognized

I have the same error. I am not using any testing repositories.

looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: wireplumber and pipewire-media-session are in conflict
inxi -Faz
System:    Kernel: 5.14.11-1-cacule x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-cacule
root=UUID=00b33177-335b-466d-8a5b-e5bad5669f19 rw [email protected] quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_wayland vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: Micro-Star product: GL65 9SE v: REV:1.0 serial: <filter> Chassis: type: 10
serial: <filter>
Mobo: Micro-Star model: MS-16U5 v: REV:1.0 serial: <filter> UEFI: American Megatrends
v: E16U5IMS.101 date: 07/02/2019
Battery:   ID-1: BAT1 charge: 21.9 Wh (51.7%) condition: 42.4/51.6 Wh (82.2%) volts: 11.0 min: 10.9
model: MSI BIF0_9 type: Li-ion serial: N/A status: Unknown
CPU:       Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake note: check
family: 6 model-id: 9E (158) stepping: A (10) microcode: EA cache: L2: 12 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62469
Speed: 2514 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 2514 2: 2368 3: 2600 4: 2600
5: 2551 6: 2557 7: 2525 8: 2117 9: 2600 10: 2601 11: 2601 12: 1957
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Micro-Star MSI driver: i915
v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Micro-Star MSI driver: nvidia
v: 470.74 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f11 class-ID: 0300
Device-3: Chicony HD Webcam type: USB driver: uvcvideo bus-ID: 1-13:5 chip-ID: 04f2:b695
class-ID: 0e02
Display: wayland server: X.Org 1.21.1.2 compositor: kwin_wayland driver: loaded: intel,nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa display-ID: :1 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: XWAYLAND0 res: 1920x1080 hz: 120 dpi: 143 size: 340x190mm (13.4x7.5")
diag: 389mm (15.3")
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.2.4 direct render: Yes
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
Sound Server-1: ALSA v: k5.14.11-1-cacule running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3
chip-ID: 8086:a370 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI
driver: r8169 v: kernel port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb v: 0.8
bus-ID: 1-14:6 chip-ID: 8087:0aaa class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 1.38 TiB used: 440.37 GiB (31.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN520 SDAPNUW-512G-1032
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD
serial: <filter> rev: 20140000 temp: 33.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10JPVX-60JC3T0 size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400
serial: <filter> rev: 1A01 scheme: GPT
Partition: ID-1: / raw-size: 73.24 GiB size: 73.24 GiB (100.00%) used: 61.68 GiB (84.2%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 256 MiB size: 252 MiB (98.46%) used: 546 KiB (0.2%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 73.24 GiB size: 73.24 GiB (100.00%) used: 61.68 GiB (84.2%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 73.24 GiB size: 73.24 GiB (100.00%) used: 61.68 GiB (84.2%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 73.24 GiB size: 73.24 GiB (100.00%) used: 61.68 GiB (84.2%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.47 GiB used: 167.3 MiB (1.1%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 45.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 390 Uptime: 4d 4h 26m wakeups: 1 Memory: 15.47 GiB used: 4.2 GiB (27.1%)
Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages:
pacman: 1758 lib: 534 Shell: fish v: 3.3.1 running-in: konsole inxi: 3.3.07
3 Likes

same here, using lxqt garuda.

System:    Kernel: 5.14.14-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
           root=UUID=8bb3194a-ff21-44b4-9623-ef62427c0fba rw [email protected] quiet splash
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
           loglevel=3
           Desktop: LXQt 0.17.1 tk: Qt 5.15.2 info: cairo-dock, lxqt-panel wm: kwin_x11 vt: 1
           dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop System: ASUSTeK product: K30AD_M31AD_M51AD v: N/A serial: <filter>
           Mobo: ASUSTeK model: K30AD_M31AD_M51AD_M32AD v: Rev X.0x serial: <filter>
           BIOS: American Megatrends v: 0507 date: 04/02/2014
CPU:       Info: Quad Core model: Intel Core i7-4790S bits: 64 type: MT MCP arch: Haswell
           family: 6 model-id: 3C (60) stepping: 3 microcode: 28 cache: L2: 8 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 51080
           Speed: 3642 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 3642 2: 3978 3: 3635
           4: 3700 5: 3856 6: 3708 7: 3775 8: 3817
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass
           mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP:
           conditional, RSB filling
           Type: srbds mitigation: Microcode
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA GM107 [GeForce GTX 750] vendor: ASUSTeK driver: nvidia v: 470.74
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1381 class-ID: 0300
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: nvidia
           unloaded: modesetting alternate: fbdev,nouveau,nv,vesa display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 69 s-size: 707x392mm (27.8x15.4")
           s-diag: 808mm (31.8")
           Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 70 size: 698x393mm (27.5x15.5")
           diag: 801mm (31.5")
           OpenGL: renderer: NVIDIA GeForce GTX 750/PCIe/SSE2 v: 4.6.0 NVIDIA 470.74
           direct render: Yes
Audio:     Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: ASUSTeK
           driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20 class-ID: 0403
           Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX] vendor: ASUSTeK
           driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0fbc class-ID: 0403
           Sound Server-1: ALSA v: k5.14.14-zen1-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: no
           Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Intel Ethernet I217-V vendor: ASUSTeK driver: e1000e v: kernel port: f040
           bus-ID: 00:19.0 chip-ID: 8086:153b class-ID: 0200
           IF: eno1 state: down mac: <filter>
           Device-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter vendor: AzureWave
           driver: rtl8821ae v: kernel port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8821
           class-ID: 0280
           IF: wlp3s0 state: up mac: <filter>
Bluetooth: Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 3-10:5
           chip-ID: 13d3:3414 class-ID: e001 serial: <filter>
           Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
           rfk-block: hardware: no software: no address: <filter>
Drives:    Local Storage: total: 931.51 GiB used: 12.3 GiB (1.3%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WDBNCE0010PNC
           size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
           serial: <filter> rev: 20RL scheme: MBR
Partition: ID-1: / raw-size: 931.51 GiB size: 931.51 GiB (100.00%) used: 12.3 GiB (1.3%) fs: btrfs
           dev: /dev/sda1 maj-min: 8:1
           ID-2: /home raw-size: 931.51 GiB size: 931.51 GiB (100.00%) used: 12.3 GiB (1.3%)
           fs: btrfs dev: /dev/sda1 maj-min: 8:1
           ID-3: /var/log raw-size: 931.51 GiB size: 931.51 GiB (100.00%) used: 12.3 GiB (1.3%)
           fs: btrfs dev: /dev/sda1 maj-min: 8:1
           ID-4: /var/tmp raw-size: 931.51 GiB size: 931.51 GiB (100.00%) used: 12.3 GiB (1.3%)
           fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 11.63 GiB used: 2.2 MiB (0.0%) priority: 100
           dev: /dev/zram0
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 36 C
           Fan Speeds (RPM): N/A gpu: nvidia fan: 27%
Info:      Processes: 283 Uptime: 1h 13m wakeups: 0 Memory: 11.63 GiB used: 2.89 GiB (24.8%)
           Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1186
           lib: 290 Client: Unknown Client: garuda-assistant inxi: 3.3.07

Hmm, guess I'm late to the party! Same issue here...

core                            138.8 KiB   168 KiB/s 00:01 [-----] 100%
extra                       1572.4 KiB  1298 KiB/s 00:01 [-----] 100%
community                  5.8 MiB  4.12 MiB/s 00:01 [-----] 100%
multilib                      150.9 KiB   175 KiB/s 00:01 [-----] 100%
chaotic-aur            1565.6 KiB  2.33 MiB/s 00:01 [-----] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: wireplumber and pipewire-media-session are in conflict
System:    Kernel: 5.14.14-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=00a6de4b-23be-482b-8163-cb26f523cbd8 rw
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:   Type: Desktop Mobo: Micro-Star model: Z490-A PRO (MS-7C75) v: 1.0 serial: <filter> UEFI: American Megatrends
v: 2.80 date: 01/30/2021
CPU:       Info: 10-Core model: Intel Core i9-10850K bits: 64 type: MT MCP arch: Comet Lake family: 6 model-id: A5 (165)
stepping: 5 microcode: EC cache: L2: 20 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 144000
Speed: 5102 MHz min/max: 800/5200 MHz Core speeds (MHz): 1: 5102 2: 5104 3: 5107 4: 5090 5: 5078 6: 5092 7: 5047
8: 5087 9: 5098 10: 5091 11: 5102 12: 5100 13: 5098 14: 5119 15: 4955 16: 5084 17: 5109 18: 5108 19: 5011 20: 5073
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel CometLake-S GT2 [UHD Graphics 630] vendor: Micro-Star MSI driver: i915 v: kernel bus-ID: 00:02.0
chip-ID: 8086:9bc5 class-ID: 0300
Device-2: Logitech HD Pro Webcam C920 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 1-10:5 chip-ID: 046d:082d
class-ID: 0102 serial: <filter>
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel unloaded: modesetting
alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 4096x2160 s-dpi: 96 s-size: 1082x571mm (42.6x22.5") s-diag: 1223mm (48.2")
Monitor-1: HDMI1 res: 4096x2160 hz: 24 dpi: 111 size: 940x530mm (37.0x20.9") diag: 1079mm (42.5")
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CML GT2) v: 4.6 Mesa 21.2.4 direct render: Yes
Audio:     Device-1: Intel Comet Lake PCH cAVS vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
Device-2: Logitech HD Pro Webcam C920 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 1-10:5 chip-ID: 046d:082d
class-ID: 0102 serial: <filter>
Device-3: Corsair VOID PRO Wireless Gaming Headset type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-3:4
chip-ID: 1b1c:0a14 class-ID: 0300
Sound Server-1: ALSA v: k5.14.14-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169 v: kernel port: 3000 bus-ID: 02:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 3.86 TiB used: 1.1 TiB (28.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM008-2FR102 size: 1.82 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: 0001 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SA400M8240G size: 223.57 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 62B3 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST2000DM001-1ER164 size: 1.82 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: CC26
Partition: ID-1: / raw-size: 223.31 GiB size: 223.31 GiB (100.00%) used: 66.74 GiB (29.9%) fs: btrfs dev: /dev/sdb2
maj-min: 8:18
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 562 KiB (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 223.31 GiB size: 223.31 GiB (100.00%) used: 66.74 GiB (29.9%) fs: btrfs dev: /dev/sdb2
maj-min: 8:18
ID-4: /var/log raw-size: 223.31 GiB size: 223.31 GiB (100.00%) used: 66.74 GiB (29.9%) fs: btrfs dev: /dev/sdb2
maj-min: 8:18
ID-5: /var/tmp raw-size: 223.31 GiB size: 223.31 GiB (100.00%) used: 66.74 GiB (29.9%) fs: btrfs dev: /dev/sdb2
maj-min: 8:18
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.2 GiB used: 2.2 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 36.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 390 Uptime: 2d 7h 26m wakeups: 12 Memory: 31.2 GiB used: 6.27 GiB (20.1%) Init: systemd v: 249
tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1462 lib: 442 Shell: fish v: 3.3.1
default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.07

Try this:

sudo pacman -S pipewire-media-session

Then:

sudo pacman -Syu

This worked for me

12 Likes

That worked, thank you!

thanks thats solved for me

It works, it install pipeware-media-session to just after (when Syncing) removing it.

For what it's worth I don't have any testing repositories enabled in /etc/pacman.conf and still had the conflict pop up today. I'm not sure if it was related but Friday everything was working fine and today I couldn't go past the splash screen until I fully updated the system.

sudo pacman -Rdd pipewire-media-session && update
2 Likes

:+1: Thanks.

Thank you very much for the command line. This worked. Fixed the issue and then updated all my stuff!