"Kwin_wayland" extremely high cpu usage

Hello Garuda users!
I recently switched to linux so im quite new to this. kwin_wayland appears to be consistently using 70 - 90% of my cpu and what other forms says do not seem to work. other forum posts say to install NVIDIA drivers to stop the such high usage but this seems to not have worked for me (i tried both open source and propriety) even after restarts and system updates nothing has changed still high cpu usage and frame drops/stutters (i think this is related to drivers and not wayland)

any help is much appreciated to help me continue my switch to linux :slight_smile:

CPU: AMD Ryzen 7 3700X (16) @ 3.600GHz
GPU: NVIDIA GeForce RTX 2060


Kernel: 6.6.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=6205bd81-9fc4-4afa-b9ea-00a9525432b6 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_wayland dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Desktop System: Gigabyte product: B450M DS3H WIFI v: N/A serial: N/A
Mobo: Gigabyte model: B450M DS3H WIFI-CF v: x.x serial: N/A
UEFI-[Legacy]: American Megatrends v: F50 Y1 date: 12/17/2019
Info: model: AMD Ryzen 7 3700X socket: AM4 bits: 64 type: MT MCP arch: Zen 2
gen: 3 level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 3600 min/max: 2200/4426 boost: enabled
base/boost: 3600/4400 scaling: driver: acpi-cpufreq governor: performance
volts: 1.1 V ext-clock: 100 MHz cores: 1: 3600 2: 3600 3: 3600 4: 3600
5: 3600 6: 3600 7: 3600 8: 3600 9: 3600 10: 3600 11: 3600 12: 3600
13: 3600 14: 3600 15: 3600 16: 3600 bogomips: 114983
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: NVIDIA TU104 [GeForce RTX 2060] vendor: Micro-Star MSI
driver: nvidia v: 545.29.02 alternate: nouveau,nvidia_drm non-free: 545.xx+
status: current (as of 2023-10; EOL~2026-12-xx) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-2022 pcie: gen: 1 speed: 2.5 GT/s
lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 0a:00.0
chip-ID: 10de:1e89 class-ID: 0300
Device-2: Logitech BRIO Ultra HD Webcam
driver: hid-generic,snd-usb-audio,usbhid,uvcvideo type: USB rev: 3.1
speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 6-4:2 chip-ID: 046d:085e
class-ID: 0300 serial: <filter>
Display: server: X.Org v: 23.2.2 with: Xwayland v: 23.2.2
compositor: kwin_wayland driver: X: loaded: modesetting,nouveau,nvidia
alternate: fbdev,nv,vesa gpu: nvidia display-ID: :1 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: Unknown-1 res: 1920x1080 hz: 60 dpi: 96
size: 508x285mm (20x11.22") modes: 1920x1080
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
drv: swrast gbm: drv: kms_swrast surfaceless: drv: nvidia x11: drv: swrast
inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: llvmpipe (LLVM 16.0.6 256 bits)
device-ID: ffffffff:ffffffff memory: 15.2 GiB unified: yes
API: Vulkan v: 1.3.269 layers: 4 device: 0 type: discrete-gpu
name: NVIDIA GeForce RTX 2060 driver: nvidia v: 545.29.02
device-ID: 10de:1e89 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: NVIDIA TU104 HD Audio vendor: Micro-Star MSI driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0a:00.1
chip-ID: 10de:10f8 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: JMTek LLC. USB PnP Audio Device
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 1-2.4.1:6 chip-ID: 0c76:161e class-ID: 0300
Device-4: Logitech BRIO Ultra HD Webcam
driver: hid-generic,snd-usb-audio,usbhid,uvcvideo type: USB rev: 3.1
speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 6-4:2 chip-ID: 046d:085e
class-ID: 0300 serial: <filter>
API: ALSA v: k6.6.1-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.85 status: n/a (root, process) with:
1: pipewire-pulse status: active 2: wireplumber status: active
3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 07:00.0
chip-ID: 8086:24fb class-ID: 0280
IF: wlp7s0 state: down mac: <filter>
Device-1: Intel Wireless-AC 3168 Bluetooth driver: btusb v: 0.8 type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-7:3 chip-ID: 8087:0aa7
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.2
lmp-v: 8 status: discoverable: no pairing: no class-ID: 7c0104
Local Storage: total: 2.75 TiB used: 13.21 GiB (0.5%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Lexar model: 1TB SSD
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: S0614B0 temp: 40.9 C
scheme: GPT
SMART: yes health: PASSED on: 1y 308d 3h cycles: 1,517
read-units: 93,509,039 [47.8 TB] written-units: 96,870,099 [49.5 TB]
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM001-1ER164
family: Barracuda 7200.14 (AF) size: 1.82 TiB block-size: physical: 4096 B
logical: 512 B sata: 3.1 speed: 6.0 Gb/s tech: HDD rpm: 7200
serial: <filter> fw-rev: CC25 temp: 36 C scheme: MBR
SMART: yes state: enabled health: PASSED on: 4y 239d 11h cycles: 1600
read: 845.69 TiB written: 88.9 TiB Pre-Fail: attribute: Spin_Retry_Count
value: 100 worst: 100 threshold: 97
ID-1: / raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 13.21 GiB (0.7%)
fs: btrfs block-size: 4096 B dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 13.21 GiB (0.7%) fs: btrfs block-size: 4096 B dev: /dev/sda1
maj-min: 8:1
ID-3: /var/log raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 13.21 GiB (0.7%) fs: btrfs block-size: 4096 B dev: /dev/sda1
maj-min: 8:1
ID-4: /var/tmp raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 13.21 GiB (0.7%) fs: btrfs block-size: 4096 B dev: /dev/sda1
maj-min: 8:1
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.56 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
System Temperatures: cpu: 67.4 C mobo: 34.0 C
Fan Speeds (rpm): N/A
Processes: 371 Uptime: 28m wakeups: 0 Memory: total: 16 GiB
available: 15.56 GiB used: 4.22 GiB (27.1%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1333 libs: 379 tools: octopi,paru Shell: garuda-inxi (sudo)
default: Bash v: 5.2.15 running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
System install date:     2023-11-16
Last full system update: 2023-11-20
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

(edit : ran garuda-inxi as super user)

Either set your session to X11 (can select session type on the login screen) or set kernel parameters for Nvidia Direct Rendering Manager


sorry for the late response went out for pizza.
IT WORKED! thank you so much so simple and it fixed all the graphical and CPU issues i was having.
thank you so much <3

1 Like

Sounds like you owe @Kayo the leftover pizza. :wink:


Naw, I’m good. I went to Pizza Hut earlier today :rofl:

1 Like

And the Oxymoron Award o’ the Day goes to…


Its one of the last Pizza Huts left in my state, so it better be good :rofl:
But in all seriousness, I just hope the new local pizza place that is opening in my area soon is good :grinning:

1 Like

Nah man pizza hut is just needlessly expensive. I mean pizza in general is more expensive than normal food around here but pizza hut has to take the award for the most expensive one.

1 Like

I wish the last Pizza Hut would leave my state. LOL!

I ate at the Pizza Hut #2 as a young kid, located in Dodge City, Kansas, my home town. Pizza Hut was founded in Wichita, KS.

Red/white checked oil-cloth table covers, Pepperoni, Sausage, or a combination, that was it. But they all came with Anchovies. American-kid tastebuds are not sophisticated enough to appreciate Anchovies. I picked mine off.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.