Konsole Toolbar

Hello all,

i just installed garuda last week and i really like the Konsole. But suddenly i have the toolbar in the top and i don't know how i can disable it now.

Appreciate your help :slight_smile:

1 Like

Welcome to the forum :smiley:

Please take the time to search the forum for your problem.
It has already been marked as solved. Thank you. :wink:

2 Likes

Already tried to change the options but it's sadly still there.

They did something crazy unintuitive. You have to right click on the menu bar, to hide that new bar. If you have the menu bar hidden, first unhide it.

6 Likes

sadly i tried some provided solutions but i guess without some screenshots i can't hide this toolbar again... Sorry.

2 Likes

i can't choose what i want to hide or unhide or something like that. it's weird.....

1 Like

Well then you broke it. :hugs:

3 Likes

I didn't done anything with the Konsole. so then Konsole is broken. it worked yesterday and i didn't touched any system settings.

I think the issue here is you have to right click on the menubar but since garuda is using global menus by default, there is no menubar.

@Mickhat , if you right click in the middle of the terminal window is there an option to show the menubar?

1 Like

No i don't see this option.

image

1 Like

You might be able to bring up Konsole's menubar with ctrl-shift-m. Then you can hide the buttonbars, and then re-hide the menu. I can't test since I don't have Latte-Dock installed.

4 Likes

A simple search engine search would have saved you and us a lot of time. Anyway, shortcut to show/hide menubar is
ctrl+shift+M

Also, refer to
https://docs.kde.org/stable5/en/konsole/konsole/commandreference.html

And welcome to forums btw.

3 Likes

That doesn't work for me in this case. The menubar isn't technically hidden, it is moved to the global menu.

As far as I can tell, the new implementation of how those toolbars is hidden isn't compatible with global menus.

Someone who uses global menus might want to open an upstream bug about that.

4 Likes

Nevermind then, apparently it's not helpful - @dalto and everyone else.

The menubar from step 1 isn't there when global menus are enabled as they are by default in Garuda.

Neither is the option in step 2.

All you have to do is right-click on the spot @dalto show you--almost--and a small window will pop out, and you can uncheck the menubar options you don't wan t to see.

But I believe you actually need to click on the menubar area, about half way in between the 'Help' and the Konsole window, just to the right of those whateverthehell they are II = symbols.

I can't prove it 'cause I'm not in Arch or Garuda and @dalto may be very right about not easily achievable in dr460nized, but damn, I've done it by rote so many times since KDE started that stupid thing, I'm not really sure.

Worth a try.

1 Like

I'm exactly having the same issue and none of the solutions mentioned above doesn't works for me too.

Also the Right click on menubar of konsole doesn't do much..

Please try to fix it, coz it's really irritating and distrubing to see a whole lot of useless toolbars when you are working on the terminal...

Settings-->Toolbars Shown ?
Sorry, I can't try it... Laptop-free vacations :wink:

2 Likes

https://forums.opensuse.org/showthread.php/557458-How-to-remove-KDE-konsole-toolbar

From inked page:

This issue is related to "Remember window size" option. If it is enabled the toolbar state is also remembered. If it is disabled the toolbars are always shown.

5 Likes