Konsole cursor glitch

I'm encountering a weird problem in Konsole. As I type a line, the cursor gets more and more misaligned with the text, and the entire line shifts with it. Here is a screenshot of the glitch:

As you can see, the cursor is misaligned with where it is in the text, and it creates a weird space thing that the text warps around as I move around. The alignment is worst near the end of the line, and it gets better and better as I move towards the beginning of the line, as shown below:

I am able to temporarily fix this by going into Settings > Edit Current Profile > Appearance > Cursor, and making a change to the settings and then immediately changing it back to the original. This refreshes the console and the alignment issue goes away. However, it comes back when I close the Konsole instance and open up another Konsole window, until I do the thing in Settings again.

Doing some research online, I found this was a common issue in Konsole and people said they fixed it by using a different font. However, no matter what font I tried the same issue persists until I change the option in Konsole settings like I mentioned before. Does anyone have a solution to this?

EDIT: I think it may have something to do with the fact that I have two monitors. When I open up Konsole on my secondary monitor, the size shows up as 132x32, and it does the weird glitch. When I move the window to my primary laptop monitor, it automatically resizes to 165x40, and the glitch disappears. However, if I do the "fix" I mentioned by going into settings, that fixes it for my secondary monitor, but when I move the window to my primary monitor, it once again resizes it and the text looks weird.

Is there anywhere I can modify the default window sizes for each monitor (like instead of 132x32 I can set a custom size that works for each monitor)?

In Profile settings (Konsole)

repair your console if needed

i have fish as main console there will save automatic position and size by default
if needed make an right klick on frame of console and there is a special config option
under other options there you can modify everthing you want

The problem is that even if I change the default window size in Profile settings, it still messes it up when I move it across a monitor. This means fixing it on one monitor messes it up on the other. Here is a video of what I am experiencing. Notice how the console is resizing itself automatically even without me doing anything other than dragging it across:

It seems a video driver configuration issue.
Of course, the easiest might be to set the same resolution to both monitors, if there is one that match both, but I understand you don't want that.

First try another Terminal Emulator application, to see if it happens as well. Alacrity, or even install xterm to test.

Then post your graphics info, maybe an idea comes up.

inxi -SGCMaxxxz
mhwd -li
1 Like

okay i don't even understand it anyway
is it because automatically the console is writing nonsens or the resize to your tv

the resize is eventually normal because there are different sizes for example you have a 15" laptop to a 55" tv there must a chance
it is confusing but it is the same size only on your tv

i have also different (looks like) sizes when change by the same resolution fullhd over hdmi

okay sorry i don't get right there is a different by me
you have a different size by both devices
i have prove it and by me both terminal are same size
SORRY
which distro you use and which graphics (modell driver etc)
did you use same resulution ?????

for alacritty it is possible to set it to every display single
but it is not easy to explain
pls rightclick on frame of alacritty go to weitere aktion - another action ----> special setting for this programm and choose there add PROPERTIES there you can choose virtual desktop and also manage position and size

sorry but it is only in germain and must translate it as good as possible
but my first post mentioned it

I've tried both Alacrity and Xterm. Both work fine. They do not resize the window when dragging across the monitor. This only happens in Konsole. My primary (laptop) monitor is at a 1920x1080 (16:9) resolution and my secondary (external larger) monitor is 3840x2160 (16:9) resolution

Here is the graphics info:

╰─λ inxi -SGCMaxxxz
System:    Kernel: 5.10.4-107-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq 
           root=UUID=0635122e-fad6-4a8c-a69e-bc195fe4aaa6 rw [email protected] quiet splash rd.udev.log_priority=3 
           vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Garuda Linux 
Machine:   Type: Laptop System: Dell product: G3 3779 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Dell model: 0JGKPC v: A00 serial: <filter> UEFI: Dell v: 1.11.0 date: 11/18/2019 
CPU:       Info: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake note: check family: 6 
           model-id: 9E (158) stepping: A (10) microcode: DE L2 cache: 9 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 52858 
           Speed: 3863 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 3863 2: 3906 3: 3830 4: 3633 5: 3975 6: 3841 
           7: 3540 8: 3923 9: 3931 10: 3954 11: 3917 12: 3702 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Dell driver: nvidia v: 460.27.04 
           alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1c8c 
           Device-3: Sunplus Innovation Integrated_Webcam_HD type: USB driver: uvcvideo bus ID: 1-5:2 
           chip ID: 1bcf:28c1 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: intel,nvidia 
           unloaded: modesetting,nouveau alternate: fbdev,nv,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 5760x2160 s-dpi: 96 s-size: 1520x570mm (59.8x22.4") s-diag: 1623mm (63.9") 
           Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 128 size: 380x210mm (15.0x8.3") diag: 434mm (17.1") 
           Monitor-2: HDMI-1-0 res: 3840x2160 hz: 30 dpi: 157 size: 621x341mm (24.4x13.4") diag: 708mm (27.9") 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.3.2 direct render: Yes 
╭─kishoreg at garuda in ⌁

Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-chaotic-nvidia-dkms-tkg-prime-render-offloading            2020.12.19               false            PCI
           video-linux            2020.12.03                true            PCI


Warning: No installed USB configs!

Alacrity is not the problem. The problem only happens on Konsole. The other terminal emulators and even Xterm work fine

i don't have the hardware but its a resolution problem itz normal when you change a pogram to an more resolute display that it is smaller
so i use only same resolution

you have two probs one is different resolution
it can be on windows like firefox the same

and you have 2 modis one is intel and one is nvidia
i read a bit of probs with it and am getting confused
don't know the name of the nivida handler maybe x.org don't know there you can change the power modis
and when to use the right graphics if it is only intel for normal use
no prob i use intel non hd version of 620

and it works fine without setting
but i have a look at if you use konsole ( fish) there is the same setting feature
as well
please check it if it works

I tried enabling virtual desktop and same thing is happening. However it is not happening on Alacrity or Xterm. Only Konsole. Its a minor annoyance, but I am able to "fix" it temporarily by going into Konsole settings and changing something and hitting "Apply". It doesn't even have to do with the cursor. I could literally just change anything under "Edit Current Profile" and hit "apply" and it automatically fixes the cursor problem. For example, I could just change the name of the profile from Garuda to "Garuda2" and hit apply and the Konsole automatically resizes itself and fixes the problem. This however goes away once I close the window.

So theoretically I can fix this by just going into settings and making some trivial change every time I move the Konsole window across a monitor, but I was wondering if there is a better way to do this permanently

Test how it goes if the external is set at 1920x1080.
It may need some digging in Konsole settings.

1 Like

Please edit your post.

If you include terminal outputs in your post please use the proper output format in your post. Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.

1 Like

Strange. Even setting both monitors to the same resolution doesn't fix the resize problem. It still resizes it even if the monitors have the same resolution. The only thing that temporarily fixes it as far as I can tell is by going into the Konsole settings and doing that "hack" I mentioned earlier. Though this fix only lasts temporarily while the window is open and I have to redo it everytime I open a new Konsole window.

did you choose program or window

Check if you already have a file

$HOME/.config/konsolerc

Please post here, so I can compare to mine.
It includes per Monitor settings. I don't know if there is something useful.

2 Likes

Here is my konsolerc file:

[Desktop Entry]
DefaultProfile=Garuda.profile

[MainWindow]
MenuBar=Disabled
ToolBarsMovable=Disabled
eDP1 HDMI-1-0 Height 1080=729
eDP1 HDMI-1-0 Height 1728=585
eDP1 HDMI-1-0 Height 864=583
eDP1 HDMI-1-0 Width 1536=1201
eDP1 HDMI-1-0 Width 1920=1501
eDP1 HDMI-1-0 Width 3072=1201
eDP1 HDMI-1-0 XPosition=1962
eDP1 HDMI-1-0 YPosition=208

okay set my resolution to 12xx mal 720p and it works but only for your konsole prob

it would be same as in first screen if you set it like this picture
first resolution you wish
then on all desktops
and the setting enabled initialized by start

sorry it is really hard to get it in english
but i have tried it worked on my 1080p lappi itz small on my changed hdmi setting on tv it fill the monitor

sorry maybe i don't get the real prob but on a bigger resolution there is the same letz say fullhd not a filled ultra hd display itz normal