Key shortcuts not working after Cinnamon update

Hello

after the latest Cinnamon bug was solved with latest update I could no longer use my key-shortcuts to probably send current app on another workspace. Checked it twice, but the keys are still defined ( for example [Super] + [ :arrow_right:] to send it on the next workspace ) and re-defining them doesn't solve the issue.

Wondering if anybody else got this issue or using keys for specific tasks on Cinnamon?

System:
  Kernel: 5.18.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=3acd578e-46d5-4b3e-b159-d07795e6e296 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3
  Desktop: Cinnamon v: 5.4.2 tk: GTK v: 3.24.34 info: plank wm: Mutter
    dm: LightDM v: 1.30.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: M5A99FX PRO R2.0 v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 2501
    date: 04/07/2014
CPU:
  Info: model: AMD FX-8350 bits: 64 type: MT MCP arch: Piledriver
    built: 2012-13 process: GF 32nm family: 0x15 (21) model-id: 2 stepping: 0
    microcode: 0x6000852
  Topology: cpus: 1x cores: 8 smt: enabled cache: L1: 384 KiB
    desc: d-8x16 KiB; i-4x64 KiB L2: 8 MiB desc: 4x2 MiB L3: 8 MiB
    desc: 1x8 MiB
  Speed (MHz): avg: 1803 high: 3539 min/max: 1400/4000 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1714 2: 3539
    3: 1405 4: 1404 5: 1404 6: 1403 7: 1649 8: 1913 bogomips: 64212
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN 4 process: GF 14nm
    built: 2016-20 pcie: gen: 2 speed: 5 GT/s lanes: 16 link-max: gen: 3
    speed: 8 GT/s ports: active: DP-1,DVI-D-1 empty: DP-2,HDMI-A-1,HDMI-A-2
    bus-ID: 01:00.0 chip-ID: 1002:67df class-ID: 0300
  Display: x11 server: X.Org v: 21.1.3 driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3286x1080 s-dpi: 96 s-size: 869x285mm (34.21x11.22")
    s-diag: 915mm (36.01")
  Monitor-1: DVI-D-1 mapped: DVI-D-0 pos: right model: BenQ G922HDL
    serial: <filter> built: 2009 res: 1366x768 hz: 60 dpi: 85 gamma: 1.2
    size: 410x230mm (16.14x9.06") diag: 470mm (18.5") ratio: 16:9 modes:
    max: 1366x768 min: 640x480
  Monitor-2: DP-1 mapped: DisplayPort-0 pos: primary,left
    model: AOC e2752Vq serial: <filter> built: 2013 res: 1920x1080 hz: 60
    dpi: 82 gamma: 1.2 size: 598x336mm (23.54x13.23") diag: 686mm (27")
    ratio: 16:9 modes: max: 1920x1080 min: 720x400
  OpenGL: renderer: AMD Radeon RX 480 Graphics (polaris10 LLVM 13.0.1 DRM
    3.46 5.18.6-zen1-1-zen)
    v: 4.6 Mesa 22.1.2 direct render: Yes
Audio:
  Device-1: AMD SBx00 Azalia vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 00:14.2 chip-ID: 1002:4383 class-ID: 0403
  Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s
    lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1
    chip-ID: 1002:aaf0 class-ID: 0403
  Sound Server-1: ALSA v: k5.18.6-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 16.1 running: no
  Sound Server-4: PipeWire v: 0.3.52 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK P8 series driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: c000 bus-ID: 09:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp9s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  
Partition:
  
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.53 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 3.73 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda2 maj-min: 8:2
Sensors:
  System Temperatures: cpu: 28.2 C mobo: N/A gpu: amdgpu temp: 61.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1211
Info:
  Processes: 368 Uptime: 5m wakeups: 0 Memory: 15.53 GiB
  used: 3.66 GiB (23.5%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 2066
  lib: 532 flatpak: 0 Shell: Zsh v: 5.9 running-in: tilix inxi: 3.3.19
Garuda (2.6.4-1):
  System install date:     2021-12-06
  Last full system update: 2022-06-24
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:    

Thanks.

I was looking at the changelog here, and saw this:

[ Michael Webster ]

  • popup menus: Add a new signal to be fired when a menu finishes animating closed.
  • tooltips: Round event mouse positions.
  • Fix recorder, minus the recording indicator for the moment.
  • Disable 'hover' effect for display module background.
  • Fix some keybindings. Snap is no more, display rotate and switch have moved to a different schema.
  • Rework xrandr applet to use muffin api.
  • Disable some media keys - they're handled internally by muffin now.

I'm not sure what "Snap is no more" means. It seems insane to get rid of such a fundamental feature. Maybe it needs to be handled by the window manager now?

Edit:

I see you were talking about sending windows to other workspaces, not snapping windows. I am still a little puzzled by the comments in the changelog. :thinking:

2 Likes

Yeah, thx for the link to the changelog.
I also found this

[ Michael Webster ]

  • keybindings: Warn, but don't forbid assigning normal keys for shortcuts.

Probably they organize keybindings some other way, while I have no clue why they should do that.

I just installed Cinnamon and brought it up to date (Cinnamon 5.4.2, Zen 5.18.6) and I can confirm these shortcuts are not working correctly--even with the stock configuration.

Out of the box, "Switch to left workspace" is set to Ctrl+Alt+Left, switch to right is Ctrl+Alt+Right but those shortcuts do not work.

I made a new shortcut binding for these using Shift+Ctrl+Alt+Super+Left and Shift+Ctrl+Alt+Super+Right (I figured there is no way this combination would be in use or otherwise conflicting with something else), but still this function does not do anything.

Similarly, the "Move window to left workspace" and "Move window to right workspace" are also not working (OOTB configuration is Shift+Ctrl+Alt+Left, and +Right, custom configs also don't work)

However, when I set up keybindings for "Switch to workspace 1", "Switch to workspace 2" and so on (under "Direct Navigation), those work fine. Also the direct navigation versions of "Move windows" work as well ("Move window to workspace 1" and so on).

So: when dealing with specifically numbered workspaces the shortcuts seem to work, but the commands where the workspace is relative ("to the left" or "to the right") are not working.

I tested a few other of the default shortcut bindings (not related to workspaces) and they seemed fine; I didn't discover anything else that seemed to be configured but not working.

I checked the workspace settings, and tried toggling this option for "Allow cycling through workspaces", but that didn't seem to make a difference. It's not clear to me what this option does.

I looked briefly through open issues on this page but I didn't see anything related to this issue.

I'm going to keep poking around a little, maybe try to figure out where these dotfiles live and take a look at those but at first glance this appears to be another bug.

Update:

I was reading through the .xsession-errors log in the home folder and noticed a few errors related to the two extensions that are installed by default, gTile and DesktopCube. I removed both extensions (System Settings->Extensions), logged out and back in and now the workspace shortcuts are all working fine. :man_shrugging:

I guess that is not a great solution if you are using those extensions, but it seems like maybe they are a little bit broken since the last update to Cinnamon.

5 Likes

@BluishHumility
Great job, that one helped. Marked it as solution! Great thanks!
BTW, deactivating the two mentioned extentions worked either.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.