Kernel problem in Manjaro Linux

hi tnx to you i got anbox working but the kernel moduel wont mount on boot can you help me with that tnx in advance:)

1 Like

:smiley:

Could you post your terminal output of this:
sudo ls -1 /dev/{ashmem,binderfs}

Which kernel are you using?

tnx for replying im using xanmod kernel and the output is
/dev/ashmem

/dev/binderfs:
binder
binder1
binder-control
features
hwbinder
vndbinder

when i boot it shows me this error message saying failed to mount biinderfs. but when i manually mount it it works.

1 Like

I hope you have entered everything correctly into fstab & /etc/tmpfiles.d/anbox.conf ?
Please recheck your steps.
Rest I don't see any problem causing it.

ok did i do something wrong in the fastab config here is what it looks like.

this is the fastab one

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=43edd5f2-593f-456b-90a1-1c6296c22c73 swap           swap    defaults,noati>
UUID=362C-479D                            /boot/efi      vfat    umask=0077 0 2
UUID=a9580fab-06f1-42bc-8c6e-8ed3c2caad41 /              ext4    defaults,noati>

/etc/fstab

none                         /dev/binderfs binder   nofail  0      0
/etc/tmpfiles.d/anbox.conf

d! /dev/binderfs 0755 root root

this is the /etc/tmpfiles.d/anbox.conf one did i do some thing wrong

1 Like

Yes, you post a picture from a text file.

4 Likes

fixed it XD i just it wouldnt let me select every thing interminal XD

Remove the #

it make text big

or just use the preformatted text with ~~~ in first and last line, terminal output between.

2 Likes

Would you mind formatting your reply correctly?

Format all terminal output as preformatted text (or select text and press ctrl + E ), as SGS has pointed out.

Rest, from what I can understand, things seem to be okay.

Edit: Also, would you post the output of sudo mount -a after a reboot without mounting binder.

It's getting late in India, I will be able to help tomorrow only now

ok tnx im new so i dont know this things

ow sry it was late where i live then so i didnt se this but canu still be able to help me here is the out put.mount:

mount: /etc/fstab: parse error at line 11 -- ignored
mount: /dev/binderfs: must be superuser to use mount.

Why do you use ext4?

Please post your inxi -Faz


Hello.

Post your terminal/konsole in- and output as text (no pictures) from:

inxi -Faz

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.

2 Likes

Wrong forum, I think :smiley:

1 Like

huh how am i so dumb pls forgive me

ok here is the out put of inxi -faz

System:
  Kernel: 5.15.6-xanmod2-2 x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-linux-xanmod-anbox
  root=UUID=a9580fab-06f1-42bc-8c6e-8ed3c2caad41 rw quiet
  resume=UUID=43edd5f2-593f-456b-90a1-1c6296c22c73 udev.log_priority=3
  zswap.enabled=1
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel, plank
  wm: xfwm 4.16.1 vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux
  base: Arch Linux
Machine:
  Type: Laptop System: Dell product: Inspiron 3185 v: 1.2.0
  serial: <superuser required> Chassis: type: 10 v: 1.2.0
  serial: <superuser required>
  Mobo: Dell model: 0T60DD v: A00 serial: <superuser required> UEFI: Dell
  v: 1.2.0 date: 02/09/2018
Battery:
  ID-1: BAT0 charge: 11.6 Wh (61.1%) condition: 19.0/32.0 Wh (59.3%)
  volts: 7.6 min: 7.6 model: Samsung SDI DELL PGYK582 type: Li-ion
  serial: <filter> status: Discharging
CPU:
  Info: Dual Core model: AMD A9-9420e RADEON R5 5 COMPUTE CORES 2C+3G
  bits: 64 type: MCP arch: Excavator family: 15 (21) model-id: 70 (112)
  stepping: 0 microcode: 6006704 cache: L1: 256 KiB L2: 2 MiB
  flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  bogomips: 7186
  Speed: 2605 MHz min/max: 1200/1800 MHz boost: enabled Core speeds (MHz):
  1: 2695 2: 2695
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
  mitigation: Full AMD retpoline, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics] vendor: Dell
  driver: amdgpu v: kernel bus-ID: 00:01.0 chip-ID: 1002:98e4 class-ID: 0300
  Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
  bus-ID: 1-1.1:3 chip-ID: 0c45:671f class-ID: 0e02
  Display: x11 server: X.Org 1.21.1.1 compositor: xfwm4 v: 4.16.1 driver:
  loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
  display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
  s-diag: 414mm (16.3")
  Monitor-1: eDP res: 1366x768 hz: 60 dpi: 136 size: 256x144mm (10.1x5.7")
  diag: 294mm (11.6")
  OpenGL: renderer: AMD STONEY (DRM 3.42.0 5.15.6-xanmod2-2 LLVM 13.0.0)
  v: 4.5 Mesa 21.2.5 direct render: Yes
Audio:
  Device-1: AMD vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:01.1
  chip-ID: 1002:15b3 class-ID: 0403
  Device-2: AMD Family 15h Audio vendor: Dell driver: snd_hda_intel
  v: kernel bus-ID: 00:09.2 chip-ID: 1022:157a class-ID: 0403
  Sound Server-1: ALSA v: k5.15.6-xanmod2-2 running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
  vendor: Dell Vostro 3470 driver: ath9k v: kernel bus-ID: 01:00.0
  chip-ID: 168c:0036 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  IF-ID-1: anbox0 state: down mac: <filter>
  IF-ID-2: docker0 state: down mac: <filter>
Bluetooth:
  Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 2-2:4
  chip-ID: 0cf3:e005 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Drives:
  Local Storage: total: 465.76 GiB used: 298.18 GiB (64.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
  model: WD5000LPCX-75VHAT1 size: 465.76 GiB block-size: physical: 4096 B
  logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
  rev: 1A05 scheme: GPT
Partition:
  ID-1: / raw-size: 420.21 GiB size: 412.54 GiB (98.18%)
  used: 298.18 GiB (72.3%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 515 MiB size: 514 MiB (99.80%)
  used: 304 KiB (0.1%) fs: vfat dev: /dev/sda4 maj-min: 8:4
Swap:
  Kernel: swappiness: 30 (default 60) cache-pressure: 50 (default 100)
  ID-1: swap-1 type: partition size: 4.98 GiB used: 1 MiB (0.0%)
  priority: -2 dev: /dev/sda1 maj-min: 8:1
Sensors:
  System Temperatures: cpu: 38.0 C mobo: 44.0 C sodimm: SODIMM C gpu: amdgpu
  temp: 38.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 216 Uptime: 38m wakeups: 1 Memory: 3.72 GiB
  used: 2.27 GiB (61.0%) Init: systemd v: 249 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: 1687 pacman: 1667 lib: 500 flatpak: 10 snap: 10
  Shell: fish v: 3.3.1 default: Bash v: 5.1.12 running-in: xfce4-terminal
  inxi: 3.3.09

and itried solving it by trying diffrent kernels with different versions i also tried to install anbox-modules-dkms but trying to install that it just gives me an eror it holds the anbox moduels binder and ashmem but it wont install so i refered to this article then after following each steps it worked for me but after a reboot it gives me an eror during the rebbot saying failed to mount binderfs then anbox stopped working after the reboot i also had problems with running and installing snap packages but reinstalling it it worked but it still gives out this eror when irun snap apps woth therminal.

2021/12/14 09:52:55.782572 system_key.go:129: cannot determine nfs usage in generateSystemKey: cannot parse /etc/fstab: expected between 3 and 6 fields, found 1

but the snap apps luanch properly work also when i run anbox system-info it shows that binder isnt present

version: local-84f0268
cpu:
  arch:  x86
  brand: AMD A9-9420e RADEON R5, 5 COMPUTE CORES 2C+3G  
  features: 
    - aes
    - sse4_1
    - sse4_2
    - avx
    - avx2
os:
  name: Manjaro Linux
  version: 
  snap-based: false
kernel:
  version: Linux version 5.15.6-xanmod2-2 ([email protected]) (gcc (GCC) 11.1.0, GNU ld (GNU Binutils) 2.36.1) #1 SMP Wed, 08 Dec 2021 19:46:46 +0000
  binder: false
  binderfs: true
  ashmem: true

hope i covered every thing im still very new to Linux so pls dont blame me if ido something stupid like posting pic XD tnx for your help <3.

No. :neutral_face: :neutral_face:

1 Like

yah just leave it at this point i will just accept anbox dosent work for me tnx for all you guys help and sry for your troubles.

Didn't you use sudo?

BTW you could install Garuda Linux and then try installing anbox?
I am not being persuasive. But I too switched to Garuda from Manjaro and I didn't regret it!

ya i know garuda is hands down one of the best distro i ever tried every thing is pre installed wine is pre configured its so beautiful also it has a great community . i was using the gaming edition one but my potato pc couldnt handle it things kept crashing b/c of ram shortage and youtube buffer was insanely high at boot it used up 2gb of ram and i dont have a good pc its preety low end 4gb ram coreI2 and 80mb of vram so i had to remove it i tied the lxqt one but it also used 1.6gb of ram on boot.but even in the gaming edition one games run very smoothly even with
high ram usage.
But i started using linux full time b/c of garuda linux i saw how beautiful it is and how well it run windows apps and games. but i had to go with a light weight distro like manjaro xfce.

2 Likes

Your topic is confusing. "Manjaro"?? This is the support forum for Garuda

2 Likes