Kernel Missing due to power fail can only boot using timeshift snapshots now

Hello, curious if anyone can give me some guidance on what to do next here. Installed updates and during kernel install my laptop plug got jiggled which sometimes shuts it down. I know thats an issue to solve, but another day...

Since this time i have to boot using a snapshot because the main boot menu item is broken. kernel file seems to be missing.

I have tried to install grub boot repair for garuda from pacman. didnt help.
I tried just updating within the snapshot...that didnt work.
I tried restoring to a few days old snapshot but that does not fix this issue either. it seems the boot parameters are outside the snapshot system.

What i would like to do is repair the default grub options so the original system will boot up without having to manually select a snapshot to boot from. Is it possible to do that? Thanks.

 ╰─λ inxi -Fxxxza
  Kernel: 5.11.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0
  parameters: BOOT_IMAGE=/timeshift-btrfs/snapshots/2021-03-22_12-18-13/@/boot/vmlinuz-linux-zen
  root=UUID=eb9481f5-69a8-41f6-b77e-1882b00a8fb7 pci=nocrs quiet splash
  rd.udev.log_priority=3 vt.global_cursor_default=0
  resume=UUID=920cfba5-ba13-4f96-b357-8534e49a7196 loglevel=3
  Desktop: KDE Plasma 5.21.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1
  dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 80FG v: Lenovo Z70-80 serial: <filter>
  Chassis: type: 10 v: Lenovo Z70-80 serial: <filter>
  Mobo: LENOVO model: Lenovo Z70-80 v: SDK0J40709 WIN serial: <filter> UEFI: LENOVO
  v: ABCN95WW date: 07/31/2015
  ID-1: BAT0 charge: 31.8 Wh (100.0%) condition: 31.8/37.6 Wh (84.5%) volts: 16.2
  min: 14.4 model: Lenovo IdeaPad type: Unknown serial: <filter> status: Full
  Info: Dual Core model: Intel Core i7-5500U bits: 64 type: MT MCP arch: Broadwell
  family: 6 model-id: 3D (61) stepping: 4 microcode: 2F cache: L2: 4 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 19155
  Speed: 2638 MHz min/max: 500/3000 MHz Core speeds (MHz): 1: 2638 2: 2756 3: 2470
  4: 2391
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW,
  STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 5500 vendor: Lenovo driver: i915 v: kernel
  bus-ID: 00:02.0 chip-ID: 8086:1616 class-ID: 0300
  Device-2: NVIDIA GM108M [GeForce 840M] vendor: Lenovo driver: nouveau v: kernel
  bus-ID: 04:00.0 chip-ID: 10de:1341 class-ID: 0302
  Device-3: Syntek Lenovo EasyCamera type: USB driver: uvcvideo bus-ID: 2-6:4
  chip-ID: 174f:14be class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver:
  loaded: intel,nouveau unloaded: modesetting alternate: fbdev,nv,vesa
  display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
  s-diag: 582mm (22.9")
  Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 128 size: 380x210mm (15.0x8.3")
  diag: 434mm (17.1")
  OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 20.3.4
  direct render: Yes
  Device-1: Intel Broadwell-U Audio vendor: Lenovo driver: snd_hda_intel v: kernel
  bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Lenovo
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0 class-ID: 0403
  Sound Server-1: ALSA v: k5.11.8-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 0.125.0 running: no
  Sound Server-4: PulseAudio v: 14.2 running: yes
  Sound Server-5: PipeWire v: 0.3.24 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo
  driver: r8169 v: kernel port: 4000 bus-ID: 02:00.0 chip-ID: 10ec:8168
  class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
  vendor: Lenovo driver: ath10k_pci v: kernel port: 4000 bus-ID: 03:00.0
  chip-ID: 168c:003e class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  Device-1: Qualcomm Atheros QCA61x4 Bluetooth 4.0 type: USB driver: btusb v: 0.8
  bus-ID: 2-7:5 chip-ID: 0cf3:e300 class-ID: e001
  Report: ID: hci0 state: down bt-service: enabled, running address: <filter>
  Local Storage: total: 894.25 GiB used: 21.83 GiB (2.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Micron model: 5100 MTFDDAK960TCB
  size: 894.25 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
  rotation: SSD serial: <filter> rev: U051 scheme: GPT
  ID-1: / raw-size: 885.19 GiB size: 885.19 GiB (100.00%) used: 21.83 GiB (2.5%)
  fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 546 KiB (0.2%)
  fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 885.19 GiB size: 885.19 GiB (100.00%) used: 21.83 GiB (2.5%)
  fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 885.19 GiB size: 885.19 GiB (100.00%)
  used: 21.83 GiB (2.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 885.19 GiB size: 885.19 GiB (100.00%)
  used: 21.83 GiB (2.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/sda3 maj-min: 8:3
  ID-2: swap-2 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram0
  ID-3: swap-3 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram1
  ID-4: swap-4 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram2
  ID-5: swap-5 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram3
  System Temperatures: cpu: 70.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 229 Uptime: 22m wakeups: 1 Memory: 7.68 GiB used: 3.66 GiB (47.6%)
  Init: systemd v: 247 tool: systemctl Compilers: gcc: 10.2.0 clang: 11.1.0
  Packages: pacman: 1591 lib: 356 Shell: Zsh v: 5.8 running-in: alacritty
  inxi: 3.3.03


and post

inxi -Fxxxza

as text!