Kde wallet keeps asking me for a password

My kde wallet asks me for a password(which i dont know since i didnt enter any password ever) for opening stuff like discord or my browser every time after i reboot and it asks me for wifi password every time i disconnect even if i nentered the password before. i tried doing a snapshot backup or whatever thats called but it doesnt work. i also tried removing kde wallet but it breaks the UI. what can i do to fix that?

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "",
LC_ALL = (unset),
LC_ADDRESS = "de_DE.UTF-8",
LC_NAME = "de_DE.UTF-8",
LC_MONETARY = "de_DE.UTF-8",
LC_PAPER = "de_DE.UTF-8",
LC_IDENTIFICATION = "de_DE.UTF-8",
LC_TELEPHONE = "de_DE.UTF-8",
LC_MESSAGES = "en_US.UTF-8",
LC_MEASUREMENT = "de_DE.UTF-8",
LC_CTYPE = "en_US.UTF-8",
LC_TIME = "de_DE.UTF-8",
LC_COLLATE = "en_US.UTF-8",
LC_NUMERIC = "de_DE.UTF-8",
LANG = "en_GB.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_GB.UTF-8").
System:
Kernel: 5.17.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=f614fe14-284d-4ce1-a620-41c5dbee7c8d rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: NZXT model: N7 B550 serial: <superuser required>
UEFI: American Megatrends v: P1.20 date: 03/02/2021
CPU:
Info: model: AMD Ryzen 9 5950X bits: 64 type: MT MCP arch: Zen 3
family: 0x19 (25) model-id: 0x21 (33) stepping: 2 microcode: N/A
Topology: cpus: 1x cores: 16 tpc: 2 threads: 32 smt: enabled cache:
L1: 1024 KiB desc: d-16x32 KiB; i-16x32 KiB L2: 8 MiB desc: 16x512 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 3603 high: 3924 min/max: 2200/5083 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3590 2: 3581
3: 3592 4: 3588 5: 3590 6: 3587 7: 3593 8: 3578 9: 3582 10: 3586 11: 3594
12: 3717 13: 3699 14: 3571 15: 3577 16: 3553 17: 3589 18: 3585 19: 3576
20: 3588 21: 3924 22: 3582 23: 3597 24: 3589 25: 3567 26: 3568 27: 3584
28: 3593 29: 3587 30: 3588 31: 3617 32: 3600 bogomips: 217188
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GA104 [GeForce RTX 3070 Lite Hash Rate] vendor: ASUSTeK
driver: nvidia v: 510.60.02 alternate: nouveau,nvidia_drm pcie: gen: 2
speed: 5 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 06:00.0
chip-ID: 10de:2488 class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa gpu: nvidia
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 93 s-size: 524x292mm (20.63x11.50")
s-diag: 600mm (23.62")
Monitor-1: DP-0 res: 1920x1080 dpi: 94 size: 521x293mm (20.51x11.54")
diag: 598mm (23.53") modes: N/A
OpenGL: renderer: NVIDIA GeForce RTX 3070/PCIe/SSE2
v: 4.6.0 NVIDIA 510.60.02 direct render: Yes
Audio:
Device-1: NVIDIA GA104 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 06:00.1 chip-ID: 10de:228b class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASRock
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 08:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Razer USA RZ04-0318 Gaming Headset [Kraken Ultimate] type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-2:3 chip-ID: 1532:0527
class-ID: 0300 serial: <filter>
Sound Server-1: ALSA v: k5.17.4-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.50 running: yes
Network:
Device-1: Realtek RTL8125 2.5GbE vendor: ASRock driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: f000 bus-ID: 04:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp4s0 state: down mac: <filter>
Device-2: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 05:00.0
chip-ID: 8086:2725 class-ID: 0280
IF: wlp5s0 state: up mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-8:7 chip-ID: 8087:0032 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 1.36 TiB used: 748.68 GiB (53.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B
speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter> rev: 2B2QGXA7
temp: 37.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 4B6Q
Partition:
ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 748.68 GiB (80.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 748.68 GiB (80.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 748.68 GiB (80.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 748.68 GiB (80.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.28 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 42 C
Fan Speeds (RPM): fan-2: 1485 fan-3: 1530 fan-4: 1486 gpu: nvidia fan: 0%
Info:
Processes: 528 Uptime: 21m wakeups: 0 Memory: 31.28 GiB
used: 5.71 GiB (18.3%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 2108 lib: 569 Shell: fish
v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15
Garuda (2.6.1-3):
System install date:     2022-02-08
Last full system update: 2022-04-23
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

You can edit file ~/.kde/share/config/kwalletrc - adding to [Wallet] section just one line

              Enabled=false

save quit reboot problem gone - I hope it helps

Mark

that folder only contains one file called kdeglobals

Then create that suggested file and add the suggested text in the suggested section, as @bugfix suggested. :wink:

thing is i just did that, it made it so i couldnt connect to any wifi always getting the message "no secrets were provided"

Are you using autologin ?

1 Like

Maybe check if this helps:

1 Like

image
but this is all i have in wallet manager i cant do anything here except unlock it with a password i didnt ever set?

Did you try your root or user password?

Try to configure network manager as suggested then use again the file disabling kwallet with enable=false

1 Like

yes i did, i also tried empty but it doesnt work

1 Like

no, i dont


where do i configure it i cant find the option? is this the wrong network manager

Please stop posting 5 posts in 1 minute. I can't catch you.
Use some time to read Archwiki and think about it.

ok i will try

Read this and try what it says.
https://wiki.archlinux.org/title/KDE_Wallet#Unlock_KDE_Wallet_automatically_on_login

1 Like
If the kwallet Migration Assistant asks for a password after every login, rename or delete the `~/.kde4/share/apps/kwallet` folder.

but that folder doesnt exist and if i try just getting rid of kwallet my entire system is gone do i really have to reinstall? if so how can i make it that all the stuff is there how i left it?

Post contents of the file. Run this in terminal

cat ~/.config/kwalletrc
1 Like

[Wallet]
Close When Idle=false
Close on Screensaver=false
Enabled=false
First Use=false
Idle Timeout=10
Launch Manager=false
Leave Manager Open=false
Leave Open=true
Prompt on Open=false
Use One Wallet=true


is this where i put Enabled=false? i tried that just now and it doesnt change anything

You also have a web browser and you can find unlimited articles about it.
This is an example:
https://bbs.archlinux.org/viewtopic.php?id=202174

5 Likes