Kde wallet keeps asking for a password

garuda-inxi
System:
  Kernel: 5.18.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=53e270ad-dfd5-4874-a125-69d21ada6b8d rw [email protected]
    rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
    sysrq_always_enabled=1 amdgpu.ppfeaturemask=0xffffffff nowatchdog
  Desktop: KDE Plasma v: 5.25.1 tk: Qt v: 5.15.5 info: latte-dock
    wm: kwin_wayland vt: 2 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASRock model: X470 Taichi serial: <superuser required>
    UEFI: American Megatrends v: P4.86 date: 01/27/2022
Battery:
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
    serial: <filter> charge: 10% (should be ignored) rechargeable: yes
    status: discharging
CPU:
  Info: model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+ gen: 2
    built: 2018-21 process: GF 12nm family: 0x17 (23) model-id: 8 stepping: 2
    microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 4123 high: 4167 min/max: 2200/3600 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 4153 2: 4165
    3: 4071 4: 4088 5: 4125 6: 4123 7: 4167 8: 4136 9: 4154 10: 4051 11: 4139
    12: 4112 bogomips: 86402
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M]
    vendor: Gigabyte driver: amdgpu v: kernel arch: RDNA 2
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
    lanes: 16 ports: active: DP-1,HDMI-A-1 empty: DP-2,HDMI-A-2
    bus-ID: 0f:00.0 chip-ID: 1002:73df class-ID: 0300
  Display: wayland server: X.org v: 1.21.1.3 with: Xwayland v: 22.1.2
    compositor: kwin_wayland driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa gpu: amdgpu
    d-rect: 5888x2160 display-ID: 0
  Monitor-1: DP-1 pos: primary,left res: 2048x864 size: N/A modes: N/A
  Monitor-2: HDMI-A-1 pos: right res: 3840x2160 size: N/A modes: N/A
  OpenGL: renderer: AMD Radeon RX 6700 XT (navy_flounder LLVM 13.0.1 DRM
    3.46 5.18.5-zen1-1-zen)
    v: 4.6 Mesa 22.1.2 direct render: Yes
Audio:
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0f:00.1 chip-ID: 1002:ab28
    class-ID: 0403
  Sound Server-1: ALSA v: k5.18.5-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 16.0 running: no
  Sound Server-4: PipeWire v: 0.3.52 running: yes
Network:
  Device-1: Intel I211 Gigabit Network vendor: ASRock driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 09:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp9s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Edimax Bluetooth Adapter type: USB driver: btusb v: 0.8
    bus-ID: 1-8:4 chip-ID: 7392:c611 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 2.96 TiB used: 3.03 TiB (102.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:3 vendor: Samsung
    model: SSD 970 EVO 250GB size: 232.89 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXE7 temp: 34.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Samsung model: SSD 980 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 1B4QFXO7
    temp: 35.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DX002-2DV164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC41 scheme: GPT
Partition:
  ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
    used: 771.02 GiB (82.8%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 16.3 MiB (5.5%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:1
  ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
    used: 771.02 GiB (82.8%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
    used: 771.02 GiB (82.8%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
    used: 771.02 GiB (82.8%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.27 GiB used: 2.2 MiB (0.0%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 44.6 C mobo: 35.0 C gpu: amdgpu temp: 53.0 C
    mem: 54.0 C
  Fan Speeds (RPM): fan-1: 0 fan-2: 1875 fan-3: 0 fan-4: 0 fan-5: 0
    gpu: amdgpu fan: 0
  Power: 12v: N/A 5v: N/A 3.3v: 3.26 vbat: 3.28 gpu: amdgpu watts: 29.00
Info:
  Processes: 430 Uptime: 7m wakeups: 2 Memory: 31.27 GiB
  used: 10.59 GiB (33.9%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: 2389
  pacman: 2377 lib: 585 flatpak: 12 Shell: fish v: 3.4.1 default: Bash
  v: 5.1.16 running-in: alacritty inxi: 3.3.18
Garuda (2.6.4-1):
  System install date:     2022-05-22
  Last full system update: 2022-06-22
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:

So keep getting random kdewallet password prompts while I am gaming which takes the focus away from the game window.

I have read several forum posts on the subjects and tried all of there solutions. So far what seems to work best is just deleting all my wallets and disabling kdewallet. That stops it from showing up on login but it will still show up when opening certain apps and while gamming (which shouldn't even be possible correct? if it's disabled how is it still showing?)

tried the unlock automatically on the login option as mentioned in the arch wiki and that doesn't work, it prompts me on login for the password and then again randomly while I am gaming.
I even tried messing with the config at /etc/pam.d/sddm and /etc/pam.d/sddm-autologin with no luck

Links to what I have read


https://bbs.archlinux.org/viewtopic.php?id=202174
https://wiki.archlinux.org/title/KDE_Wallet

Have you tried also the tip in green in the Arch wiki (using a blank password)?
https://wiki.archlinux.org/title/KDE_Wallet

yeah it still prompts for a password (and for some reason its still my users password)

this how I'm setting a blank password btw and I rebooted afterwards

Hmm maybe because I am autologin with sddm disabled that and set my wallet's password to be the same as my user and now I only need to type the password once to log in and not for the wallet (so far at least)

That's the reason. With SDDM autologin, you still need to enter a password for kWallet.

I'm not sure if this is by design, but you have to check whether a blank password is not enough for SDDM autologin.

This looks like the most reasonable method for your case (autologin).

Just confirm this works, since your latest post is a little confusing :person_shrugging: .

2 Likes

From what I read you can't automatically unlock kde wallet on login like this, but you can create an empty kde wallet password so that it (supposedly) never prompts you.

The last post I made I was trying to setup kde wallet like this KDE Wallet - ArchWiki which for that I need to disable auto login in sddm.

configured this way it does not ask my to unlock my wallet on boot as it gets unlocked when I login to my user, however I still sometimes get the kdewallet password prompt and I have to put in my users password again (which is what I am trying to avoid I don't want any password prompt after i am already login to my user)

tried spacing things around to see if it helps with clarity

If you are OK with providing password once, then the easiest (and sane) way to do it is to disable autologin and use the DM like everyone else.
If not, just for fun, describe what you want to gain and how much important it is, in comparison to the well known security risks. :smile:
Are you sure this requirement is not part of a habit, or syndrome? :rofl:

2 Likes

Install the package gnome-keyring.

1 Like

I don't mind disabling auto login in sddm.( slightly more convenient to have it enable since this is a desktop computer with only one user which I use as a couch PC)

what bother's me is kde wallet popping up while I'm gaming and taking the focus away from the game window (even without a couch pc setup I am sure you can see how this is annoying if you are in the middle of an online match and is far from a)

so I have to get a mouse and close the window or use a keyboard to type the password.

i did (needed it for something else)

pacman -Qi gnome-keyring
Name            : gnome-keyring
Version         : 1:42.1-1
Description     : Stores passwords and encryption keys
Architecture    : x86_64
URL             : https://wiki.gnome.org/Projects/GnomeKeyring
Licenses        : GPL  LGPL
Groups          : gnome
Provides        : org.freedesktop.secrets
Depends On      : gcr  libcap-ng  pam  openssh
Optional Deps   : None
Required By     : github-desktop
Optional For    : git  libsecret
Conflicts With  : None
Replaces        : None
Installed Size  : 3.59 MiB
Packager        : Jan Alexander Steffens (heftig) <[email protected]>
Build Date      : Wed 25 May 2022 07:53:16 PM EDT
Install Date    : Thu 26 May 2022 05:40:55 PM EDT
Install Reason  : Installed as a dependency for another package
Install Script  : Yes
Validated By    : Signature

Then the mentioned methods should make it silent. Are you sure you implement them correctly? It's not an unusual case, since it's even included in Archwiki.

About my teasing, I was refering to autologin. You are right, it's an inconvenient thing. But Games use to create such anomalies, interfering with the system badly. You should ask at the Game channels for their experience.

yeah I don't get why Im still getting kde wallet prompts ( more confusing is its during a game where nothing should be opening that requires accses to the wallet)

most of this was said in my first post but....

From what I understand from the archwiki and other resources there are 3 ways to prevent the kde wallet prompt

  1. disable auto login and set the wallet password to be the same as the user password. This will unlock the wallet on login and should keep it unlocked for the rest of your session (unless you configure it to close after a while which I haven't as you can see here


    The problem with this is that I still get random wallet prompts while gaming

  2. Set an empty password for the kde wallet. You can use auto login with this method since it doesn't rely on a password to unlock the wallet it should just automatically unlock. However for some reason if I set a blank password it just uses my user's password and from everything I have read this is NOT intended behavior (so guess I have to open a bug report upstream for that.)

  3. The third option is just to disable the wallet all together. The problem with this is I have heard conflicting reports of whether this actually works some say it actually can cause random kde wallet prompts (and doesn't solve my issue like I said in the first post)

Have you tried all the Notes suggested in the Arch wiki? Eg Just to name a couple

  • If using KDE, one may want to disable Close when last application stops using it in KDE Wallet settings to prevent the wallet from being closed after each usage (WiFi-passphrase unlock, etc.).
  • It may be needed to remove the default created wallet first, thus removing all stored entries.

Edit: I see the first one in the picture :blush:

yes see my attached image
EDIT: didn't see your edit :sweat_smile:
and as for removing the wallet and re adding it that was suggested if it wasn't automatically unlocking on login. So i did definitely try that

1 Like

posted about this in the kde telegram and was linked to this issue org.freedesktop.secrets DBus API initial support (!11) · Merge requests · Frameworks / KWallet Framework · GitLab which fixes a simillar issue where pepole where getting random prompts while playing minecraft long shot but I tried installing AUR (en) - kwallet-secrets (also on the chaotic aur) to see if it helps

Famous last words of a WinOS user, just before his computer was locked from a hacker! :rofl:

Is that or other just games open source apps?
If so, check (or ask others to review) the source code for security related anomalies.
If not, ask the app vendor about this behavior.
In any way, I hope this is just a kwallet issue.

FYI if some process tries to access system resources, the system would try to authenticate the request. That's kwallet's job.

Good luck :fire_extinguisher:

1 Like

Well so far no more wallet prompts while gaming (this was in several games both Linux native and windows games ran through proton) so it looks like installing that package might have fixed it

from what I understand kde wallet stores credentials such as wifi password, session tokens form discord and other apps etc. It should only prompt the user for a password when

a. the wallet is currently locked

and

b. an application is trying to open that wallet. ( this should only be done by apps which store some needed credential in the wallet for example discord does this same for github desktop)

again I'm not questioning the security provided by kde wallet in fact I welcome it and do want it to be password protected.

What I don't want is it trying to unlock itself while I'm in the middle of a game ( it should be unlocked anyway if I set it up to unlock upon user login)

figured out the issue the problem wasn't KDE wallet but gnome-keyring it works separately (and uses its own password) from KDE wallet. This is why setting up auto-unlock or disabling the KDE wallet was not working because the wallet that was being accessed while I'm gaming isn't KDE wallet it's gnome-keyring so If I want to do auto-unlock, for example, I need to implement it for both. If I want to go the empty password route I need to set both to an empty password

This is an application design issue and you should report upstream, to that application dev team.
As suspected, the source of the problem is the application :

As a side note, I can't understand why users call their applications by their usage type (game).
The only difference is this and is not nice:

1 Like

Wdym? I kinda confused by you using application and game interchangeably.

I was saying that while i am gaming i get a password prompt to unlock my keyring.

At first i thought it was the kde wallet that was trying to be unlocked and was confused as to why since

A. The only app that i use kde wallet with is obs-cli which runs at game start to enable the replay buffer (the prompt was after playing for few hours)

B. I tried disabling the kde wallet or putting an empty password

It turns out it was gnome keyring that was being accessed
Which now makes alot of sense because

A.more apps on my system use gnome keyring (as they don't work with kde-wallet) such as GitHub desktop and jetbrain toolbox

B. Since gnome keyring is its own separate wallet app it's probably not configured (and idk if it's possible couldn't find an option) to stay unlocked. So it probably locks after a while so when jetbrain toolbox for example (which is always running in the background) refreshers to update it tries to unlock the wallet hence the prompt while gaming.

I don't understand why you keep referring to the game as an application as if it has the same capabilities and can access the keyring. Maybe a Linux game can but there is no way for a windows app to interface with a Linux only system unless it does through wine which doesn't access the wallet

So in summary everything is working as it's supposed there's no malicious game trying to take over my system to make part of a bot net to take over the world :earth_africa::sweat_smile: kde wallet is working as expected and so is gnome keyring

EDIT: after re-reading the thread I realized i was making it sound like this issue only happens in games and it was the games fault. My bad.

I never thought the issue was exclusive to games. I was just using games as an example of when this happens and why it's annoying. When I'm at my desk i don't mind the prompts i just ignore them or close them.
The issue was that when I'm gaming I'm not at my desk and don't have a keyboard and mouse making the prompts much more of an annoyance.

That's why I was confused about your game remarks. Again my bad​:sweat_smile:

Anyway the solution would be to either look for a way to prevent gnome keyring from auto closing or configure it with an empty password