KDE really slow on newly-built computer

Hi all. I'm new to Garuda Linux and loving it so far, but I'm having some issues with KDE being really unresponsive on my newly-built PC (Ryzen 5 5600X, Nvidia GeForce RTX 3060, 16 MB RAM). I would characterize myself as a Linux intermediate, maybe slightly more towards beginner, but I'm a complete noob in PC building. I'll try my best to summarize what I'm trying to fix below. Thanks in advance for any help.

After building my system, Garuda installed on it no problem. It picked up my Nvidia card, etc, without issues. However, I'm regularly experiencing significant slowdowns in KDE. Examples are:

  1. KRunner taking 10 seconds to load
  2. Tap meta, start typing, have to wait 5-10 seconds for text to appear
  3. Occasional application freezes. The mouse cursor is always available, but windows will freeze and become unresponsive for 5 seconds to ~1 minute.

I've also felt that I'm not getting quite the performance in games from my GPU that I would expect. I've seen occasional stuttering in Outer Wilds. Nothing crazy, but that combined with the stuttering in KDE--plus the fact that System Monitor never showed my CPU or RAM getting overloaded--led me down a path of troubleshooting my Nvidia driver. So here's what I've done:

  1. Installed the nvidia-fake-powerd package from the AUR, after finding this forum post. This didn't see any noticeable change.
  2. Installed the nvidia-all driver (not Vulkan, dkms), following instructions here. Again, no noticeable change.

I'm a bit out of ideas at this point and would love any recommendations. Thanks, all. Here's my inxi:

inxi -Faz
System:    Kernel: 5.15.2-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=98598844-044f-41ac-a5a9-7b45c555414d
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=23cc812f-a1d1-453e-85f0-01f210e1e021 loglevel=3
Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop System: ASUS product: N/A v: N/A serial: <filter>
Mobo: ASUSTeK model: TUF GAMING X570-PRO (WI-FI) v: Rev X.0x serial: <filter>
UEFI: American Megatrends v: 4021 date: 08/10/2021
CPU:       Info: 6-Core model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3 family: 19 (25)
model-id: 21 (33) stepping: 0 microcode: A201016 cache: L2: 3 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 100805
Speed: 4200 MHz min/max: 2200/4200 MHz boost: enabled Core speeds (MHz): 1: 4200 2: 4185
3: 4191 4: 4178 5: 4198 6: 4199 7: 4198 8: 4190 9: 4194 10: 4198 11: 4200 12: 4196
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA vendor: Micro-Star MSI driver: nvidia v: 495.44 alternate: nouveau,nvidia_drm
bus-ID: 0a:00.0 chip-ID: 10de:2487 class-ID: 0300
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: nvidia
unloaded: modesetting alternate: fbdev,nouveau,nv,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 3440x1440 s-dpi: 109 s-size: 802x333mm (31.6x13.1") s-diag: 868mm (34.2")
Monitor-1: DP-0 res: 3440x1440 dpi: 109 size: 800x330mm (31.5x13.0") diag: 865mm (34.1")
OpenGL: renderer: NVIDIA GeForce RTX 3060/PCIe/SSE2 v: 4.6.0 NVIDIA 495.44 direct render: Yes
Audio:     Device-1: NVIDIA GA104 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel
v: kernel bus-ID: 0a:00.1 chip-ID: 10de:228b class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
Sound Server-1: ALSA v: k5.15.2-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 05:00.0 chip-ID: 8086:2723
class-ID: 0280
IF: wlp5s0 state: up mac: <filter>
Device-2: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel port: N/A bus-ID: 06:00.0
chip-ID: 8086:15f3 class-ID: 0200
IF: enp6s0 state: down mac: <filter>
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:3 chip-ID: 8087:0029
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 1.86 TiB used: 846.59 GiB (44.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:4 model: T-FORCE TM8FP8001T size: 953.87 GiB block-size:
physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: V9002s77 temp: 39.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 model: T-FORCE TM8FP8001T size: 953.87 GiB block-size:
physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: V9002s77 temp: 39.9 C scheme: GPT
Partition: ID-1: / raw-size: 936.48 GiB size: 936.48 GiB (100.00%) used: 744.59 GiB (79.5%) fs: btrfs
dev: /dev/nvme1n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%) fs: vfat
dev: /dev/nvme1n1p1 maj-min: 259:1
ID-3: /home raw-size: 936.48 GiB size: 936.48 GiB (100.00%) used: 744.59 GiB (79.5%) fs: btrfs
dev: /dev/nvme1n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 936.48 GiB size: 936.48 GiB (100.00%) used: 744.59 GiB (79.5%)
fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 936.48 GiB size: 936.48 GiB (100.00%) used: 744.59 GiB (79.5%)
fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 17.09 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme1n1p3 maj-min: 259:3
ID-2: swap-2 type: zram size: 15.6 GiB used: 12.76 GiB (81.8%) priority: 100 dev: /dev/zram0
Sensors:   Message: No sensor data found. Is lm-sensors configured?
Info:      Processes: 372 Uptime: 1h 54m wakeups: 0 Memory: 15.6 GiB used: 7.75 GiB (49.7%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1817 lib: 502 Shell: fish
v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.08
1 Like

have you tried it with lts kernel

3 Likes

No, I'll give it a try. Thanks for the suggestion!

If I install the lts kernel, do I need to switch my Nvidia drivers? Here's what I have installed right now:

sudo pacman -Qs nvidia
local/garuda-nvidia-config 1.1.4-2
Meta configuration package for nvidia systems on Garuda Linux
local/gwe 0.15.4-1
A system utility for controlling NVIDIA GPUs
local/lib32-libvdpau 1.4-1
Nvidia VDPAU library
local/lib32-nvidia-utils-tkg 495.44-186
NVIDIA driver utilities and libraries for 'nvidia-tkg' (32-bit)
local/lib32-opencl-nvidia-tkg 495.44-186
NVIDIA's OpenCL implemention for 'lib32-nvidia-utils-tkg'
local/libvdpau 1.4-1
Nvidia VDPAU library
local/libxnvctrl 495.44-1
NVIDIA NV-CONTROL X extension
local/mhwd-nvidia 495.44-1
mhwd-nvidia pci id
local/mhwd-nvidia-390xx 390.143-1
mhwd-nvidia-390xx PCI ID database
local/nvidia-dkms-tkg 495.44-186
NVIDIA kernel module sources (DKMS)
local/nvidia-egl-wayland-tkg 495.44-186
NVIDIA EGL Wayland library (libnvidia-egl-wayland.so.1.1.9) for 'nvidia-utils-tkg'
local/nvidia-fake-powerd 0.1.0-2
dbus blackhole for nvidia.powerd.server for working around a bug in nvidia-495 drivers.
local/nvidia-settings-tkg 495.44-186
Tool for configuring the NVIDIA graphics driver
local/nvidia-utils-tkg 495.44-186
NVIDIA driver utilities and libraries for 'nvidia-tkg'
local/opencl-nvidia-tkg 495.44-186
NVIDIA's OpenCL implemention for 'nvidia-utils-tkg'

Welcome :slight_smile:

15,6 GiB :wink:

Is Baloo working in background?

Drives:    Local Storage: total: 1.86 TiB used: 846.59 GiB (44.4%)

Lot of data.

Check in terminal with top/htop.

2 Likes

I'd also check in the Garuda assistant if a btrfs balance is suggested. Although it's a new installation, with all this stuff maybe it is already needed.

1 Like

:laughing:
I'm showing my age a bit, I think. I remember a time when RAM was measured in MB.

Yes, Baloo is working in the background. It's the top four processes in htop by MEM%, taking ~19%. It's top in CPU% as well, varying between 1% - ~25%. But my overall RAM and CPU usage seem fine:

I just switched over to the LTS kernel, and it doesn't seem to have improved things. Still seeing random slowdowns that don't make sense on this hardware. I'll try disabling Baloo and see if that fixes it.

Oh, re: LTS kernel, the way I switched over was to install linux-lts and linux-lts-headers. I have the dkms Nvidia driver. Then I switched to the LTS kernel on the grub screen and verified it's running LTS. Seems to all be working, but let me know if I did anything wrong, I guess.

Thanks, all.

Wait, many here started with KB :blush:
But I don't want to go oot..

3 Likes

I think you be fine if baloo is ready with indexing. I think zen is better for your hardware, but just test it :slight_smile:

1 Like

Update: Looks like it was Baloo. I disabled it by unchecking "Enable File Search" in System Settings, rebooted, and everything is much snappier.

Next I'm going to try re-enabling it but unchecking "Also index file content". I'll be super bummed if that doesn't work, as I definitely want that type of functionality on my system.

Does anyone have any insight as to why htop / System Monitor weren't able to call this to my attention? I never saw RAM or CPU as a whole spike significantly when running Baloo. Watching the aggregate values for those definitely led me to look at the GPU, since they didn't seem to be having any issues.

1 Like

and now we almost have Desktop CPUs with more Cache capacity than our HDDs did (already there for those who class Threadripper as Desktop, or those earlier than me an my 170MB HDD).

1 Like

Where in System Settings, might I find "Enable File Search" ? I want to stop Baloo because it is running a lot.

balooctl disable (or just suspend)
https://wiki.archlinux.org/title/Baloo

3 Likes

Just load up system settings, then in the search bar on the top left, just type "search" and one of the options it will filter to on the left sidebar will be "File Search" - click on that, then disable. That is, if you want the GUI way of doing it.

3 Likes

Update update: I tested turning Baloo back on, and it was stuck at 97% index for a really long time. I ran balooctl purge and re-enabled Baloo (still without indexing file content, which I don't really need), and htop is looking good.

Thanks for the help, everyone! I really appreciate it! And loving this super snappy computer now. :grin:

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.