KDE Global Scale stuck after update

Howdy, updated earlier today and the global scale on my desktop has been somehow enlarged and permanently stuck that way. the KDE global scale setting slider does not currently work.

i have tried to:
change the glocal scale in the KDE settings,
redo the entire desktop theme,
change themes all together,
manually work around it with Nvidia settings
manually work around it with DPI scale & font scale
searched these forums in the hopes of someone else having this problem
searched google for possible arch/alternate distro users with a similar problem
searched all known KDE forums/githubs for any mention of such a problem
prayed to arcane gods from lands long lost to recorded history
ritualistic sacrifice of the mind at the alter of cthulhu

and have come up dry… i have no clue why this is happening now.

terminal output:

╭─gem@gem in ~
╰─λ garuda-inxi
System:
Kernel: 6.6.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=362a2186-9834-456e-94cc-0e5df56caa01 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: ROG CROSSHAIR VIII IMPACT v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 3302
date: 03/05/2021
CPU:
Info: model: AMD Ryzen 5 3600X bits: 64 type: MT MCP arch: Zen 2 gen: 3
level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 3747 high: 3800 min/max: 2200/4409 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3800 2: 3800
3: 3800 4: 3800 5: 3800 6: 3800 7: 3573 8: 3800 9: 3597 10: 3800 11: 3594
12: 3800 bogomips: 91197
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA GM204 [GeForce GTX 980] vendor: ZOTAC driver: nvidia
v: 545.29.02 alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current
(as of 2023-10; EOL~2026-12-xx) arch: Maxwell code: GMxxx
process: TSMC 28nm built: 2014-2019 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 09:00.0 chip-ID: 10de:13c0 class-ID: 0300
Device-2: Logitech HD Pro Webcam C920 driver: snd-usb-audio,uvcvideo
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-1.1:4
chip-ID: 046d:082d class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia display-ID: :0
screens: 1
Screen-1: 0 s-res: 3000x1920 s-dpi: 52 s-size: 1465x290mm (57.68x11.42")
s-diag: 1493mm (58.8")
Monitor-1: DP-2 pos: top-right res: 1080x1920 hz: 60 dpi: 94
size: 293x521mm (11.54x20.51") diag: 598mm (23.53") modes: N/A
Monitor-2: DP-4 pos: primary,bottom-l res: 1920x1080 hz: 60 dpi: 94
size: 521x293mm (20.51x11.54") diag: 598mm (23.53") modes: N/A
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia
inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.02
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce GTX 980/PCIe/SSE2
memory: 3.91 GiB
API: Vulkan v: 1.3.269 layers: 5 device: 0 type: discrete-gpu
name: NVIDIA GeForce GTX 980 driver: nvidia v: 545.29.02
device-ID: 10de:13c0 surfaces: xcb,xlib
Audio:
Device-1: NVIDIA GM204 High Definition Audio vendor: ZOTAC
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 09:00.1 chip-ID: 10de:0fbb class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0b:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Logitech HD Pro Webcam C920 driver: snd-usb-audio,uvcvideo
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-1.1:4
chip-ID: 046d:082d class-ID: 0102 serial: <filter>
API: ALSA v: k6.6.1-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 0.3.84 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp4s0 state: down mac: <filter>
Device-2: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 05:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-5:4 chip-ID: 8087:0029
class-ID: e001
Report: btmgmt ID: hci1 rfk-id: 3 state: up address: <filter> bt-v: 5.2
lmp-v: 11 status: discoverable: no pairing: no class-ID: 7c0104
Device-2: ASUSTek ASUS USB-BT500 driver: btusb v: 0.8 type: USB rev: 1.1
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-6:2 chip-ID: 0b05:190e
class-ID: e001 serial: <filter>
Report: ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.1 lmp-v: 10
status: discoverable: no pairing: no class-ID: 7c0104
Drives:
Local Storage: total: 1.38 TiB used: 1.03 TiB (75.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDS512G1X0C-00ENX0 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: B35500WD temp: 44.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 4B6Q scheme: GPT
Partition:
ID-1: / raw-size: 58.59 GiB size: 58.59 GiB (100.00%)
used: 48.97 GiB (83.6%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-2: /boot/efi raw-size: 385 MiB size: 384.2 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p3 maj-min: 259:3
ID-3: /home raw-size: 417.97 GiB size: 417.97 GiB (100.00%)
used: 134.93 GiB (32.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 58.59 GiB size: 58.59 GiB (100.00%)
used: 48.97 GiB (83.6%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-5: /var/tmp raw-size: 58.59 GiB size: 58.59 GiB (100.00%)
used: 48.97 GiB (83.6%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 62.71 GiB used: 6.8 MiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 35.0 C mobo: 30.0 C gpu: nvidia temp: 32 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 35%
Info:
Processes: 403 Uptime: 2m wakeups: 0 Memory: total: 64 GiB note: est.
available: 62.71 GiB used: 5.05 GiB (8.1%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: pm: pacman pkgs: 1833 libs: 506 tools: octopi,pamac,paru
pm: flatpak pkgs: 0 Shell: fish v: 3.6.1 default: Bash v: 5.2.15
running-in: yakuake inxi: 3.3.31
Garuda (2.6.18-1):
System install date:     2023-07-09
Last full system update: 2023-11-10
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

Try creating a new user and log in as them to see if it is an issue related to your profile, or something else.

3 Likes

Just tried making a new user and logged into it. same problem.
tried adjusting the global scale on that user, same problem.
the global scale slider in KDE settings just Does Not Do Anything.

it’s the weirdest thing. like that function just doesn’t exist. the slider moves and I can “apply” it but it doesn’t change the global scale at all.

In terminal use

sudo nvidia-settings

Maybe you must install the software.

Oops, overlooked

im perfectly happy to hop on the discord voice channel and let you guys rapid fire try solutions?
i’ve taken screenshots to provide examples but i cant post those here.
“new user’s are not allowed to upload images”

Maybe it’s just a matter of wrong resolution? Can you please post the output of

xrandr
1 Like

I have two monitors, one landscape, and one portrait. I do lots of gaming, but I also do lots of work from home. spreadsheets, etc.

╭─gem@gem in ~
╰─λ xrandr
Screen 0: minimum 8 x 8, current 3000 x 1920, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 connected 1080x1920+1920+0 right (normal left inverted right x axis y axis) 521mm x 293mm
1920x1080     60.00*+ 143.85   119.98    99.93    59.94    50.00
1680x1050     59.95
1440x900      59.89
1440x576      50.00
1440x480      59.94
1280x1024     75.02    60.02
1280x960      60.00
1280x720      60.00    59.94    50.00
1152x864      75.00
1024x768      75.03    70.07    60.00
800x600       75.00    72.19    60.32    56.25
720x576       50.00
720x480       59.94
640x480       75.00    72.81    59.94    59.93
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 connected primary 1920x1080+0+420 (normal left inverted right x axis y axis) 521mm x 293mm
1920x1080     60.00*+ 143.85   119.98    99.93    59.94    50.00
1680x1050     59.95
1440x900      59.89
1440x576      50.00
1440x480      59.94
1280x1024     75.02    60.02
1280x960      60.00
1280x720      60.00    59.94    50.00
1152x864      75.00
1024x768      75.03    70.07    60.00
800x600       75.00    72.19    60.32    56.25
720x576       50.00
720x480       59.94
640x480       75.00    72.81    59.94    59.93
DP-5 disconnected (normal left inverted right x axis y axis)

╭─gem@gem in ~ took 18ms
╰─λ

I have changed you to TL1 so you can post pictures if you would like.

It is possible you have encountered a bug in KDE, which will not be resolved with adjustments to your configuration. This possibility seems likely because you mentioned it happened after an update.

2 Likes

thank you so much <3

Hmm, :thinking: your resolutions look right both set to 1920x1080 so the bug is somewhere else… Can you also post your

kscreen-doctor -o

See if we find anything useful.

1 Like

absolutely :saluting_face:
sidenote:
i am chilling in the garuda discord voice right now

╭─gem@gem in ~
╰─λ kscreen-doctor -o
Output: 444 DVI-I-0 disabled disconnected priority 0 DVI Modes: Geometry: 0,0 0x0 Scale: 1 Rotation: 1 Overscan: 0 Vrr: incapable RgbRange: unknown
Output: 445 DVI-I-1 disabled disconnected priority 0 DVI Modes: Geometry: 0,0 0x0 Scale: 1 Rotation: 1 Overscan: 0 Vrr: incapable RgbRange: unknown
Output: 446 HDMI-0 disabled disconnected priority 0 HDMI Modes: Geometry: 0,0 0x0 Scale: 1 Rotation: 1 Overscan: 0 Vrr: incapable RgbRange: unknown
Output: 447 DP-0 disabled disconnected priority 0 DisplayPort Modes: Geometry: 0,0 0x0 Scale: 1 Rotation: 1 Overscan: 0 Vrr: incapable RgbRange: unknown
Output: 448 DP-1 disabled disconnected priority 0 DisplayPort Modes: Geometry: 0,0 0x0 Scale: 1 Rotation: 1 Overscan: 0 Vrr: incapable RgbRange: unknown
Output: 449 DP-2 enabled connected priority 2 DisplayPort Modes: 450:1920x1080@60*! 451:1920x1080@144 452:1920x1080@120 453:1920x1080@100 454:1920x1080@60 455:1920x1080@50 456:1680x1050@60 457:1440x900@60 458:1440x576@50 459:1440x480@60 460:1280x1024@75 461:1280x1024@60 462:1280x960@60 463:1280x720@60 464:1280x720@60 465:1280x720@50 466:1152x864@75 467:1024x768@75 468:1024x768@70 469:1024x768@60 470:800x600@75 471:800x600@72 472:800x600@60 473:800x600@56 474:720x576@50 475:720x480@60 476:640x480@75 477:640x480@73 478:640x480@60 479:640x480@60 Geometry: 1920,0 1080x1920 Scale: 1 Rotation: 8 Overscan: 0 Vrr: incapable RgbRange: unknown
Output: 480 DP-3 disabled disconnected priority 0 DisplayPort Modes: Geometry: 0,0 0x0 Scale: 1 Rotation: 1 Overscan: 0 Vrr: incapable RgbRange: unknown
Output: 481 DP-4 enabled connected priority 1 DisplayPort Modes: 450:1920x1080@60*! 451:1920x1080@144 452:1920x1080@120 453:1920x1080@100 454:1920x1080@60 455:1920x1080@50 456:1680x1050@60 457:1440x900@60 458:1440x576@50 459:1440x480@60 460:1280x1024@75 461:1280x1024@60 462:1280x960@60 463:1280x720@60 464:1280x720@60 465:1280x720@50 466:1152x864@75 467:1024x768@75 468:1024x768@70 469:1024x768@60 470:800x600@75 471:800x600@72 472:800x600@60 473:800x600@56 474:720x576@50 475:720x480@60 476:640x480@75 477:640x480@73 478:640x480@60 479:640x480@60 Geometry: 0,420 1920x1080 Scale: 1 Rotation: 1 Overscan: 0 Vrr: incapable RgbRange: unknown
Output: 482 DP-5 disabled disconnected priority 0 DisplayPort Modes: Geometry: 0,0 0x0 Scale: 1 Rotation: 1 Overscan: 0 Vrr: incapable RgbRange: unknown

╭─gem@gem in ~ took 140ms
╰─λ

I sadly can’t see anything wrong here either… global display set to 100% with 1920x1080p according to kscreen-doctor as well. Maybe someone more experienced can help.

1 Like

I know! it’s maddening.
it’s such a trivial simple thing but when you don’t have control over it,
it’s maddening.

notice here 100%

notice here 300%

and no difference between the two.
that settings panel was closed and re-opened between screenshots.

You can try rolling back a snapshot to see if it helps and hold out on updating this week if it does?

2 Likes

would setting the grub_gfxmode to the correct resolution and forwarding the gfxpayload to the kernel from GRUB possibly fix it?

i wouldn’t know how to do that sadly :sweat_smile:

I also wouldn’t know how to do a rollback either…
I’m like a normie user. :sweat_smile:
been using Linux for about 10 years but all I do is work and play and don’t step out of my lane :face_exhaling:

2 Likes

it’s in etc/default/grub
‘grub’ in that folder is the grub configuration file.
open it with kate and modify
GRUB_GFXMODE=auto to GRUB_GFXMODE=1920x1080x32 (32 is the color bit depth)
and then modify GRUB_GFXPAYLOAD_LINUX= to GRUB_GFXPAYLOAD_LINUX=keep

after that run sudo update-grub in the terminal and then reboot your machine.
grub will then send the video resolution parameters to the kernel on boot-up.

2 Likes

~Grub changes back to 420p dispite it being 1920x1080 in /etc/default/grub config file

Check first what’s possible, videoinfo in grub or

sudo pacman -S hwinfo --needed
sudo hwinfo | grep -C3 "Resolution"
1 Like