KDE Dragonized gaming won't boot from iso to install

Hey guys,
I'm trying to install the kde dragonized gaming iso and it will not boot the ISO to install. It just keeps hanging. It gets to Finished LiveMedia Pacman mirror ranking script and says it is successful.
It then moves on and says:
A start job is running for LiveMedia MHWD script (4min 25s / no Limit)
Any ideas how to fix this?
The previous iso works just fine. It's just the latest one that doesn't work.
(There are no actual errors it just keeps going)

I tried turning off the network as that sometimes helps with manjaro but that didnt do anything here either. I'm wondering if the issue is optimus to be honest

Have you tried using only the free drivers option?

Have you tested some other Garuda ISO's to see if they boot properly?

Did you checksum your ISO before burning it?

What method did you use to burn the ISO?


None of the new isos work. I have tried the qtile version and the kde gaming. To put them on the flash drive I use etcher. Dragonized tkg bmq 210107 works. (I'm also trying to boot from the ISO with virtual box and VMware workstation.)

On your side, try dd or Ventoy too.

Also read

please and post

inxi -Fxxxza

as text!

Sorry none of them worked inside VMWare. I'm going to try them in ventoy next as well. The host is a windows machine Graphics card is RTX2060 with a gen8 i7. on the VM's I usually use 8 of the 16gb of ram in the machine and give the vm 6 cores. If you give me a minute I will try and boot it from ventoy

Purely for information and a reminder

We also don't recommend running Garuda Linux in a virtual machine as it is optimized to run on real hardware. Some things also refuse to run in Virtualbox such as Picom or Alacritty.