KDE Dr460nized - Lock Screen asks for Password when there is no Password

Hello, new to the forum, returning Linux user after 5+ years away from doing anything Linux. I started messing with Arch Linux to brush up about a month ago, and then I found Garuda Linux earlier this month, liked what I saw and wiped my Arch Linux Partition and installed the KDE Dr460nized edition. I love it, it's wonderful and beautiful!

I have a few questions/ noticed some oddities. I am currently doing a fresh install of 210102 and maybe some of these concerns are fixed/addressed in the newest update:

  • No Password Lock Screen issue - On my last install I chose to not use a password for my user. Whenever the lock screen would show up it would still prompt me for a password. I tried the root password and it didn't work and no matter what I tried (no password and multiple passwords) it wouldn't let me in. I ended up needing a full reboot to get back in.
  • No Networks Detected after restart - After I would reboot, occasionally the network manager would tell me there were no connections available and no matter what I configured it wouldn't detect anything. I didn't dive into this one too far, as a simple shut down and power on would resolve it each time.
  • Snap issues - I read on other posts that there were issues getting Snap working right. I tried both not enabling classic snap support and enabling it and each time I tried I would either get notifications that Core wasn't detected (did basic snap troubleshooting like reboot and refresh to no avail), or PATH errors, or that the configuration failed. This one isn't a huge deal, I am only trying to install the Youtube Music Player from the Snap Store.

Once I clean install the newest version I think I will try

sudo pacman -S pamac-all

and then enable snap in pamac preference. ¯_(ツ)_/¯

Thanks for letting me list out my questions/concerns! Any help or insight is appreciated. I hope it wasn't to brazen of me for my introductory post to list out 3 issues lol.

Thanks for all you guys do! :smiley:

Let's wait and see, before people start replying about issues that no longer exist. :wink:


Id strongly advise you to use a password :thinking:

In fact we decided to stop officially supporting snaps & flatpaks with the latest release however, if you still want to try there is a wiki article. Did you read that one already?

And welcome to Garuda :slight_smile:


I was doing a test run and was planning on adding a password once I was done playing with the fresh install.

I will read that wiki absolutely! Thanks for the info.

This is tecnicly my falt

I was about to ask on other topic about snaps and flatpaks... when I install pamac-all, and try to install anything, the pamac closes without notice. Is there something related to using fish on terminal?

So the Wifi issues seemed to fix with the reinstall, however I am still experiencing the password issue. I did add a password to my user to get around it, however when there is no password and the screen locks, I am stuck at the lock screen.

Generally, it is best to open a separate topic on each separate issue. Threads that resemble a dogs breakfast are not encouraged on the forum. Threads that cover many different issues make it hard for other users looking for answers on the forum to find a solution.

Are you dual booting Windows?

This sounds like a driver conflict issue try rmmodding then modprobing your wifi driver module.

I'll keep that in mind in the future, I didn't mean to barrage anyone with issues, I just wanted to get the info out there.

I am dual booting, however The wifi issue solved itself with the clean reinstall. And the pacman issue isn't officially supported so now the only issue remaining is the no password/lock screen.

Thanks for your help.

Have you tried simply, repeating entering the password more than once. Sometimes this is enough to let you login. I have encountered a few different bugs myself at times. They usually resolve with KDE updates, and then will perhaps pop up again at a later date.

Some tips:

Watch carefully as you enter your password. Are the characters being entered twice as you type them in. If so, backspace/erase the redundant character anytime it is entered twice.

Try a different method such as the onscreen keyboard to login if using a keyboard (or vice versa).

1 Like

These are all great tips, except the issue is I didn't set a password for the user initially, only root.

When I set a password to the user the lock screen and everything is fine. It's when I don't set a password is when there is an issue. When Garuda locks, it requires a password to unlock even when there is no password set. The only solution is to restart.

I know the quick answer would be to always set a password, but during the installation setup it accepted a blank password, and nothing blocked me from doing so. If I don't want to set a password, I shouldn't have too, and the lock screen shouldn't ask me for a password if there isn't one.

Also I don't know if there is a thread change long, but I changed the name of the topic for clarity. :stuck_out_tongue:

Loving Garuda so far. :slight_smile:

Try creating a new user account with a password and simply set it to auto login.

Auto login is enabled and works when booting in. It's when I lock the desktop where it becomes the issue. I can get around being locked out with a reboot because auto login is enabled. I already tried a second user, and the results were the same. When there is no password set, the lock screen locks me out completely.

Just to clarify overall, I have access to my desktop because I did set a password. But I am experiencing a bug where if I set the user to not have a password and the desktop locks either through auto lock or manual lock, I cannot unlock because it requires a password to unlock. The work around is to either set a password or reboot from the lock screen.

I hope that clarified what I am experiencing. :slight_smile:

You could try using a different screen locker utility.

I will try that, thank you. Looks like its just using the kscreenlocker. I did a quick google search and nothing came up matching what I am seeing. :man_shrugging:

Try these 2 commands (separately):

Lock screen via command line on KDE 5:

xdg-screensaver lock

Lock all sessions via command line on KDE 5:

loginctl lock-sessions

Check if the behaviour is any different using the different commands. Be sure to place your mouse pointer in the password entry field and left click there to ensure that it is active when you enter the password on your keyboard.

That does indeed sound like a bug in the screen locker program - might be worth checking on KDE's bug trackers and giving it a +1, or reporting it if it isn't already.


It sounds a bit silly, asking for password, when there is a no-password user.
The obvious and very clear (to me) solution (not a workaround) is to set the Lockscreen not ask for a password!!

The setting for blanking screen is at Battery Config IIRC.



The obvious and very clear (to me) solution (not a workaround) is to set the Lockscreen not ask for a password!!

I am confused by this response. If you are suggesting I disable the lock screen, that would be a workaround? Since the lock screen still requires a password if I manually lock the screen with "Windows + L".

I dont see a way to set the lockscreen to not need a password in the configuration screen you show in your screenshot. Maybe there is a way through the screen locker program config.

@tbg I tried both those commands and the results were the same. When no password is set it still wont let me unlock.


That does indeed sound like a bug in the screen locker program - might be worth checking on KDE's bug trackers and giving it a +1, or reporting it if it isn't already.

Looking into this now. Thanks!

1 Like