KDE asking for wifi password on startup

System:    Kernel: 5.14.16-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=8fb4d0aa-c7a3-4503-a2bd-892955066d06 rw
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1 resume=UUID=ae82cfe5-7222-4e43-b44a-6d3b5d08171e loglevel=3
           Desktop: KDE Plasma 5.23.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
           Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: LENOVO product: 80WK v: Lenovo Y520-15IKBN serial: <filter> Chassis: type: 10
           v: Lenovo Y520-15IKBN serial: <filter>
           Mobo: LENOVO model: LNVNB161216 v: SDK0J40688 WIN serial: <filter> UEFI: LENOVO v: 4KCN45WW
           date: 01/11/2019
Battery:   ID-1: BAT0 charge: 32.1 Wh (100.0%) condition: 32.1/45.0 Wh (71.4%) volts: 12.2 min: 11.1
           model: SMP L14M3P24 type: Li-poly serial: <filter> status: Full
CPU:       Info: Quad Core model: Intel Core i5-7300HQ bits: 64 type: MCP arch: Kaby Lake family: 6
           model-id: 9E (158) stepping: 9 microcode: EA cache: L2: 6 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19999
           Speed: 3300 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 3300 2: 3489 3: 3302 4: 3279
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
           Type: mds mitigation: Clear CPU buffers; SMT disabled
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling
           Type: srbds mitigation: Microcode
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel HD Graphics 630 vendor: Lenovo driver: i915 v: kernel bus-ID: 00:02.0
           chip-ID: 8086:591b class-ID: 0300
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Lenovo driver: nvidia v: 495.44
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1c8d class-ID: 0302
           Device-3: Realtek EasyCamera type: USB driver: uvcvideo bus-ID: 1-6:4 chip-ID: 0bda:58e5
           class-ID: 0e02 serial: <filter>
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting,nvidia
           display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
           Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
           OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 21.2.4 direct render: Yes
Audio:     Device-1: Intel CM238 HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
           chip-ID: 8086:a171 class-ID: 0403
           Sound Server-1: ALSA v: k5.14.16-zen1-1-zen running: yes
           Sound Server-2: sndio v: N/A running: no
           Sound Server-3: JACK v: 1.9.19 running: no
           Sound Server-4: PulseAudio v: 15.0 running: no
           Sound Server-5: PipeWire v: 0.3.39 running: yes
Network:   Device-1: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi v: kernel
           bus-ID: 03:00.0 chip-ID: 8086:3166 class-ID: 0280
           IF: wlp3s0 state: up mac: <filter>
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169
           v: kernel port: 3000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
           IF: enp4s0 state: down mac: <filter>
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-11:5
           chip-ID: 8087:0a2a class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 931.51 GiB used: 248.84 GiB (26.7%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB block-size:
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: LCM2
           scheme: GPT
Partition: ID-1: / raw-size: 166.48 GiB size: 166.48 GiB (100.00%) used: 18.67 GiB (11.2%) fs: btrfs
           dev: /dev/sda7 maj-min: 8:7
           ID-2: /boot/efi raw-size: 524.4 MiB size: 523.4 MiB (99.80%) used: 580 KiB (0.1%) fs: vfat
           dev: /dev/sda5 maj-min: 8:5
           ID-3: /home raw-size: 166.48 GiB size: 166.48 GiB (100.00%) used: 18.67 GiB (11.2%) fs: btrfs
           dev: /dev/sda7 maj-min: 8:7
           ID-4: /var/log raw-size: 166.48 GiB size: 166.48 GiB (100.00%) used: 18.67 GiB (11.2%) fs: btrfs
           dev: /dev/sda7 maj-min: 8:7
           ID-5: /var/tmp raw-size: 166.48 GiB size: 166.48 GiB (100.00%) used: 18.67 GiB (11.2%) fs: btrfs
           dev: /dev/sda7 maj-min: 8:7
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 7.66 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
           ID-2: swap-2 type: partition size: 3.91 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda6
           maj-min: 8:6
Sensors:   System Temperatures: cpu: 47.5 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 259 Uptime: 18m wakeups: 1 Memory: 7.66 GiB used: 3.53 GiB (46.1%) Init: systemd v: 249
           tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1538 lib: 365 Shell: fish
           v: 3.3.1 default: Bash v: 5.1.8 running-in: yakuake inxi: 3.3.08

Hello, i got this problem where the KDE daemon asks my wifi password on startup everytime, but only on startup. i followed this posts troubleshooting but didn't work:

What can i do?

:point_up_2: If you include terminal outputs in your post please
use the proper output format in your post.
Using "~" 3 times above and "~" 3 times below the text block
will provide a readable, raw look.

You can try a couple of things that might work.

  1. Check to see if the Kwallet feature is disabled. You can check/enable under Settings>Personalization>Users>Enable the KDE Wallet Subsystem

  2. Open Network Manager, go to wireless tab and edit or add your wireless network info, making sure to check the box "all users may connect to this network." Also, on the tab "Wifi Security" make sure you store password for this user with encryption" is selected and not "ask for password each time."


1.- Not only it didn't work, it actually asked me the kwallet password on every startup, like the wifi. Had to disable it again because it didn't stop the daemon either.

2.- not sure what the network manager is, but i went seetings>network>connections and then removed it and added manually, adding the ''all users may connect'' and ''store password for this user with encryption'' but still persisted.

You have not stated if this situation was present since you first installed or if it only recently started after an update or some other changes you made.

Did you also perform this step from the post you linked:

You should also ensure your regulatory domain is set correctly. Search for that procedure on the Arch Wiki.

I am not sure how much we can help you as the information you provide is sporadic and incomplete. This usually leads to an immense amount of time wastage and no resolution.

Is this a typo ^^^

You are supposed to set the connection to store the password unencrypted.

Please answer all questions that I've edited into my post in full if you wish assistance.

1 Like

After eternal reboots, i figured it out, yeah you where right on this:

Didn't know i absolutely had to use that option (neither wanted since it's pretty insecure in my use case), anyways for some reason everytime i wrote the password and saved it as encrypt for this user, and then went to change something (Ex: shortcuts) and went back again to connections, the space was always blank, which didn't happen on not encrypted.
Probably a KDE bug, not sure.

Anyways thanks for your time, is there some tutorial or something on how to post effective bug reports that don't waste time?

Also i did install it yesterday, however i updated it fully without restarting so not sure which thing blame here, and in terms of customization the only thing could be that i disabled kwallet, and activated the firewall, that's it.

We always mark here the solution and not the implementation.

1 Like

This has been an "on again, off again" KDE bug for years.

So glad you figured out the fix. It usually helps when following my troubleshooting instructions to do so in their entirety. My instructions are posted numerous times on this subject. You had the correct answer that I had posted linked on your very first post of this thread.

You ignored my posted instructions, choosing to chery pick only the suggestions you liked. Then you proceeded to state:

You will find few assistants on the forum willing to respond to users such as yourself. You are simply wasting everyone's time here (as I already observed).

The answer to your problem was already posted on my response you linked and claimed you'd tested. You need to get your act together and start posting in a coherent and thorough manner if you wish assistance on our forum. Otherwise, please take your help requests to Reddit where they delight in wasting their time.

1 Like

Odd, I am using the encrypted option and it is not a problem for me. :man_shrugging:

For troubleshooting purposes you need to test the unencrypted option when this issue occurs. Usually having the connection's password encrypted works fine on almost all installs. In a small subset where this bug occurs you must change that setting or you will be constantly prompted for a password.

This bug has been mostly resolved for quite some time, but it always pops up now and again for a few people. Just one of those recurrent KDE annoyances.

1 Like

Oh srry im gonna de-mark it then.

Then i guess the correct way to end this is by redirecting to the OG post i guess:


Just to be clear, i did follow all your instructions, and i did tried my best to solve it before wasting your precious time as if i forced you to answer me in the first place

I know you must be tired of answering users that don't know how to read a post properly, but that doesn't give you the right to speak to everyone in that allmighty passive-agressive tone, assuming people's actions with an arrogant and sarcastic actitude, as if you are any better than them.

Yes, i will take my requests to reddit, where they actually understand the concept of good-manners and humbleness.
Thank you so much for your wasted time! :slightly_smiling_face:

I understand i didn't use the right format, and i understand that this ended in nothing gained, but i still tried to be nice and even wanted to apologize despite your sarcasm and passive-agressiveness, but after you calling me out as if you were superior than me, i don't think i will apologize for anything, in fact, im happy that you spent that hour of your precious time with this! means that at least i got something to laugh about.