KDE 6 Cursor (and Possibly More) Themes Not Applying to All Windows Under Wayland

Greetings,

I have recently updated to KDE 6 and have noticed a weird issue with my cursor theme not being applied on top of all windows. As far as I can tell, windows running under XWayland are fine, but many windows running under Wayland do not respect the cursor theme or size. I did find this issue, but it didn’t seem to contain a general solution to this issue. I can’t tell exactly, but it also seems other theme aspects aren’t being correctly applied to various applications and things are going to kde default. So far, I have seen that the cursor theme is not being followed in octopi, any of the garuda apps, kitty, nor firedragon (when using the MOZ_ENABLE_WAYLAND=1 environment variable). I can provide pictures or more information if need be.

Garuda-inxi:

System:
  Kernel: 6.7.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=acc91bbd-51b8-4669-9368-f85ecd75b0a1 rw rootflags=subvol=@
    rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=5bb1f004-d544-4ddf-bfac-8a1cf21296d8 loglevel=3 ibt=off
  Desktop: KDE Plasma v: 6.0.1 tk: Qt v: N/A info: frameworks v: 6.0.0
    wm: kwin_wayland with: krunner vt: 1 dm: SDDM Distro: Garuda
    base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: ThinkPad W541 v: 1.0
    serial: <superuser required> Chassis: type: 9 serial: <superuser required>
  Mobo: LENOVO model: ThinkPad W541 v: 1.0 serial: <superuser required>
    BIOS: coreboot v: 4.20-410-g3e523b495c date: 06/17/2023
CPU:
  Info: model: Intel Core i7-4710MQ bits: 64 type: MT MCP arch: Haswell
    gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
    family: 6 model-id: 0x3C (60) stepping: 3 microcode: 0x28
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 2793 high: 3500 min/max: 800/3500 scaling:
    driver: intel_cpufreq governor: performance cores: 1: 3500 2: 2494 3: 2494
    4: 2494 5: 2877 6: 3500 7: 2494 8: 2496 bogomips: 39906
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
Graphics:
  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Lenovo
    driver: i915 v: kernel arch: Gen-7.5 process: Intel 22nm built: 2013 ports:
    active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2, VGA-1 bus-ID: 00:02.0
    chip-ID: 8086:0416 class-ID: 0300
  Device-2: NVIDIA GK107GLM [Quadro K1100M] vendor: Lenovo driver: nvidia
    v: 470.239.06 alternate: nouveau,nvidia_drm non-free: series: 470.xx+
    status: legacy-active (EOL~2024-09-xx) arch: Kepler code: GKxxx
    process: TSMC 28nm built: 2012-2018 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s ports: active: none empty: DP-3
    bus-ID: 01:00.0 chip-ID: 10de:0ff6 class-ID: 0300
  Device-3: Bison Integrated Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-12:4 chip-ID: 5986:026a
    class-ID: 0e02
  Display: wayland server: X.org v: 1.21.1.11 with: Xwayland v: 23.2.4
    compositor: kwin_wayland driver: X: loaded: modesetting,nvidia dri: crocus
    gpu: i915,nvidia display-ID: 0
  Monitor-1: eDP-1 res: 1920x1080 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: intel crocus drv: nvidia platforms: device: 0
    drv: nvidia device: 1 drv: crocus device: 3 drv: swrast gbm: drv: crocus
    surfaceless: drv: crocus wayland: drv: crocus x11: drv: crocus
    inactive: device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.0.2-arch1.2
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 4600 (HSW
    GT2) device-ID: 8086:0416 memory: 1.46 GiB unified: yes display-ID: :1.0
  API: Vulkan v: 1.3.279 layers: 4 device: 0 type: integrated-gpu name: Intel
    HD Graphics 4600 (HSW GT2) driver: mesa intel v: 24.0.2-arch1.2
    device-ID: 8086:0416 surfaces: xcb,xlib,wayland device: 1
    type: discrete-gpu name: Quadro K1100M driver: nvidia v: 470.239.06
    device-ID: 10de:0ff6 surfaces: xcb,xlib,wayland device: 2 type: cpu
    name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
    v: 24.0.2-arch1.2 (LLVM 17.0.6) device-ID: 10005:0000
    surfaces: xcb,xlib,wayland
Audio:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
    vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:03.0
    chip-ID: 8086:0c0c class-ID: 0403
  Device-2: Intel 8 Series/C220 Series High Definition Audio
    vendor: Lenovo 8 driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:8c20 class-ID: 0403
  Device-3: NVIDIA GK107 HDMI Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:0e1b class-ID: 0403
  API: ALSA v: k6.7.9-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Intel Ethernet I217-LM driver: N/A modules: e1000e port: 1040
    bus-ID: 00:19.0 chip-ID: 8086:153a class-ID: 0200
  Device-2: Intel Wireless 7260 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:08b2 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Bluetooth:
  Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-11:3 chip-ID: 8087:07dc
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 4 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 4.0 lmp-v: 6
    status: discoverable: no pairing: no
Drives:
  Local Storage: total: 931.51 GiB used: 34.37 GiB (3.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 3B6Q scheme: MBR
Partition:
  ID-1: / raw-size: 914.37 GiB size: 914.37 GiB (100.00%)
    used: 34.37 GiB (3.8%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-2: /home raw-size: 914.37 GiB size: 914.37 GiB (100.00%)
    used: 34.37 GiB (3.8%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-3: /var/log raw-size: 914.37 GiB size: 914.37 GiB (100.00%)
    used: 34.37 GiB (3.8%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-4: /var/tmp raw-size: 914.37 GiB size: 914.37 GiB (100.00%)
    used: 34.37 GiB (3.8%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 15.58 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 17.14 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda2 maj-min: 8:2
Sensors:
  System Temperatures: cpu: 47.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 16 GiB available: 15.58 GiB used: 4.39 GiB (28.2%)
  Processes: 326 Power: uptime: 9h 13m states: freeze,standby,mem,disk
    suspend: deep avail: s2idle,shallow wakeups: 3 hibernate: platform
    avail: shutdown, reboot, suspend, test_resume image: 6.18 GiB
    services: org_kde_powerdevil,upowerd Init: systemd v: 255
    default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1882 libs: 437 tools: octopi,paru pm: flatpak
    pkgs: 0 Compilers: clang: 17.0.6 gcc: 13.2.1 Shell: garuda-inxi
    default: Bash v: 5.2.26 running-in: kitty inxi: 3.3.33
Garuda (2.6.23-1):
  System install date:     2023-12-07
  Last full system update: 2024-03-09 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       <superuser required>
  Failed units:            
4 Likes

Running the listed command after installing the package results in the below error and the command freezes (has to be escaped via ctrl-c):

(/usr/lib/xdg-desktop-portal:598743): xdg-desktop-portal-WARNING **: 11:41:23.440: Choosing gtk.portal for org.freedesktop.impl.portal.Lockdown as a last-resort fallback

(/usr/lib/xdg-desktop-portal:598743): xdg-desktop-portal-WARNING **: 11:41:23.440: The preferred method to match portal implementations to desktop environments is to use the portals.conf(5) configuration file

(/usr/lib/xdg-desktop-portal:598743): xdg-desktop-portal-WARNING **: 11:41:23.561: Failed to create background monitor: Failed to own background monitor D-Bus name

(/usr/lib/xdg-desktop-portal:598743): xdg-desktop-portal-WARNING **: 11:41:23.562: No skeleton to export

Interestingly enough, even though the command failed, it fixed the cursor in firedragon (but the other apps are still bugged).

you could try logging out and logging back in or just restarting.

1 Like

I had the same problem when testing wayland. And before the post on the forum. I found as well a user on Firefox forum >

https://support.mozilla.org/bm/questions/1434500

Basically just installing it, and reload of the system afterwards fixed all the Text rendering weirdness and the cursor problems.

Regards,
S.

I tried between reboots and that didn’t fix the issue.

This is exactly what I did essentially, I installed through octopi tried the replace command, rebooted, then tried the replace command again and got the same error.

Can you provide a screenshot of the bugged apps? Which ones are it exactly?

1 Like

I provided a list in my initial post, as to providing screenshots, the only thing that is different is that the cursor seems to be defaulting to the adwaita theme with inconsistent cursor size. I will try to look through more apps to see if I find more.

So far:
The Garuda Apps (welcome, gamer, etc)
Octopi
Kitty terminal
The libreoffice suite

Edit: Also noticed on the sddm login screen.




Small update, most recent update to kitty v0.33.0 seems to have fixed the cursor issue for this application, the others are still bugged though.

Edit: Most recent update to libreoffice-fresh also fixed the issue there.

Make sure you are using cursors from the Plasma 6 theme manager and not old ones left over from plasma 5. Same for icons, and probably the rest. It is best just to clear out all the old plasma 5 theming files.

1 Like

Already did, even tried reinstalling the sweet cursors to no effect.

1 Like

@dr460nf1r3

Managed to fix the cursor issue by changing /usr/share/icons/default/index.theme to:

[Icon Theme]
Inherits=Sweet-cursors

which initially was inheriting Adwaita. Something still seems a little off about the appearance of Octopi and the Garuda Apps (may be a qt5 vs qt6 issue?), but thus far a full solution eludes me. This issue may not be an issue on fresh installs (i.e. with wayland/qt6 from the beginning) according to this post from which I obtained my current solution.

Edit: Might be better to put the same config in ~/.icons/default/index.theme instead according to KDE 6.5.6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.