Kate does not detect spellcheck backends

I like to confirm, that this is not just a configuration issue on my side, before I open a bug report.

My Kate does refuse to recognize any spellcheck library on my computer.

I tried hunspell, nuspell and enchant, all are supposed to work with Kate.

garuda-inxi
System:
Kernel: 6.5.7-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=4836c503-d2d0-481e-a632-f9ac2f82aebc rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.11 wm: kwin_wayland vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: HP product: HP EliteBook 820 G3 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: HP model: 807C v: KBC Version 85.61 serial: <superuser required>
UEFI: HP v: N75 Ver. 01.05 date: 03/22/2016
Battery:
ID-1: BAT0 charge: 27.5 Wh (78.3%) condition: 35.1/35.1 Wh (100.0%)
volts: 11.7 min: 11.4 model: Hewlett-Packard Primary type: Li-ion
serial: <filter> status: discharging
CPU:
Info: model: Intel Core i5-6200U bits: 64 type: MT MCP arch: Skylake
gen: core 6 level: v3 note: check built: 2015 process: Intel 14nm family: 6
model-id: 0x4E (78) stepping: 3 microcode: 0xF0
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 900 min/max: 400/2800 scaling: driver: intel_pstate
governor: powersave cores: 1: 900 2: 900 3: 900 4: 900 bogomips: 19200
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Hewlett-Packard
driver: i915 v: kernel arch: Gen-9 process: Intel 14n built: 2015-16 ports:
active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:1916 class-ID: 0300
Device-2: Cheng Uei Precision Industry (Foxlink) HP HD Camera
driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
bus-ID: 1-9:5 chip-ID: 05c8:0383 class-ID: 0e02
Display: wayland server: X.org v: 1.21.1.8 with: Xwayland v: 23.2.1
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: 0
Monitor-1: eDP-1 res: 1366x768 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: swrast surfaceless: drv: iris wayland: drv: iris x11:
drv: iris inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 520 (SKL GT2)
device-ID: 8086:1916 memory: 7.25 GiB unified: yes display-ID: :1.0
API: Vulkan v: 1.3.264 layers: 3 device: 0 type: integrated-gpu name: Intel
HD Graphics 520 (SKL GT2) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:1916 surfaces: xcb,xlib,wayland device: 1 type: cpu
name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403
API: ALSA v: k6.5.7-zen2-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.82 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Ethernet I219-V vendor: Hewlett-Packard driver: e1000e
v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:1570 class-ID: 0200
IF: enp0s31f6 state: down mac: <filter>
Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:24f3 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-7:3 chip-ID: 8087:0a2b
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.2
lmp-v: 8 status: discoverable: no pairing: no class-ID: 7c010c
Drives:
Local Storage: total: 894.26 GiB used: 22.27 GiB (2.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Patriot model: M.2 P310 480GB
size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: EDFM90.0 temp: 26.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37480G
size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 1103 scheme: GPT
Partition:
ID-1: / raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
used: 22.26 GiB (5.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
used: 22.26 GiB (5.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
used: 22.26 GiB (5.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
used: 22.26 GiB (5.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.42 GiB used: 5.25 GiB (70.8%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 40.0 C pch: 39.0 C mobo: N/A
Fan Speeds (rpm): N/A
Info:
Processes: 249 Uptime: 10h 49m wakeups: 2 Memory: total: 8 GiB note: est.
available: 7.42 GiB used: 5.69 GiB (76.7%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1491 libs: 377 tools: octopi,paru Shell: fish v: 3.6.1
running-in: yakuake inxi: 3.3.30
Garuda (2.6.17-1):
System install date:     2023-10-05
Last full system update: 2023-10-17 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

You have to install it manually , in my case i use Sonnet5 as an engine :

sudo pacman -S sonnet5

then quick reboot .

1 Like

I have sonnet5 installed as well (and question why its not in the dep list of Kate) :smiley:

@SGS Thanks for moving this thread to the apparently correct forum category.
As Kate belongs to KDE, and is even installed by default:

How am I able to distinguish between supported and unsupported next time?

Hi @anon71037787 , actually Kate’s spell check is just a mess , some times work some not , Its more of a KDE software issue ,To actually be able to distinguish between supported software and unsupported one in the forum just see if it belong (developed/maintained)to the garuda team in any way , like checking in app Help etc …

2 Likes

I doubt that Garuda develops KDE. If you mean only the software that was written by Garuda itself, I doubt that as well, as there are no software stacks for anything beyond KDE to speak of, and there are categories for other DEs still.

And I just like to confirm - as written in the first line - that this occurs not just on my machine.
It is most likely something to be reported on the KDE bug tracker, but I like that somebody reproduces it first, to avoid posting an issue there unnecessarily.

So, can you reproduce it?
:slightly_smiling_face:

This forum is not a general technical support forum, even if we try to help with any problem.

That’s easy, everything that has nothing to do with Garuda Linux is unsupported. :slight_smile:

KDE is provided, but not developed, by us.

If your TV is running a bad program, do you write to Grundig (LG, Sony, …), or to the TV station? :wink:

So if any software shipped with Garuda Linux is buggy, you should contact the manufacturer.

Well, I did not ask for technical assistance. I asked for somebody to reproduce the problem. :slight_smile:

Sure. The point stands: In order to do that, I look for other people to reproduce the problem.

KDE-bugtracker?
Github/Gitlab issue page?

1 Like

I guess Nate and the others welcome, that simple things like that are done by the community.

The difficulty level is something, that you would assume to be doable by one of the most popular Linux distros and its users.

Do you see the value of easier tasks being done by people who are not yet able to contribute to the complex issue of debugging complicated C++ code, when they can install software and look into a menu instead?

Casuals are more here, than on any other page.

Define simple.
The best thing is to ask him yourself. :arrow_down:

And if it’s really easy, why haven’t you solved it yet?
Of course, it’s easier to let others search for you.
There are certainly beginners who can be helped on how best to solve problems, you are certainly not one of them.
For the others

As it is common by members of this forum, have you simply not understood what this post is all about.

I wrote multiple times now, that this is about reproducing a bug.
This is not about fixing an issue. I clearly state, that I like to ensure, that this is a general issue.

How is this so difficult to understand?

We are digressing from the (second) topic. It was originally about moving your post.

BTW, Garuda Linux is not Arch Linux.

1 Like

Everyone is pointing at some other entity.

It is either the packaging, in which case Garuda is absolutely Arch.
And Arch would of course not answer on my report.

And if the packaging is not the cause, then it might be either related to the config or is a bug in the source code.

You seem to refuse to understand, that Garuda did fail and continues to fail, to maintain a community in a sense, that it becomes actionable and gains contributors.

Despite that, some parts of the team self admittedly say that the distro did not succeed in doing so.

So it is not possible to develop the distro as a community.

It is impossible to post about obvious distro-related issues, without having people commenting in a manner, that clearly shows that they failed to read the initial post conclusively.

It is also impossible, to find a place where someone might report an issue that is in the clear opportunity for a distro to conclude, as it is the topmost layer of the development chain.

Particularly from the perspective of a casual user.

The only thing that this community does seem to achieve, is to discourage others from contributing.

You clearly understand how to build a distro, and you clearly failed to build a community.

And to moderate one.

In addition to Sonnet and Hunspell, you need to install one of the Hunspell dictionaries. https://docs.kde.org/stable5/en/plasma-desktop/kcontrol/spellchecking/index.html#spellchecker

You can see all of the available dictionaries like this:

pacman -Ss hunspell

If you get that part straightened out and it still doesn’t work, SGS is right: to get it fixed you’ll have to raise an issue here so the developers can take a look.

What on Earth are you on about? You are having another whinge, that much is clear, but other than that your meaning is just indecipherable.

Is this about Librewish stepping back from the project? My understanding is they made that decision tof ocus on their career–they haven’t been chased off by our bad attitudes or something like you make it sound.

Where is this so-called failure to maintain a community? Any project that is run by a bunch of volunteers on their free time will have people come and go as their interests or availability changes over time, whether you are talking about writing code for a hobby Linux distro or scooping poop at the local animal shelter. That isn’t indicative of a failure to maintain a community, or failure of anything else really.

You may be misinterpreting the “unsupported” category. Opening issues like this one–about software you are choosing to use that has nothing to do with Garuda Linux–is perfectly fine. The forum help is available on a best-effort basis, and if someone knows how to resolve the problem you are having the community is typically forthcoming with that kind of assistance.

If the issue you are having is a software bug, etc (as opposed to a configuration issue where some guidance is needed), then someone will likely help direct you to a more appropriate place to seek assistance, like this:

If this topic you have opened is your idea of “contributing”, then yes: we do try to discourage these types of contributions. slash7 with Amy Hoy » Blog Archive » Help Vampires: A Spotter’s Guide

4 Likes

I’m closing this topic before it devolves any further.