Issues with FireDragon

After using FireDragon browser for a while, I'm seeing a couple of issues with it.

First, font rendering is bad, or at least, not comparable to browsers in Windows, or even other browsers in Linux. It seems to be a common issue with FireFox on Linux. Going in "about:config" and editing gfx.font_rendering.ahem_antialias_none helped a lot, but still.

Just did a quick comparison of FireFox vs Chrome in Linux. The Chrome text is more balanced and easier to read.

Comparison of a Wikipedia page: FireFox on top, Chrome below (is it using a different font?)
Browser-Font.png

Second, PayPal refuses to login. Probably because of some privacy restriction settings?

Third, Ventusky.com doesn't render properly.

Fourth... and the most annoying. For privacy, it doesn't store my browsing history, but that means that it doesn't remember my URLs either to auto-fill them, and I need to type all the full URLs manually. One thing I did to mitigate that a "little bit" is adding bookmarks for all the main websites I'm using regularly so that it can auto-fill these URLs. If it could at least use LastPass' list of websites to auto-fill the URLs, that would be great. What are my options here?

System:
Kernel: 5.16.1-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=58203bda-e2e2-4c32-a006-c91d933cad4e rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 intel_iommu=on
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Acer product: Predator PH315-53 v: V1.01
serial: <superuser required>
Mobo: CML model: QX50_CMS v: V1.01 serial: <superuser required>
UEFI: Insyde v: 1.01 date: 04/27/2020
Battery:
ID-1: BAT1 charge: 43.7 Wh (100.0%) condition: 43.7/58.8 Wh (74.4%)
volts: 16.4 min: 15.4 model: SMP AP18E7M type: Li-ion serial: <filter>
status: Full
CPU:
Info: model: Intel Core i7-10750H bits: 64 type: MT MCP arch: Comet Lake
family: 6 model-id: 0xA5 (165) stepping: 2 microcode: 0xEA
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 3764 high: 4591 min/max: 800/5000 scaling:
driver: intel_pstate governor: performance cores: 1: 3641 2: 3365 3: 4500
4: 1814 5: 4505 6: 4529 7: 4591 8: 2047 9: 4519 10: 2680 11: 4485
12: 4503 bogomips: 62399
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CometLake-H GT2 [UHD Graphics]
vendor: Acer Incorporated ALI driver: i915 v: kernel bus-ID: 00:02.0
chip-ID: 8086:9bc4 class-ID: 0300
Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile]
vendor: Acer Incorporated ALI driver: nvidia v: 495.46
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f15
class-ID: 0300
Device-3: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 1-5:5
chip-ID: 0408:a061 class-ID: 0e02
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: modesetting,nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 506x285mm (19.9x11.2")
s-diag: 581mm (22.9")
Monitor-1: HDMI-1-0 res: 1920x1080 hz: 60 dpi: 40
size: 1210x680mm (47.6x26.8") diag: 1388mm (54.6")
OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.3.4
direct render: Yes
Audio:
Device-1: Intel Comet Lake PCH cAVS vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:06c8 class-ID: 0403
Device-2: NVIDIA TU106 High Definition Audio driver: snd_hda_intel
v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
Device-3: Texas Instruments PCM2900B Audio CODEC type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1.2:10
chip-ID: 08bb:29b0 class-ID: 0300
Sound Server-1: ALSA v: k5.16.1-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.43 running: yes
Network:
Device-1: Intel Comet Lake PCH CNVi WiFi vendor: Rivet Networks
driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Realtek vendor: Acer Incorporated ALI driver: r8169 v: kernel
port: 3000 bus-ID: 07:00.0 chip-ID: 10ec:2600 class-ID: 0200
IF: enp7s0 state: down mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
IF-ID-2: virbr0 state: down mac: <filter>
IF-ID-3: virbr1 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:6 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 1.63 TiB used: 1 TiB (61.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: PC SN730 SDBQNTY-512G-1014 size: 476.94 GiB block-size:
physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
serial: <filter> rev: 11101100 temp: 24.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS721010A9E630
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: A3J0
scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT275MX300SSD4
size: 256.17 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: R060 scheme: GPT
Partition:
ID-1: / raw-size: 376.95 GiB size: 376.95 GiB (100.00%)
used: 188.78 GiB (50.1%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:2
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 51.2 MiB (53.4%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 376.95 GiB size: 376.95 GiB (100.00%)
used: 188.78 GiB (50.1%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:2
ID-4: /var/log raw-size: 376.95 GiB size: 376.95 GiB (100.00%)
used: 188.78 GiB (50.1%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:2
ID-5: /var/tmp raw-size: 376.95 GiB size: 376.95 GiB (100.00%)
used: 188.78 GiB (50.1%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.46 GiB used: 58.2 MiB (0.4%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 82.0 C pch: 64.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 396 Uptime: 1d 4h 23m wakeups: 1 Memory: 15.46 GiB
used: 5.82 GiB (37.6%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1715 lib: 490 Shell: fish
v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.11

Yes since the recent update I’ve noticed issues here and there that I shove it off right now. I’ve been using my other browser that I use till they get them ironed out now maybe come back the graphics are cool I like it on the update but there is issues since probably last week

We had an issue like this with Gitlab in the past, which was ultimately solved by Gitlab itself. It might be the same with PayPal :thinking:

Maybe try setting your device font as the one used in the settings page?

But you did explore the settings and checked the right checkboxes regarding keeping history?

4 Likes

Which are these? Shoving off is easy :wink:

3 Likes

whoogle doesn't work as before the update it did first off. I just selected another search engine and it has no issues whether it is Google Duck duck Go bing etc... only whoogle and searx.

So I decided since I hate google and M$ bing to use Duck duck Go for the time, and also use Falkon browser which is my second browser.

like I stated before " I shove it off right now" which means I gave little care as the issue isn't that big for me as I have a alternative to use. When the quirks are worked out I'll go back to using the default.

It seems the same for me @Bubby regarding Whoogle. Even after following config changes on its github page it did not help. So DDG for me now.

1 Like

For PayPal, I could "fix" the problem by using another browser.

Browsing history? Looking at the settings, it is set to "remember browsing and download history", so I'm not sure why it's not auto-filling the URLs then!

Whoogle was very slow for me yesterday; today seems better.

Oh, I misunderstood you then. You can try removing "SearchSuggestEnabled": false, from /usr/lib/firedragon/distribution/policies.json :eyes:

3 Likes

Wow that fixed it!

2 Likes

I'll just remove that value from the config in the next build to let the user choose the preferred behaviour then :slight_smile:

5 Likes

btw... maybe a better way, if editing policies.json, would be to copy that file into /etc/firedragon/policies/policies.json and editing it there.

That file will take prevelence to the other one.

1 Like

You could also change the default value of gfx.font_rendering.ahem_antialias_none

Wikipedia page wasn't a good comparison as it was using a different font.

Comparing this forum page between FireDragon and Chrome in Linux. Very similar. Perhaps slightly more anti-aliasing in Chrome, for better or worse. Comparing with Edge in Windows. Text in like this uses a different font, but the rest of the text has the same font, but displays tall letters a bit taller, and the letters are drawn very slightly "thicker", it doesn't look bolder, but it's a bit easier to read in Windows.

When error pages appear in FireDragon, it displays large thin text; that text is particularly distorted!

Anything else can be done to improve fonts?

1 Like

Totally true on my end as well. It also makes it look like reddish shadowed in that situation.

This is what errors look like

Browser-Error.png

Also, Whoogle is currently giving this

Error

Instance has been ratelimited

that generally is a freetype issue, rgb subhinting and lcd filter.

just a few days had the same issue, and it wasn't with FireDragon.

And what setup you recommend? Does it vary from monitor to monitor?

Considering I take a screenshot and you view it on a separate monitor... it doesn't look monitor-dependent!

Well... if you really want to get rid of that, just disable subpixel hinting.

Before check if using the right lcdfilter, since lcdnone makes that happen everywhere. lcdfilter light and default do make it almost hidden.

So:

first check if using lcdfilter = lcddefault. if so,
disable subpixel hinting.

Can be done through kde settings (or gnome-tweaks) or through managing the symlinks at /etc/fonts/conf.d.

at the end, you can check it with:

fc-match -v | rg -e hint -e rgb -e filter

(replace rg with grep if rg not available ... somehow).

It should say lcdfilter: 1(i)(w) ( means lcdfilter default )
and rgba: 1(i)(w) being enabled and rgb , and 0, meaning none (no subpixel hinting).

EDIT: also, as a workaround, you can set firefox/firedragon to only use your specified fonts, and ignore the webpage's font preferences. that might also fix it.

3 Likes

Hey not bad, man!!

Although mine isn't called 'lcdfilter' but 'hintstyle', I simply disabled totally Sub-pixel rendering, while keeping Antialising (that last one is a must) and it improved quite a lot! Not just FireDragon but in Kate and everywhere else. Hinting (None, Medium, Full, etc.) does not seem to have easy to see effect so I guess this one for me isn't much important. I left it at Full.

I couldn't test the Whoogle error page as this time it worked through! loll In German though, even though I selected English but it worked.

It's funny cuz on my machine with nvidia proprietary driver I do have RGB Sub-pixel Rendering and the quality is top notch no matter the monitor I use. On my other machine with AMD integrated GPU with Nouveau driver it's not good and I needed to disable them.

I ended up with this setup:

hintstyle: 0(i)(w)
hinting: False(w)
autohint: False(s)
rgba: 5(i(w)
fonthashint: True(w)

So I guess if Sub-pixel Rendering doesn't harm you it's fine to keep it, but if you have fonts rendering issues, then I hope this helps others playing around with these configs and finding the best match.

Tnx @alexjp :smiley:

2 Likes

this means you have hintstyle = none, hinting: disabled, autohint: disabled, and subpixel hinting disabled also.

you do have a lcdfilter, but doesnt seem active. Check if you have /etc/fonts/conf.d/11-lcdfilter-default.confsymlink
if not, do:

cd /etc/fonts/conf.d
ln -s /usr/share/fontconfig/conf.avail/11-lcdfilter-default.conf

for me, good results are hintstyle: none or slight. I don't like full.

you don't need lcdfilter if you don't have subpixel hinting. but if you enable back subpixel hinting, do check lcdfilter !

Generally, hintstyle:
none/0 -> means that fonts will be displayed how they should be. but if your monitor has low DPI, they will show alot of ?? blur ?? dunno how to describe it.

slight and up modify the natural presentation of the font, to make it more ?? "streamlined" ??

So the hintstyle will definitely be about your tastes and monitor DPI ! (well, i guess subpixel hinting too)

1 Like