Issues after system update on 17/05/2021

So I updated my system yesterday and used it all day without rebooting. Nothing stood out in particular in pacman. I didn't see anything in this section of the forum either. However when I went to boot up my laptop (it defaults to linux-lts and thats what I use daily) the boot skips over the garuda loading logo and goes straight to the black screen with Loading linux-lts kernel and Loading initial ramdisk output and gets stuck there. Atm I am using the regular linux kernel and it boots just fine. However since I cannot even get to a tty I don't know how to post logs.

Another smaller issue I noticed is that neofetch got uninstalled somehow. I know I haven't uninstalled it. It was installed just a few hours ago then I open terminal and the output says neofetch can be found in these packages with a list of teh repos. I would like to add that I have since installed it from official repos and I see the new logo being displayed. Though it isn't color coded like before.

Only thing I did today was use Garuda Assitant to Apply New Configs as I saw that being suggested in pacman output after Syu run for a couple of days. Also ran btrfs-trim a few times from there as well.

sudo inxi -Fxxxza output

System:    Kernel: 5.12.4-arch1-2 x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux root=UUID=6bffdc79-d9cf-4de9-a3aa-58bbfb0e7a9c rw [email protected] 
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 
intel_iommu=on i915.enable_gvt=1 kvm.ignore_msrs=1 i915.enable_guc=0 
Console: tty pts/1 wm: kwin_x11 DM: SDDM Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: Dell product: G3 3590 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
Mobo: Dell model: 0DKM3T v: A00 serial: <filter> UEFI: Dell v: 1.8.0 date: 11/11/2019 
Battery:   ID-1: BAT0 charge: 42.2 Wh (100.0%) condition: 42.2/51.0 Wh (82.8%) volts: 12.7 min: 11.4 model: BYD DELL M4GWP98 
type: Li-poly serial: <filter> status: Full 
CPU:       Info: 6-Core model: Intel Core i7-9750H socket: BGA1440 (U3E1) note: check bits: 64 type: MT MCP arch: Kaby Lake 
note: check family: 6 model-id: 9E (158) stepping: A (10) microcode: DE cache: L1: 384 KiB L2: 12 MiB L3: 12 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62431 
Speed: 4283 MHz min/max: 800/4500 MHz base/boost: 2600/2600 volts: 1.2 V ext-clock: 100 MHz Core speeds (MHz): 
1: 4283 2: 4403 3: 4389 4: 4401 5: 4391 6: 4400 7: 4400 8: 4395 9: 4352 10: 4239 11: 4173 12: 4337 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
Type: meltdown mitigation: PTI 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e9b
class-ID: 0300
Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: Dell driver: nvidia v: 465.27
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:2191 class-ID: 0300
Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-5:2 chip-ID: 0bda:5521 class-ID: 0e02
serial: <filter>
Display: server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: modesetting,nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.1.0 direct render: Yes
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: sof-audio-pci-intel-cnl
alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0401
Device-2: NVIDIA TU116 High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 01:00.1
chip-ID: 10de:1aeb class-ID: 0403
Sound Server-1: ALSA v: k5.12.4-arch1-2 running: yes
Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-3: PulseAudio v: 14.2 running: yes
Sound Server-4: PipeWire v: 0.3.27 running: no
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8169 v: kernel port: 3000
bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Dell driver: ath10k_pci v: kernel
port: 3000 bus-ID: 04:00.0 chip-ID: 168c:0042 class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-14:3 chip-ID: 0cf3:e009 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 1.38 TiB used: 1.15 TiB (83.7%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN520 NVMe WDC 512GB size: 476.94 GiB
block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 rotation: SSD serial: <filter> rev: 20220012
temp: 57 Celsius C scheme: MBR
SMART: yes health: PASSED on: 159d 22h cycles: 1,292 read-units: 50,309,450 [25.7 TB]
written-units: 75,494,895 [38.6 TB]
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172 family: Mobile HDD size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B sata: 3.1 speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: ACM1
temp: 40 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 2y 53d 8h cycles: 3344 read: 52.37 TiB written: 38.5 TiB Old-Age:
g-sense error rate: 330 Pre-Fail: attribute: Spin_Retry_Count value: 100 worst: 100 threshold: 97
Partition: ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 431.08 GiB (90.4%) fs: btrfs block-size: 4096 B
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 568 KiB (0.2%) fs: vfat block-size: 512 B
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 431.08 GiB (90.4%) fs: btrfs block-size: 4096 B
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 431.08 GiB (90.4%) fs: btrfs
block-size: 4096 B dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 431.08 GiB (90.4%) fs: btrfs
block-size: 4096 B dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Alert: No swap data was found.
Sensors:   System Temperatures: cpu: 64.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 337 Uptime: 4m wakeups: 1821 Memory: 15.43 GiB used: 3.21 GiB (20.8%) Init: systemd v: 248
tool: systemctl Compilers: gcc: 11.1.0 clang: 11.1.0 Packages: pacman: 1775 lib: 546 Shell: fish (sudo) v: 3.2.2
default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.04

For the little it will count, I just upgraded to the 5.10.37-1-lts kernel with no problems.
So I would guess that your problem could be related to the update process itself or to the Nvidia drivers?
Maybe you could review yesterday's pacman.log to see if anything important went unnoticed.

As for booting to tty, have you tried with ending grub parameter 3 on your lts line?
If you could reach the tty you could try startx, see the logs and maybe reinstall or recompile what is needed for the Nvidia drivers (I've never had Nvidia GPU's so I don't know much about it...)

1 Like

I am still on 5.10 lts . I will get back after checking pacman logs.

Seems the lts kernel got updated yesterday from 5.10.36 to 5.10.37.

1 Like

Sorry, you're right, I wrote too quickly and maybe got confused with the zen kernel, updated alongside: I've got 5.10.37-1-lts
I'm updating now my post above, just in case.

Can you elaborate this please? Which parameter do I set to 3? log-level is already at 3

Sorry, I didn't mean the log level: when on the grub string for your lts kernel (i.e. pressing E when on that line), go to the line starting with linux and simply add a 3 at the end, then ctrl+x

Will report back soon after trying. Tried to add 3 to the very end and the linux line and nothing changed. Also idk if you noticed but the last parameter passed in grub is i915.enable_guc which is set to 0.

I don't have this one actually, although I don't think this is the root cause of you problem.
Just for the record, my "Linux line" is:

/@/boot/vmlinuz-linux-lts root=UUID=xxx rw [email protected]  quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3

Anyway, sorry, I'm running out of ideas...

I have additional parameters passed because I run vfio.

1 Like

So you have a system. No panic. :+1:

Update with pacman in terminal and stay there to watch messages.
If there is no kernel update, do it yourself.

sudo mkinitcpio -P
sudo update-grub

Reboot to lts to check.

If it fails, reboot to linux and get journal errors from previous boot.

man journalctl
4 Likes

I ran mkinitcpio and update-grub quite a bit yesterday as I was fiddling around with my vfio setup so kernels are up-to-date.

sudo journalctl -b -1 --system I ran this with both -1 and -2 but it only shows the successful boot entries. No mention of the failed lts boot. I tried to boot into lts right before I ran the command.

Run pacdiff and properly merge new settings, if you have new files.
Post which files were not merged yet.

Usually linux-lts is the stable/safe alternative for linux issues.
It's surprising you face the opposite. :man_shrugging:

3 Likes

Tell me about it. I had no idea lts would even have such problems. Though I just updapted my system and it seems there is a new lts version out. I will try to boot into that first.

Edit: Just checked through the entirety of pacman.log for that day and nothing seems different from usual. The logs are fine. I tried looking through `journalctl --since"2021-05-17" but there was too much text to go through and I don't even know what specifically to look out for to filter it.

This is left in complain :slightly_smiling_face:

2 Likes

I have no idea what you mean by this. Anyways the update to kernel 5.10.38 worked and I can boot into lts again. As for pacdiff:

==> pacnew file found for /usr/lib/librewolf/librewolf.cfg
:: (V)iew, (S)kip, (R)emove pacnew, (O)verwrite with pacnew, (Q)uit: [v/s/r/o/q] O
renamed '/usr/lib/librewolf/librewolf.cfg.pacnew' -> '/usr/lib/librewolf/librewolf.cfg'
==> pacnew file found for /etc/libvirt/qemu.conf
:: (V)iew, (S)kip, (R)emove pacnew, (O)verwrite with pacnew, (Q)uit: [v/s/r/o/q] O
renamed '/etc/libvirt/qemu.conf.pacnew' -> '/etc/libvirt/qemu.conf'
==> pacnew file found for /etc/pacman.d/mirrorlist
:: (V)iew, (S)kip, (R)emove pacnew, (O)verwrite with pacnew, (Q)uit: [v/s/r/o/q] o
renamed '/etc/pacman.d/mirrorlist.pacnew' -> '/etc/pacman.d/mirrorlist'
==> pacnew file found for /etc/plymouth/plymouthd.conf
:: (V)iew, (S)kip, (R)emove pacnew, (O)verwrite with pacnew, (Q)uit: [v/s/r/o/q] o
renamed '/etc/plymouth/plymouthd.conf.pacnew' -> '/etc/plymouth/plymouthd.conf'
==> pacnew file found for /etc/systemd/system.conf
:: (V)iew, (S)kip, (R)emove pacnew, (O)verwrite with pacnew, (Q)uit: [v/s/r/o/q] o
renamed '/etc/systemd/system.conf.pacnew' -> '/etc/systemd/system.conf'
==> pacnew file found for /etc/systemd/user.conf
:: (V)iew, (S)kip, (R)emove pacnew, (O)verwrite with pacnew, (Q)uit: [v/s/r/o/q] o
renamed '/etc/systemd/user.conf.pacnew' -> '/etc/systemd/user.conf'

I realize now that I just ended up resetting my mirrorlist by running pacdiff.

Blindly overwriting with new files is completely out of scope of the pacdiff utility.
I hope you know what you are doing :man_shrugging:
(Edit: I had not read your latest post... go figure... :laughing: )

The good news is lts is back!, so we keep that :wink:

1 Like

Just how much does pacdiff control in terms of configs? Because I seem to have lost my cool garuda loading screen that happens while booting.

Check in /etc/plymouth/plymouthd.conf.
E.g. I have Theme=dr460nized there, and that theme should be installed, but I guess it is by default

1 Like

I just reloaded a snapshot.