Is there a way to have noise reduction with Pipewire?

I switched back to PulseAudio because noise reduction is not working with Pulseeffects or Noise torch which the latter is still experimental for Pipewire. Maybe both are?

But this is my first experience with Piepewire so I don't know if there are easier or alternatives to have noise reduction using Piepewire.

Pulse effects freeze religiously and Noise torch is plain not working when I test it.

TY

As far as I know not many great noise reduction plugins are out there for pipewire, You could always pulseaudio, INstall it with
sudo pacman -S pulseaudio
Do note- Please don't mess with all this unless you wan't broken audio, because there is a slight risk of breaking some stuff. Or just use the garuda assistant tool which is included

Edit- Ijust noticed you swapped it out

3 Likes

I'm trying again. Installed Pipewire bt with trial and error because the assistant seems to have issues with switching back to pipewire.

When all was installed I didn't have settings for devices and I ran systemctl enable --user pipewire-pulse.service and logged out and setting where there.

The noise reduction work but I'm getting some weird behavior with Discord, it starts repeating what I say incrementing the volume until is outputs cracked sound. I think it's the sound level not adjusted well, also WebRTC is the plugin for Discord, added voice detection and i's better now. Maybe it's just a matter of setting snad not inherently bugs.

Luckily Zoom and Discord have their own plugins but I may need this for other Web based interactions.

Weird, it works for me. rnnoise is brought in by default, so it likely just needs configuring correctly within PulseEffects, e.g.:

3 Likes

Your can use easyeffects its the alternative of pulseeffect and the interface is also same

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.