[Intervention potentially required] Python 3.10 and you

Thanks, I installed Garuda a few weeks ago on my laptop and I like it a lot.

2 Likes

Can you set your avatar?
Maybe I can then remember you :slight_smile: , or you are the virus? :smiley:

5 Likes

System borked after garuda-update. Can only access tty via ctrl alt f2 after reboot. Attempted to - Syu Optimus-manager. Get an error "failed to synchronize all databases (unable to lock database)

and search in forum about "black screen"

2 Likes

Just a heads up if you use third-party repo in kodi 19 you will most likely have to rebuild the extension. Most of the ones I used are build with a older version of python and @TNE post a tool that I will help your process.

If you're on a laptop with Optimus-manager you'll want to reinstall with Pacman -Syyu. If you reboot before hand you'll get the black screen and have to manually connect to wifi (damn near impossible) or use ether net cable (what I ended up doing).

OT.

Just a heads up, third party sketchy Kodi extensions is one of the most likely attack vectors for infecting a Linux machine with malware.

7 Likes

What virus?

Let me whoogle that for you :smiley:

https://duckduckgo.com/?q=eicar+virus&t=ffsb&ia=web

ohh, :duck: :duck: :walking_man:

7 Likes

You got that one!

hey, i reinstalled aur packages (with yay) and after built myself from git but Gkraken and other still don't work, what to do?

If you have reinstalled or used 'garuda-update' in terminal, and it still doesn't work, then you have to track down the maintainers of the package, usually a git page, and open an issue with them. Site the python 3.10 links, etc. and your output from terminal running the app or any info you can give them....then wait. :upside_down_face:

3 Likes

welp, someone else already posted it... the dev is already working on it

2 Likes

When I try and run garuda-update or update it just says error: target not found: garuda-update anyone know why?

pacman -Qi garuda-update

If empty than

sudo pacman -Syu garuda-update

Thank you for the help! Somehow chaotic aur disappeared when I readded it everything seemed to work.

1 Like

I ran pacman -Syu and garuda-update. However mpv aborts with the following error:

mpv: error while loading shared libraries: libpython3.9.so.1.0: cannot open shared object file: No such file or directory

My mpv is provided by the package "mpv-full", version 0.34.0-1

Am I missing a step?

Edit:
The error occurs, when mpv is run after updates are finished. Not during the update process.

I fixed this by downloading the latest python39 package and telling pacman to install it: sudo pacman -U python-3.9.9-1-x86_64.pkg.tar.zst
The 3.10 version is used by default, but some applications (az, for instance) still require 3.9 dependencies, which will now be present.

1 Like

Aaaaaaah don't do this! Every other package will behave this way then. Seems like we didn't catch mpv-full while rebuilding :eyes: (or is this a compatibility package?)

2 Likes

I don't know where to find the info of it being an compatibility package. Here is the information pacman provides:

╭─[email protected] in ~ took 8s
╰─λ pacman -Qi mpv
Name                     : mpv-full
Version                  : 0.34.0-1
Beschreibung             : A free, open source, and cross-platform media player (with all possible libs)
Architektur              : x86_64
URL                      : https://mpv.io/
Lizenzen                 : GPL
Gruppen                  : Nichts
Stellt bereit            : mpv
Hängt ab von             : cmocka  ffmpeg  lcms2  libcdio-paranoia  libgl  libxss  libxinerama  libxv
libxkbcommon  libva  wayland  libcaca  desktop-file-utils  hicolor-icon-theme
xdg-utils  lua52  mujs  libdvdnav  libxrandr  jack  rubberband  uchardet
libarchive  zlib  vapoursynth  openal  vulkan-icd-loader  shaderc  libplacebo
zimg  spirv-cross  libsixel
Optionale Abhängigkeiten : youtube-dl: for video-sharing websites playback
nvidia-utils: for hardware accelerated video decoding with CUDA [Installiert]
Benötigt von             : olivia
Optional für             : Nichts
In Konflikt mit          : mpv
Ersetzt                  : Nichts
Installationsgröße       : 5,25 MiB
Packer                   : UFSCar HPC Builder <[email protected]>
Erstellt am              : Di 02 Nov 2021 14:03:12 CET
Installiert am           : Di 14 Dez 2021 20:49:10 CET
Installationsgrund       : Ausdrücklich installiert
Installations-Skript     : Nein
Verifiziert durch        : Signatur
1 Like