Intel Wireless 8265 / 8275 card not working

Hello so i tried the garuda network assistant but its doesnt show any driver i installed the driver manually but it doesnt work lets keep it short here is my inxi -Faz

Kernel: 6.6.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=b7db5aca-6a36-4084-baa3-3af99917d4e0 rw rootflags=subvol=@
quiet resume=UUID=56308c5f-6524-4d0a-98e8-8bfda1961225 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 wm: kwin_wayland dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Convertible System: HP product: HP EliteBook x360 1030 G2 v: N/A
serial: <filter> Chassis: type: 31 serial: <filter>
Mobo: HP model: 827D v: KBC Version 44.79 serial: <filter> UEFI: HP
v: P80 Ver. 01.45 date: 12/15/2022
ID-1: BAT0 charge: 12.4 Wh (29.8%) condition: 41.6/57.2 Wh (72.7%)
volts: 10.7 min: 11.6 model: Hewlett-Packard Primary type: Li-ion
serial: <filter> status: discharging cycles: 429
Info: model: Intel Core i7-7600U socket: BGA1356 (U3E1) note: check bits: 64
type: MT MCP arch: Amber/Kaby Lake note: check gen: core 7 level: v3
note: check built: 2017 process: Intel 14nm family: 6 model-id: 0x8E (142)
stepping: 9 microcode: 0xF4
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 770 high: 800 min/max: 400/3900 base/boost: 2700/3900
scaling: driver: intel_pstate governor: powersave volts: 0.8 V
ext-clock: 100 MHz cores: 1: 776 2: 800 3: 705 4: 800 bogomips: 23199
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Type: gather_data_sampling mitigation: Microcode
Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: IBRS
Type: spec_rstack_overflow status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
RSB filling, PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Device-1: Intel HD Graphics 620 vendor: Hewlett-Packard driver: i915
v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:5916 class-ID: 0300
Device-2: Cheng Uei Precision Industry (Foxlink) HP HD Camera
driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
bus-ID: 1-7:3 chip-ID: 05c8:080b class-ID: 0e02 serial: <filter>
Device-3: Cheng Uei Precision Industry (Foxlink) HP IR Camera
driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
bus-ID: 1-8:4 chip-ID: 05c8:0396 class-ID: 0e02 serial: <filter>
Display: server: X.Org v: 23.2.3 with: Xwayland v: 23.2.3
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :1 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: InfoVision Optronics/Kunshan 0x0535 built: 2017
res: 1920x1080 hz: 120 dpi: 168 gamma: 1.2 size: 290x170mm (11.42x6.69")
diag: 337mm (13.3") ratio: 16:9 modes: 1920x1080
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 620 (KBL GT2)
device-ID: 8086:5916 memory: 15.13 GiB unified: yes
API: Vulkan v: 1.3.269 layers: 9 device: 0 type: integrated-gpu name: Intel
HD Graphics 620 (KBL GT2) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:5916 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
API: ALSA v: k6.6.7-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.0 status: n/a (root, process) with:
1: pipewire-pulse status: active 2: wireplumber status: active
3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Wireless 8265 / 8275 driver: N/A modules: iwlwifi pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 3a:00.0 chip-ID: 8086:24fd
class-ID: 0280
Device-2: ASIX AX88179 Gigabit Ethernet driver: cdc_ncm type: USB rev: 3.2
speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 4-1:2 chip-ID: 0b95:1790
class-ID: 0a00 serial: <filter>
IF: enp57s0u1c2 state: up speed: 100 Mbps duplex: half mac: <filter>
Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-9:5 chip-ID: 8087:0a2b
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 4.2
lmp-v: 8 status: discoverable: no pairing: no class-ID: 7c0000
Local Storage: total: 1.16 TiB used: 21 GiB (1.8%)
ID-1: /dev/mmcblk0 maj-min: 179:0 model: EE4S5 size: 238.75 GiB
block-size: physical: 512 B logical: 512 B type: Removable tech: SSD
serial: <filter> scheme: MBR
SMART Message: Unknown smartctl error. Unable to generate data.
ID-2: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: PC300 NVMe 1TB
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 20005A00 temp: 28.9 C
scheme: GPT
SMART: yes health: PASSED on: 2y 317d 14h cycles: 285
read-units: 15,048,949 [7.70 TB] written-units: 55,406,134 [28.3 TB]
ID-1: / raw-size: 936.52 GiB size: 936.52 GiB (100.00%) used: 21 GiB (2.2%)
fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 936.52 GiB size: 936.52 GiB (100.00%)
used: 21 GiB (2.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-4: /var/log raw-size: 936.52 GiB size: 936.52 GiB (100.00%)
used: 21 GiB (2.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-5: /var/tmp raw-size: 936.52 GiB size: 936.52 GiB (100.00%)
used: 21 GiB (2.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.5 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
ID-2: swap-2 type: partition size: 17.05 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
System Temperatures: cpu: 50.0 C pch: 41.5 C mobo: N/A
Fan Speeds (rpm): N/A
Processes: 210 Uptime: 12m wakeups: 0 Memory: total: 16 GiB
available: 15.5 GiB used: 3.75 GiB (24.2%) igpu: 32 MiB Init: systemd v: 255
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1861 libs: 560 tools: octopi,pamac,paru Shell: Bash (su)
v: 5.2.21 running-in: konsole inxi: 3.3.31

so i checked that out and i find a lot of people that have Intel Wireless 8265 / 8275 got the same issue as me

If you’re dual booted, could be this. Though I can’t tell from the inxi.

Disabling fast startup, and properly shutting down PC may help if that’s the case.

1 Like

no dual booting also fast startup is disabled

Try running

sudo modprobe iwlwifi

and post the results if it errors.

1 Like

We want/need your ‘garuda-inxi’


And please check for a more recent BIOS update. They always concern hardware.


How exactly?
Which driver?

Detail your exact install procedure, if done from the terminal show input & output of all commands.

You have likely installed an inappropriate driver.


default intel driver from intel

and i just placed the .ucode in /lib/firmware

That is not the driver, that is the firmware.

This is not how it works.

then i didnt do anything other than seeing the garuda network assistant and the firmware

and as i said its Intel Wireless 8265 / 8275

do you have a link for the driver or something like that?

The driver is in the Linux kernel.

Please post:


okay so the good news is that today when i booted my laptop the wifi is working the bad news is that i dont know how it worked and the second bad news is my fingerprint sensor is not supported by libfprint

Glad to hear your wifi is now working. :+1:

This is a different issue, please open a new help request for this separate problem. We prefer each forum help request to only deal with one issue per thread. Mixing separate issues on the same thread leads to excessively long threads that are confusing and hard to follow.

Be sure to include your garuda-inxi output when opening any new help request.

Good luck with resolving your outstanding issues.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.