[Intel AX210] My Wifi cannot find any networks [SOLVED]

ok. So i'm trying to get this to work for hours but cannot. The only fix i found to work is to download 5.12 linux kernel but that kernel is so buggy for me especially when shutting down. I'm trying to get my wifi to find something but it always says that I'm disconnected. I am running dual boot with windows. My hardware is realtek rtl8111/8168/8411. I tried to blacklist 8169 but still it does not work.

Here is what inxi -Fxz says:

System:    Kernel: 5.11.15-zen1-2-zen x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: KDE Plasma 5.21.4 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: GIGABYTE product: AERO 15XV8 v: N/A serial: <filter> 
Mobo: GIGABYTE model: AERO 15XV8 serial: <filter> UEFI: American Megatrends v: FB0A 
date: 08/16/2019 
Battery:   ID-1: BAT1 charge: 16.2 Wh (17.2%) condition: 94.2/94.2 Wh (100.0%) volts: 15.6 min: 15.2 
model: GIGABYTE Aero 15 status: Charging 
CPU:       Info: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake note: check 
rev: A cache: L2: 9 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 52799 
Speed: 3935 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 3935 2: 4000 3: 4000 4: 4000 
5: 4002 6: 4001 7: 4045 8: 4051 9: 4101 10: 4098 11: 4092 12: 4049 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Gigabyte driver: i915 v: kernel bus-ID: 00:02.0 
Device-2: NVIDIA GP104M [GeForce GTX 1070 Mobile] vendor: Gigabyte driver: nvidia v: 465.24.02 
bus-ID: 01:00.0 
Device-3: Sunplus Innovation HD WebCam type: USB driver: uvcvideo bus-ID: 1-9:3 
Display: x11 server: X.Org 1.20.11 driver: loaded: intel,nvidia unloaded: modesetting,nouveau 
resolution: 1920x1080~144Hz 
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.0.2 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Gigabyte driver: snd_hda_intel v: kernel 
bus-ID: 00:1f.3 
Sound Server-1: ALSA v: k5.11.15-zen1-2-zen running: yes 
Sound Server-2: JACK v: 0.125.0 running: no 
Sound Server-3: PulseAudio v: 14.2 running: yes 
Sound Server-4: PipeWire v: 0.3.25 running: no 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: N/A 
port: 3000 bus-ID: 02:00.0 
Device-2: Intel driver: iwlwifi v: kernel port: 3000 bus-ID: 03:00.0 
IF-ID-1: enp0s20f0u2 state: unknown speed: N/A duplex: N/A mac: <filter> 
Bluetooth: Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 1-10:4 
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter> 
Device-2: Samsung GT-I9070 (network tethering USB debugging enabled) type: USB 
driver: rndis_host v: kernel bus-ID: 1-2:7 
Drives:    Local Storage: total: 1.05 TiB used: 28.13 GiB (2.6%)
ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 476.94 GiB temp: 68.8 C
ID-2: /dev/nvme1n1 vendor: Toshiba model: KXG50ZNV512G NVMe 512GB size: 476.94 GiB temp: 48.9 C
ID-3: /dev/sda type: USB vendor: Lexar model: USB Flash Drive size: 119.25 GiB
Partition: ID-1: / size: 476.68 GiB used: 28.1 GiB (5.9%) fs: btrfs dev: /dev/nvme1n1p2
ID-2: /boot/efi size: 252 MiB used: 25.4 MiB (10.1%) fs: vfat dev: /dev/nvme1n1p1
ID-3: /home size: 476.68 GiB used: 28.1 GiB (5.9%) fs: btrfs dev: /dev/nvme1n1p2
ID-4: /var/log size: 476.68 GiB used: 28.1 GiB (5.9%) fs: btrfs dev: /dev/nvme1n1p2
ID-5: /var/tmp size: 476.68 GiB used: 28.1 GiB (5.9%) fs: btrfs dev: /dev/nvme1n1p2
Swap:      ID-1: swap-1 type: zram size: 2.6 GiB used: 0 KiB (0.0%) dev: /dev/zram0
ID-2: swap-2 type: zram size: 2.6 GiB used: 0 KiB (0.0%) dev: /dev/zram1
ID-3: swap-3 type: zram size: 2.6 GiB used: 0 KiB (0.0%) dev: /dev/zram2
ID-4: swap-4 type: zram size: 2.6 GiB used: 0 KiB (0.0%) dev: /dev/zram3
ID-5: swap-5 type: zram size: 2.6 GiB used: 0 KiB (0.0%) dev: /dev/zram4
ID-6: swap-6 type: zram size: 2.6 GiB used: 0 KiB (0.0%) dev: /dev/zram5
ID-7: swap-7 type: zram size: 2.6 GiB used: 0 KiB (0.0%) dev: /dev/zram6
ID-8: swap-8 type: zram size: 2.6 GiB used: 0 KiB (0.0%) dev: /dev/zram7
ID-9: swap-9 type: zram size: 2.6 GiB used: 0 KiB (0.0%) dev: /dev/zram8
ID-10: swap-10 type: zram size: 2.6 GiB used: 0 KiB (0.0%) dev: /dev/zram9
ID-11: swap-11 type: zram size: 2.6 GiB used: 0 KiB (0.0%) dev: /dev/zram10
ID-12: swap-12 type: zram size: 2.6 GiB used: 0 KiB (0.0%) dev: /dev/zram11
Sensors:   System Temperatures: cpu: 68.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 331 Uptime: 34m Memory: 31.22 GiB used: 3.98 GiB (12.8%) Init: systemd Compilers:
gcc: 10.2.0 clang: 11.1.0 Packages: 1872 Shell: fish v: 3.2.1 inxi: 3.3.04

Here is what lspci says

00:00.0 Host bridge: Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation 6th-9th Gen Core Processor PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th/8th Gen Core Processor Gaussian Mixture Model
00:12.0 Signal processing controller: Intel Corporation Cannon Lake PCH Thermal Controller (rev 10)
00:14.0 USB controller: Intel Corporation Cannon Lake PCH USB 3.1 xHCI Host Controller (rev 10)
00:14.2 RAM memory: Intel Corporation Cannon Lake PCH Shared SRAM (rev 10)
00:16.0 Communication controller: Intel Corporation Cannon Lake PCH HECI Controller (rev 10)
00:1b.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #19 (rev f0)
00:1b.3 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #20 (rev f0)
00:1b.4 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #21 (rev f0)
00:1d.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #9 (rev f0)
00:1d.4 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #13 (rev f0)
00:1f.0 ISA bridge: Intel Corporation HM470 Chipset LPC/eSPI Controller (rev 10)
00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10)
00:1f.4 SMBus: Intel Corporation Cannon Lake PCH SMBus Controller (rev 10)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH SPI Controller (rev 10)
01:00.0 VGA compatible controller: NVIDIA Corporation GP104M [GeForce GTX 1070 Mobile] (rev a1)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 16)
03:00.0 Network controller: Intel Corporation Device 2725 (rev 1a)
04:00.0 Non-Volatile memory controller: Toshiba Corporation NVMe Controller (rev 01)
05:00.0 Non-Volatile memory controller: Toshiba Corporation Device 0116

I blacklisted driver r8169 and iwlwifi which were the drivers i was using. I've been at this for hours. If I switch to the other kernel, the wifi works but after a little while, the connection would drop and slow significantly.
I'm trying to make the wifi work with linux-zen kernel. I found a link that explains why my realtek driver doesn't really work well with linux but it's for ubuntu.

Anyone can help me out? Any help is appreciated. it's also 4am here so if i don't respond, it's cause im probably sleeping. Thanks!

edit: i also disabled MAC address randomization and installed r8168-dkms

rfkill list all

0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

is wifi LED on or off? I see there's a common issue with wifi and dual booting w10. Try going Windows device manager find your wifi device and set the option to not turn it off. Toggle wifi button/switch/bios option before booting Linux.

Your Realtek device is the ethernet card. What you linked for Realtek wireless is for other cards, not what you have. I think your wifi controller is Intel AC 8265 but you should make sure.

If that doesn't help and updated linux-firmware is not working, you can try backport-iwlwifi or another version (en:users:drivers:iwlwifi [Linux Wireless]). It solved a very similar issue for someone. Also worth checking if BIOS is up to date if nothing helps.

1 Like

That's your Ethernet adapter:

Your wifi adapter is:

Intel wifi chips will work without additional drivers, so revert any changes you have made, then make sure your wifi is physically enabled (hardware switch) and is enabled in the BIOS.


wifi and bluetooth led's are on. I tried turning on/off the wifi on Windows, disabling te wifi and forgetting all the wifi profiles. Then i toggled wifi in the bios on/off. I tried to install backport-iwlwifi but pacman can't find anything. My wifi card is an a 6E wifi card (intel AX210).

did you remove blacklists and revert all changes you made as jonathon advised?
take a look at this recent bug affecting AX210 on arch after linux-firmware update
FS#70071 : [linux-firmware] AX210 wifi card not working after last update.

Apparently a downgrade fixed the issue.

You could also try a different 5.11 kernel. Sorry I'm not sure how to troubleshoot further, but I think output of dmesg | grep iwlwifi will help others to assist you.


Please check also this workaround


Search the Arch forums there are several outstanding bugs with the AX200 - 210 series adapters. One of the fixes is to use the LTS kernel IIRC.

The fix is most likely kernel or firmware related. I would definitely test the following kernels:


It wouldn't hurt to test as many kernels as possible as a kernel change is your most likey fix.

Changing to a newer or older firmware is also a possibility. Check the Intel site for newer Linux firmware for your model. Sometimes Google also has newer developmental drivers for android phones that fix bugs before a widespread release in the linux-firmware package that is installed by default with Garuda.

Also search for special driver options you can add to /etc/modprobe.d/iwlwifi.conf.

There lots of different avenues you can search to address this from multiple different angles.

Good luck and welcome to Garuda.


I never knew that there was a problem with the AX200 series adapters. I guess the easiest/fastest solution is to change the firmware and wait it out til the zen firmware gets updated. Thank you to everyone who helped out. Cheers!

I deleted the /lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm file and it worked. Thank you!

1 Like

Thank you so much, but I'm just a curious reader (hopefully learner), which is something that increased a lot in this first arch-based experience of mine :slight_smile:


You should know that this file will be recreated with the next linux-firmware package upgrade.
It is possible that an upgrade may fix the issue, or not.
You can temporary disable re-creation of the file with a NoExtract directive in pacman.conf, or better, with a NoUpgrade directive (this will install the file as .pacnew file, so you may test from time to time if the issue is fixed).

Read more:


Installing the newest firmware or newest kernels with the fix already included (if available) would be the best solution. The method selected as a solution is a workaround at best.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.