Intel 3165 WiFi adapter - Improve Performance

Hi, I have really bad Wi-Fi at home, how can I improve my Wi-Fi adapter?
I have Intel Wireless 3165

@tbg Thank you to this offer from kernel discussion.

Please post:

inxi -Fxxxza
1 Like
> [soong@sngoong-dell ~]$ inxi -Fxxxza
> System:    Kernel: 5.12.0-8-cacule x86_64 bits: 64 compiler: gcc v: 10.2.0 
>            parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-cacule root=UUID=db4c0d18-b815-4ee7-b1d2-359b6f5ba242 rw 
>            rootflags=subvol=@ quiet 
>            cryptdevice=UUID=32ab6f7e-6dd0-4bab-acb3-0b09fdc2980e:luks-32ab6f7e-6dd0-4bab-acb3-0b09fdc2980e 
>            root=/dev/mapper/luks-32ab6f7e-6dd0-4bab-acb3-0b09fdc2980e splash rd.udev.log_priority=3 vt.global_cursor_default=0 
>            systemd.unified_cgroup_hierarchy=1 loglevel=3 
>            Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda Linux base: Arch Linux 
> Machine:   Type: Laptop System: Dell product: Inspiron 15 7000 Gaming v: N/A serial: <filter> Chassis: type: 10 
>            serial: <filter> 
>            Mobo: Dell model: 065C71 v: A00 serial: <filter> UEFI: Dell v: 1.10.0 date: 05/17/2019 
> CPU:       Info: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
>            stepping: 9 microcode: DE cache: L2: 6 MiB 
>            flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44798 
>            Speed: 3491 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 3491 2: 3457 3: 3429 4: 3401 5: 3417 6: 3403 7: 3483 
>            8: 3400 
>            Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
>            Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
>            Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
>            Type: meltdown mitigation: PTI 
>            Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
>            Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
>            Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
>            Type: srbds mitigation: Microcode 
>            Type: tsx_async_abort status: Not affected 
> Graphics:  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:591b 
>            class-ID: 0300 
>            Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Dell driver: nvidia v: 465.27 
>            alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1c8c class-ID: 0300 
>            Device-3: Realtek Integrated Webcam type: USB driver: uvcvideo bus-ID: 1-12:4 chip-ID: 0bda:568a class-ID: 0e02 
>            serial: <filter> 
>            Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: intel,nvidia unloaded: modesetting,nouveau 
>            alternate: fbdev,nv,vesa display-ID: :0 screens: 1 
>            Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
>            Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
>            OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 21.0.3 direct render: Yes 
> Audio:     Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a171 
>            class-ID: 0403 
>            Sound Server-1: ALSA v: k5.12.0-8-cacule running: yes 
>            Sound Server-2: JACK v: 1.9.18 running: no 
>            Sound Server-3: PulseAudio v: 14.2 running: no 
>            Sound Server-4: PipeWire v: 0.3.26 running: yes 
> Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8169 v: kernel port: d000 
>            bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 
>            IF: enp2s0 state: down mac: <filter> 
>            Device-2: Intel Wireless 3165 driver: iwlwifi v: kernel port: d000 bus-ID: 03:00.0 chip-ID: 8086:3165 
>            class-ID: 0280 
>            IF: wlp3s0 state: up mac: <filter> 
> Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-4:3 chip-ID: 8087:0a2a 
>            class-ID: e001 
>            Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block: hardware: no software: yes 
>            address: <filter> 
> RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: f060 bus-ID: 00:17.0 
>            chip-ID: 8086.282a rev: 31 class-ID: 0104 
> Drives:    Local Storage: total: 931.51 GiB used: 66.82 GiB (7.2%) 
>            SMART Message: Required tool smartctl not installed. Check --recommends 
>            ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM049-2GH172 size: 931.51 GiB block-size: physical: 4096 B 
>            logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: SDM1 scheme: GPT 
> Partition: ID-1: / raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 66.82 GiB (7.2%) fs: btrfs dev: /dev/dm-0 
>            maj-min: 254:0 mapped: luks-32ab6f7e-6dd0-4bab-acb3-0b09fdc2980e 
>            ID-2: /boot/efi raw-size: 256 MiB size: 252 MiB (98.46%) used: 682 KiB (0.3%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
>            ID-3: /home raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 66.82 GiB (7.2%) fs: btrfs dev: /dev/dm-0 
>            maj-min: 254:0 mapped: luks-32ab6f7e-6dd0-4bab-acb3-0b09fdc2980e 
>            ID-4: /var/log raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 66.82 GiB (7.2%) fs: btrfs dev: /dev/dm-0 
>            maj-min: 254:0 mapped: luks-32ab6f7e-6dd0-4bab-acb3-0b09fdc2980e 
>            ID-5: /var/tmp raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 66.82 GiB (7.2%) fs: btrfs dev: /dev/dm-0 
>            maj-min: 254:0 mapped: luks-32ab6f7e-6dd0-4bab-acb3-0b09fdc2980e 
> Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100) 
>            ID-1: swap-1 type: zram size: 977.9 MiB used: 301.8 MiB (30.9%) priority: 32767 dev: /dev/zram0 
>            ID-2: swap-2 type: zram size: 977.9 MiB used: 302.8 MiB (31.0%) priority: 32767 dev: /dev/zram1 
>            ID-3: swap-3 type: zram size: 977.9 MiB used: 303.1 MiB (31.0%) priority: 32767 dev: /dev/zram2 
>            ID-4: swap-4 type: zram size: 977.9 MiB used: 304.8 MiB (31.2%) priority: 32767 dev: /dev/zram3 
>            ID-5: swap-5 type: zram size: 977.9 MiB used: 305.5 MiB (31.2%) priority: 32767 dev: /dev/zram4 
>            ID-6: swap-6 type: zram size: 977.9 MiB used: 303.1 MiB (31.0%) priority: 32767 dev: /dev/zram5 
>            ID-7: swap-7 type: zram size: 977.9 MiB used: 303.4 MiB (31.0%) priority: 32767 dev: /dev/zram6 
>            ID-8: swap-8 type: zram size: 977.9 MiB used: 301.7 MiB (30.8%) priority: 32767 dev: /dev/zram7 
> Sensors:   System Temperatures: cpu: 65.0 C mobo: 43.0 C sodimm: SODIMM C 
>            Fan Speeds (RPM): cpu: 3651 
> Info:      Processes: 312 Uptime: 8h 18m wakeups: 9 Memory: 7.64 GiB used: 4.87 GiB (63.7%) Init: systemd v: 248 
>            tool: systemctl Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1433 lib: 487 Shell: Bash v: 5.1.4 
>            running-in: konsole inxi: 3.3.04

If you include terminal outputs in your post please use the proper output format in your post. Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.

1 Like

@Soong Did you have better performance before you installed Garuda or has it always been bad wireless signal with Linux? Was it better with Widows? Have you done anything on your end to troubleshoot this? What have you done? What is the output?

Your initial post requires a lot of divination to figure out a possible solution. Thanks!

There is your problem if you have bad wi-fi at home i is you ISP's fault.

I was hoping I could help you improve your wifi performance, but this is a rather poor adapter that is no longer supported by Intel. There is a chance that you may be able to improve the performance somewhat by testing different driver options.

Sadly many people don't get a lot of improvement, but you can try this:

Create the driver options configuration file:

/etc/modprobe.d/iwlwifi.conf

With the following content:

options iwlwifi 11n_disable=1 
options iwlwifi swcrypto=1
options iwlwifi power_save=0 
options iwlwifi d0i3_disable=0 
options iwlwifi uapsd_disable=0

Save the conf file, and exit text editor.

Then reboot.

If there is no improvement after creating the options file then you can delete the conf file (and consider buying a replacement adapter).

Best of luck.

4 Likes

Thank you! I'll try that. Anyway I have USB TP link w722n, I can try it too.
Edit: Hehe I could play Xonotic better. :smiley:

1 Like

So, the new driver options file improved your your wifi's performance somewhat?

If so, that's good.

Glad that I could help.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.